No documents are returned in the search results when a user searches for Lotus Notes content in SharePoint Server 2007

Article translations Article translations
Article ID: 933939 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

Consider the following scenario. You configure Microsoft Office SharePoint Server 2007 to crawl an IBM Lotus Notes database. In this configuration, Microsoft Windows domain user accounts are mapped to Lotus Notes user IDs. A user logs on to SharePoint Server 2007. Then, the user searches for Lotus Notes content. In this scenario, no documents are returned in the search results.

This problem occurs even though the following conditions are true:
  • The documents exist in the Lotus Notes database.
  • The user has at least Reader permissions to the documents.
  • SharePoint Server 2007 successfully crawls the Lotus Notes database.

CAUSE

This problem occurs if the following conditions are true:
  • The documents are set to the "All readers and above" permission.
  • The template on which the Lotus Notes database is based does not use an Author field.
In this scenario, the Lotus Notes protocol handler incorrectly processes the permissions for the document.

RESOLUTION

How to obtain the hotfix

This issue is fixed in the SharePoint Server 2007 Hotfix Package that is dated April 12, 2007. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
934793 Description of the SharePoint Server hotfix package: April 12, 2007

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Properties

Article ID: 933939 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Office SharePoint Server 2007
Keywords: 
kbqfe kbbug kbfix kbexpertiseinter KB933939

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com