Article ID: 934004 - Last Review: November 15, 2007 - Revision: 1.2

Some Japanese characters are not written to the Stdout file when you run shell scripts that process MBCS Japanese characters by using a Korn shell in Windows Services for UNIX 3.5

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SYMPTOMS

Consider the following scenario. You run shell scripts that process multibyte character set (MBCS) Japanese characters in Microsoft Windows Services for UNIX 3.5. The shell scripts are processed by using a Korn shell. In this scenario, some Japanese characters in the shell scripts are not written to the Stdout file. You may also receive an error message that resembles the following.
Error message 1
no closing double quotation
Error message 2
no closing back quotation

CAUSE

This problem occurs because an MBCS character is treated as single-byte character set (SBCS) characters at a specific point in the Korn shell. For example, the Japanese double byte character "955C" is interpreted separately as "95" and "5C" single byte characters in the Korn shell. Additionally, the double quotation mark character followed by the Japanese double-byte character set (DBCS) is interpreted as a backslash. The Japanese double-byte character "8360" is interpreted separately as "83" and "60." In this case, "60" is interpreted as a closing quotation mark.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows Services for UNIX 3.5 installed on the computer.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile sizeDateTimePath
Ksh307,71217-Apr-200706:02sfu35-kb934004-x86-enu\sfu35eng

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Windows Services for UNIX 3.5
Keywords: 
kbautohotfix kbexpertiseadvanced kbbug kbfix kbhotfixserver kbqfe kbtshoot KB934004
 

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