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Error message in Windows Vista when you try to rename a new subfolder in a shared folder on the network: "The <SharedFolderName> folder does not exist"

Article ID:934160
Last Review:November 5, 2007
Revision:4.4

SYMPTOMS

In Windows Vista, after you create a subfolder in a shared folder on a network, you receive the following error message when you try to rename the new subfolder:
The SharedFolderName folder does not exist. The file may have been moved or deleted.

Do you want to create it?
The message incorrectly states that the shared folder does not exist.

Additionally, if you save a file to the shared folder on a network, you may receive the following error message:
There has been a network or file permission error. The network connection may be lost.

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CAUSE

This issue occurs if the following conditions are true:
Windows Vista was deployed to the computer from an image by using the Microsoft Systems Management Server (SMS) 2003 Operating System Deployment (OSD) Feature Pack Update.
The client-side cache database that the Offline Files feature uses was corrupted when Windows Vista was deployed.

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WORKAROUND

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 (http://support.microsoft.com/kb/322756/) How to back up and restore the registry in Windows


To work around this issue, add the FormatDatabase registry entry to the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters
Then, set the FormatDatabase registry entry to 1.

To do this, follow these steps:
1.Click StartStart button, type regedit in the Start Search box, and then click regedit in the Programs list.

 User Account Control permission
				If you are prompted for an administrator password or confirmation, type your password or click Continue.
2.Locate and then click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc\Parameters
Note If the Parameters subkey does not exist, create it. To do this, follow these steps:
a. Click the following registry subkey:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Csc
b. On the Edit menu, point to New, and then click Key.
c. Type Parameters, and then press ENTER.
3.On the Edit menu, point to New, and then click DWORD Value.
4.Type FormatDatabase, and then press ENTER.
5.On the Edit menu, click Modify.
6.Type 1 in the Value data box, and then click OK.
7.Exit Registry Editor, and then restart the computer.

Scenarios in which to apply the workaround

Apply this workaround in scenarios that resemble the following:
For an image that you are currently deploying, apply this workaround in a custom action in the state restore phase. This procedure requires that you restart the computer.
For an image that you have already deployed, apply this workaround. This procedure requires that you restart the computer.
For a new image, apply this workaround and then restart the computer. Create the image after you restart the computer and before you configure network connections.
You can also apply this workaround to the registry of a Microsoft Windows Imaging Format (WIM) image file. To do this, use the ImageX.exe tool that is included in the Windows Automated Installation Kit (AIK). For more information about Windows AIK, visit the following Microsoft Web site:
http://technet2.microsoft.com/WindowsVista/en/library/129a1712-e3d8-46c1-bc09-a14349dc67db1033.mspx?mfr=true (http://technet2.microsoft.com/WindowsVista/en/library/129a1712-e3d8-46c1-bc09-a14349dc67db1033.mspx?mfr=true)
For more information about the ImageX.exe tool and WIM image format in Windows Vista, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/windowsvista/aa905070.aspx (http://technet.microsoft.com/en-us/windowsvista/aa905070.aspx)
One possible advantage of using this procedure is that you do not have to create a new image. Additionally, you do not have to restart the computer.

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MORE INFORMATION

For more information about the SMS 2003 OSD Feature Pack Update, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/sms/bb676770.aspx (http://technet.microsoft.com/en-us/sms/bb676770.aspx)

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APPLIES TO
Windows Vista Home Basic
Windows Vista Home Premium
Windows Vista Ultimate
Windows Vista Business
Windows Vista Enterprise
Windows Vista Home Basic 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Business 64-bit Edition
Windows Vista Enterprise 64-bit Edition
Windows Vista Starter
Microsoft Systems Management Server 2003

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Keywords: 
kbtshoot kbexpertiseinter kbprb KB934160

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