Un message électronique est remis pas une bibliothèque de documents et 6874 ID événement est enregistré lorsque vous utilisez Forefront Security pour SharePoint

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important Cet article contient des informations sur la modification du Registre. Assurez-vous de sauvegarder le Registre avant de le modifier. Vérifiez que vous connaissez comment restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322756 Comment faire pour sauvegarder et restaurer le Registre dans Windows
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Symptômes

Envisagez le scénario suivant :
  • Une batterie de serveurs Microsoft Office SharePoint Server 2007 s'exécute sur un serveur. Autres applications sont exécutent sur un autre serveur.
  • Fonctionnalité de courrier électronique entrant est activée pour une bibliothèque de documents Microsoft Windows SharePoint Services.
  • Sur un serveur de services Internet (IIS), vous utilisez Microsoft Forefront Security pour SharePoint pour analyser les messages électroniques de courrier électronique non sollicité (courrier électronique non SOLLICITÉ). Courrier électronique non SOLLICITÉ est également appelée spam.
Dans ce scénario, lorsque vous envoyez un message électronique à la bibliothèque de documents, vous rencontrez les problèmes suivants :
  • Le message électronique est remis pas à la bibliothèque de documents.
  • L'ID d'événement 6874 est enregistré dans le journal des applications avec la description suivante :

    Une erreur s'est une produite lors de la tentative créer un pièces jointes d'éléments envoyés par courrier électronique.

    note Cette entrée de journal doit commencer comme « une erreur s'est produite. »

Cause

Ce problème se produit car le processus FSCRealtimeScanner.exe de Forefront Security pour SharePoint s'exécute sous le compte service réseau. Cette configuration est par défaut. Par conséquent, le processus FSCRealtimeScanner.exe n'a pas accès au service SPSTimer.

Contournement

Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller le système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.

Pour contourner ce problème, configurer le processus FSCRealtimeScanner.exe pour s'exécuter sous le compte système local. Pour ce faire, utilisez définissez l'entrée de Registre LegacyScanAccount 1 (un). Pour configurer cette entrée de Registre, procédez comme suit :
  1. Arrêtez le service FSCController. Une fois que vous arrêtez ce service, démarrez le Gestionnaire des tâches Windows et puis vérifiez que les processus suivants n'apparaissent pas dans la liste des processus en cours d'exécution :
    • FSCController.exe
    • FSCRealtimeScanner.exe
  2. Démarrez une invite de commandes. Pour ce faire, cliquez sur Démarrer , cliquez sur Exécuter , tapez cmd , puis cliquez sur OK .
  3. À l'invite de commandes, tapez iisreset /stop et puis appuyez sur ENTRÉE.
  4. À l'invite de commandes, tapez net stop sptimerv3 et puis appuyez sur ENTRÉE.
  5. Modifier le Registre. Pour cela, appliquez l'une des opérations suivantes, selon la version de Windows que vous exécutez :
    • Pour les versions 32 bits de Windows, procédez comme suit :
      1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
      2. Recherchez et cliquez ensuite la sous-clé de Registre suivante :
        HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Forefront Server Security\SharePoint
      3. Cliquez avec le bouton droit sur une zone vide dans le volet de détails, pointez sur Nouveau et puis cliquez sur valeur DWORD .
      4. Tapez LegacyScanAccount et puis appuyez sur ENTRÉE pour nommer la nouvelle entrée de Registre.
      5. Cliquez avec le bouton droit sur LegacyScanAccount , puis cliquez sur Modifier .
      6. Dans la zone données de la valeur , tapez 1 (un) et puis cliquez sur OK .
    • Pour les versions 64 bits de Windows, procédez comme suit :
      1. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
      2. Recherchez et cliquez ensuite la sous-clé de Registre suivante :
        HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Forefront Server Security\SharePoint\
      3. Cliquez avec le bouton droit sur une zone vide dans le volet de détails, pointez sur Nouveau et puis cliquez sur valeur DWORD .
      4. Tapez LegacyScanAccount et puis appuyez sur ENTRÉE pour nommer la nouvelle entrée de Registre.
      5. Cliquez avec le bouton droit sur LegacyScanAccount , puis cliquez sur Modifier .
      6. Dans la zone données de la valeur , tapez 1 (un) et puis cliquez sur OK .
  6. Quittez l'Éditeur du Registre.
  7. À l'invite de commandes, tapez net start sptimerv3 et puis appuyez sur ENTRÉE.
  8. À l'invite de commandes, tapez iisreset /start et puis appuyez sur ENTRÉE.
  9. Envoyer un message de courrier électronique test à la bibliothèque de documents. Le processus FSCRealtimeScanner.exe doit s'exécuter maintenant sous le compte système local lorsque vous envoyez le message électronique à la bibliothèque de documents.

Propriétés

Numéro d'article: 934285 - Dernière mise à jour: mardi 20 novembre 2007 - Version: 2.1
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Forefront Security for SharePoint
Mots-clés : 
kbmt kbspam kbregistry kbtshoot kbprb KB934285 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 934285
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