ID do artigo: 934376 - Última revisão: sexta-feira, 28 de dezembro de 2007 - Revisão: 1.2

Não é possível usar um aplicativo FTP para carregar um arquivo em um servidor remoto de um computador que tenha o Internet Explorer 7 instalado

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Recolher tudo

Sintomas

Em um computador que tenha o Windows Internet Explorer 7 instalado, não é possível usar um aplicativo FTP para carregar um arquivo em um servidor remoto.

Esse problema ocorre se o aplicativo estiver com base em funções WinINet FTP.

Causa

Esse problema ocorre devido à violação de acesso que é causada pela função InternetWriteFile do WinINet API.

Ao usar um aplicativo com base em funções WinINet FTP para carregar um arquivo para um servidor remoto, o arquivo remoto é criado, usando o comando FTP APPE. Porém, quando o sistema operacional tenta usar a função InternetWriteFile para gravar o arquivo, ocorre a violação de acesso.

Resolução

Informações sobre o hotfix para Windows Vista

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://support.microsoft.com/gp/CUHotFix_LandingPage_Request (http://go.microsoft.com/?linkid=6294451)
Observação Se outros problemas ocorrerem ou se uma solução de problema for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Pré-requisitos

Não há pré-requisitos.

Necessidade de reinicialização

É necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações do Registro

Não faça nenhuma alteração no Registro.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
Versões de 32 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Update.mumNão aplicável2.03310.07.200713:47Não aplicável
X86_868285fffb13074270db1e1d2146dd4a_31bf3856ad364e35_6.0.6000.20636_none_b841a7b1fddd39b2.manifestNão aplicável72610.07.200713:47Não aplicável
X86_microsoft-windows-i..tocolimplementation_31bf3856ad364e35_6.0.6000.20636_none_0071e1b4bddd0f75.manifestNão aplicável56.60210.07.200713:54Não aplicável
Jsproxy.dll7.0.6000.2063627.64810.07.200702:24x86
Wininet.dll7.0.6000.20636824.32010.07.200702:26x86
Wininetplugin.dll1.0.0.164.51210.07.200702:26x86
Versões de 64 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Amd64_868285fffb13074270db1e1d2146dd4a_31bf3856ad364e35_6.0.6000.20636_none_14604335b63aaae8.manifestNão aplicável72810.07.200713:47Não aplicável
Amd64_eee29d13daf15ad6ce18038e216c02dd_31bf3856ad364e35_6.0.6000.20636_none_16896adf06be2c5b.manifestNão aplicável73010.07.200713:47Não aplicável
Amd64_microsoft-windows-i..tocolimplementation_31bf3856ad364e35_6.0.6000.20636_none_5c907d38763a80ab.manifestNão aplicável56.67610.07.200713:57Não aplicável
Package_1_for_kb934376~31bf3856ad364e35~amd64~~6.0.1.0.mumNão aplicável1.82510.07.200713:47Não aplicável
Package_2_for_kb934376~31bf3856ad364e35~amd64~~6.0.1.0.mumNão aplicável2.04410.07.200713:47Não aplicável
Update.mumNão aplicável1.92510.07.200713:47Não aplicável
Jsproxy.dll7.0.6000.2063632.25610.07.200703:20x64
Wininet.dll7.0.6000.206361.021.95210.07.200703:22x64
Wininetplugin.dll1.0.0.193.18410.07.200703:22x64

Informações sobre o hotfix para Windows Server 2003

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://support.microsoft.com/gp/CUHotFix_LandingPage_Request (http://go.microsoft.com/?linkid=6294451)
Observação Se outros problemas ocorrerem ou se uma solução de problema for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Pré-requisitos

Para aplicar esse hotfix, é necessário ter o Windows Server 2003 Service Pack 2 (SP2) instalado.

Necessidade de reinicialização

É necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações do Registro

Não faça nenhuma alteração no Registro.

Informações sobre o arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
Windows Server 2003 com SP2 em versões com base em x86
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Wininet.dll7.0.6000.20636824.32014-jul-200705:58x86
Windows Server 2003 com SP2 em versões com base em x64
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataformaRequisito de SPRamificação do serviço
Wininet.dll7.0.6000.206361.021.95213-jul-200715:46x64SP2Não aplicável
Wwininet.dll7.0.6000.20636824.32013-jul-200715:46x86SP2WOW
Windows Server 2003 com SP2 em versões com base em Itanium
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataformaRequisito de SPRamificação do serviço
Wininet.dll7.0.6000.206361.861.12013-jul-200715:45IA-64SP2Não aplicável
Wwininet.dll7.0.6000.20636824.32013-jul-200715:45x86SP2WOW

Informações sobre o hotfix para Windows XP

Um hotfix compatível foi disponibilizado pela Microsoft. No entanto, esse hotfix destina-se a corrigir somente o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Testes adicionais podem ser realizados nesse hotfix. Portanto, se esse problema não o prejudicar seriamente, é recomendável que você aguarde o próximo service pack que contenha esse hotfix.

Para resolver esse problema, envie uma solicitação para o Atendimento ao Cliente Online Microsoft para obter o hotfix. Para enviar a solicitação online para obter o hotfix, visite o seguinte site da Microsoft:
http://support.microsoft.com/gp/CUHotFix_LandingPage_Request (http://go.microsoft.com/?linkid=6294451)
Observação Se outros problemas ocorrerem ou se uma solução de problema for requisitada, pode ser necessário criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem a esse hotfix. Para criar uma solicitação de serviço separada, visite o seguinte site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Pré-requisitos

Para aplicar esse hotfix, é necessário ter o Windows XP Service Pack 2 (SP2) instalado.

Necessidade de reinicialização

É necessário reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui nenhum outro.

Informações do Registro

Não faça nenhuma alteração no Registro.

Informações do arquivo

A versão em inglês desse hotfix tem os atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horários destes arquivos estão listados em formato UTC (Tempo Universal Coordenado). Ao exibir as informações sobre o arquivo, elas são convertidas para a hora local. Para localizar a diferença entre o UTC e a hora local, use a guia Fuso horário no item Data e hora do Painel de Controle.
Recolher esta tabelaExpandir esta tabela
Nome do arquivoVersão do arquivoTamanho do arquivoDataHoraPlataforma
Wininet.dll7.0.6000.20636824.32012.07.200713:16x86

Situação

A Microsoft confirmou que este é um problema nos produtos Microsoft que estão listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre a função InternetWriteFile visite o seguinte site da Microsoft (em inglês):
http://msdn2.microsoft.com/en-us/library/aa385128.aspx (http://msdn2.microsoft.com/en-us/library/aa385128.aspx)
Para uma lista de todas as funções WinINet, visite o seguinte site da Microsoft (em inglês):
http://msdn2.microsoft.com/en-us/library/aa385473.aspx (http://msdn2.microsoft.com/en-us/library/aa385473.aspx)
Para uma lista de exemplos WinInet FTP API , clique no número abaixo para exibir o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
289253  (http://support.microsoft.com/kb/289253/ ) Lista de exemplos Wininet FTP API
Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para exibir o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
824684  (http://support.microsoft.com/kb/824684/LN/ ) Descrição da terminologia padrão usada para descrever as atualizações de software da Microsoft

A informação contida neste artigo aplica-se a:
  • Windows Internet Explorer 7 in Windows Vista
  • Windows Internet Explorer 7 for Windows Server 2003
  • Windows Internet Explorer 7 for Windows Server 2003 IA64
  • Windows Internet Explorer 7 for Windows XP
Palavras-chave: 
kbvistasp1fix kbexpertisebeginner kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB934376