Article ID: 934380 - Last Review: April 2, 2007 - Revision: 1.0

The Backup SMS Site Server maintenance task logs an "Unable to verify installation" error in SMS 2003

Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Description of the Microsoft Windows registry
Expand all | Collapse all

SYMPTOMS

After you enable the Backup SMS Site Server maintenance task and after you configure it to back up a Microsoft Systems Management Server 2003 site, you experience the following symptoms:
  • The Backup SMS Site Server task logs the following errors in the Smsbkup.log file:
    SMS site backup service 2.50 started.
    STATMSG: ID=500 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_SITE_BACKUP" SYS= <Servername> SITE=<Site> PID=2904 TID=1384 GMTDATE=<date and time> ISTR0="SMS site backup" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0
    STATMSG: ID=5029 SEV=W LEV=M SOURCE="SMS Server" COMP="SMS_SITE_BACKUP" SYS= <Servername>..
    Unable to verify installation for SMS_SQL_MONITOR_<Servername> on \\ <Servername>.   So this Service will not be started or stopped
    Note This log file is created in the backup destination location that was specified when the Backup SMS Site Server maintenance task was enabled.
  • After the Backup SMS Site Server task runs, the SMS Site Component Manager uninstalls SMS components, and then it re-installs them. This action is recorded in the Sitecomp.log file as follows:
    Reinstalling component SMS_EXECUTIVE...	SMS_SITE_COMPONENT_MANAGER	<date and time>	8100 (0x1FA4)
    STATMSG: ID=1018 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_EXECUTIVE" SYS= <Servername> SITE=<Sitecode> PID=5880 TID=8100 GMTDATE=<date and time> 2006 ISTR0="" ISTR1="" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=0	
    Stopped.	SMS
    Deinstalled the performance counters.	
    Deinstalled as service SMS_EXECUTIVE.	
    Starting bootstrap operations...	
    Installed service SMS_SERVER_BOOTSTRAP_ <Servername>.	
    Starting service SMS_SERVER_BOOTSTRAP_ <Servername> with command-line arguments "<Sitecode> <drive>:\SMS /deinstall                        
    	<drive>:\SMS\bin\i386\smsexecd.exe"...	)
    "<drive>:\SMS\bin\i386\smsexecd.exe /deinstall /siteserver: <Servername> " executed successfully on server <Servername>.	
    Bootstrap operation successful.	
    Deinstalled service SMS_SERVER_BOOTSTRAP_s <Servername>.	
    Bootstrap operations completed.	
    Writing component specific registry values.	
    The "C:\WINDOWS" directory has 24764649472 bytes free out of 33548677120 total bytes.
     The component is being installed on the site server, no files need to be installed in the "<drive>:\SMS" directory because the files are already there.	
    7865009 bytes are required in the "C:\WINDOWS" directory for this component's files.	
    Installed file C:\WINDOWS\system32\smsmsgs\srvmsgs.cmd.	
    Installed file C:\WINDOWS\system32\smsmsgs\climsgs.cmd.	
    Installed file C:\WINDOWS\system32\smsmsgs\provmsgs.cmd.	
    All files installed.	
    Note This log file is located in the SMS\Logs folder.

CAUSE

This problem occurs if the entries that specify the SMS 2003 server name in the Windows registry and in the SiteCtrl.ct0 file use lowercase characters instead of uppercase characters.

Note By default, these entries specify the server name by using uppercase characters. However, if you perform an unattended installation of SMS 2003, you may specify the server name by using lowercase characters.

RESOLUTION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

To resolve this problem, manually change the server name entries in the registry and in the SiteCtrl.ct0 file to use uppercase characters. To do this, follow these steps:
  1. Start Registry Editor. To do this, click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ComputerName\ComputerName
  3. In the details pane, right-click ComputerName, and then click Modify.
  4. Change the entry in the Value data box to use uppercase characters, and then click OK.
  5. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ComputerName\ActiveComputerName
  6. In the details pane, right-click ComputerName, and then click Modify.
  7. Change the entry in the Value data box to use uppercase characters, and then click OK.
  8. Locate and then click the following registry subkey:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS
  9. Under the SMS registry subkey, expand each registry key, and then modify each registry entry that specifies the server name by using lowercase characters. For each of these registry entries, change the server name to use uppercase characters.
  10. Exit Registry Editor.
  11. Start Windows Explorer, and then locate the SMS\Inboxes\Sitectrl.box\Sitectrl.ct0 file.
  12. Open this file by using a text editor such as Notepad.
  13. In this file, locate each entry that specifies the server name by using lowercase characters, and then replace the lowercase characters with the corresponding uppercase characters. To do this, you may want to use the Replace command in Notepad together with the Match case check box.
  14. Stop the SMS_EXECUTIVE service.
  15. Save the changes to the Sitectrl.ct0 file, and then exit the text editor.
  16. Start the SMS_EXECUTIVE service.

MORE INFORMATION

The Backup SMS Site Server task generates errors, and the SMS Site Component Manager program re-installs components if the following conditions are true:
  • The Backup SMS Site Server task determines that the SMS_SQL_Monitor service is located on a remote computer.
  • The SMS_SQL_Monitor service is located on the local site server computer.
The SMS backup task makes this incorrect determination if the value for the Site Server registry entry in the following registry subkey is specified in lowercase characters:
HKEY_LOCAL_MACHINE\Software\Microsoft\SMS\Identification

APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbtshoot kbprb KB934380
 

Article Translations

 

Related Support Centers