The "Allow hybrid sleep" option is intermittently missing from the Advanced Settings tab of the Power Options dialog box in Windows Vista

Article translations Article translations
Article ID: 934429 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You experience the following symptoms on a computer that is running Windows Vista:
  • The Allow hybrid sleep option is missing from the Advanced settings tab of the Power Options dialog box in Windows Vista.
  • When you run the powercfg.exe -a command to list the power states that are supported on the computer, the output that appears includes the following lines:
    The system firmware does not support this standby state.
    Hybrid Sleep
These symptoms occur intermittently. When you restart the computer, the Allow hybrid sleep option reappears. Additionally, when you run the powercfg.exe -a command again, the output that appears includes a line that resembles the following:
The following sleep states are available on this system: Hybrid Sleep

CAUSE

This problem occurs in scenarios where a race condition exists between the Monitor.sys driver and a kernel setting.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Update.mumNot applicable1,99617-Apr-200717:25Not applicable
X86_38842e8a9920e87789f15cf51c83f457_31bf3856ad364e35_6.0.6000.20580_none_2f7466c1b5f35f7a.manifestNot applicable69717-Apr-200717:25Not applicable
X86_microsoft-windows-os-kernel_31bf3856ad364e35_6.0.6000.20580_none_6a7d3c99d05b067b.manifestNot applicable18,77817-Apr-200717:27Not applicable
Ntkrnlpa.exe6.0.6000.205803,504,31217-Apr-200702:37Not applicable
Ntoskrnl.exe6.0.6000.205803,469,49617-Apr-200702:37Not applicable
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_c3962e8cefe18a3d9bff5b6e3518e8b0_31bf3856ad364e35_6.0.6000.20580_none_f3bf013ca2ba0f1d.manifestNot applicable70117-Apr-200717:25Not applicable
Amd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.0.6000.20580_none_c69bd81d88b877b1.manifestNot applicable17,33017-Apr-200717:31Not applicable
Update.mumNot applicable2,00817-Apr-200717:25Not applicable
Ntoskrnl.exe6.0.6000.205804,431,03217-Apr-200703:54x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about the Powercfg.exe tool in Windows Vista, visit the following Microsoft Web site:
http://technet2.microsoft.com/WindowsVista/en/library/dc8e252e-b7d7-46af-b946-e118b39cae371033.mspx?mfr=true
For more information about terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 934429 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Starter
Keywords: 
kbautohotfix kbvistasp1fix kbwinvistapostrtmfix kbbug kbfix kbHotfixServer kbqfe kbexpertiseinter KB934429

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com