A "Web Services on Devices"-based printer appears as Offline after you wake a Windows Vista-based computer from sleep

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Article ID: 934455 - View products that this article applies to.
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SYMPTOMS

You install a "Web Services on Devices" (WSD)-based printer on a computer that is running Windows Vista. After you do this, you put the computer to sleep, and then you wake it from sleep. However, when you view the Printers item in Control Panel, the status of the WSD-based printer appears as Offline. You expect the printer to resume online when you wake the computer from sleep.

CAUSE

This problem occurs because of a timing issue that causes a race condition in the WSDMON port monitor. The race condition prevents the WSDMON port monitor from updating the status of the printer.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable2,44211-Apr-200714:24Not Applicable
X86_9aa1a7483f3a2306e7be4d0e4fe57004_31bf3856ad364e35_6.0.6000.20576_none_bb045f2f8144f11a.manifestNot Applicable67911-Apr-200714:24Not Applicable
X86_fc15dca3ada4534c64e4ee18ba6dc0f2_31bf3856ad364e35_6.0.6000.20576_none_0eb6c53d3914bf9c.manifestNot Applicable71111-Apr-200714:24Not Applicable
X86_ipbusenum_31bf3856ad364e35_6.0.6000.20576_none_68623cff7d45a5d5.manifestNot Applicable19,75311-Apr-200714:26Not Applicable
X86_microsoft-windows-p..ting-wsdportmonitor_31bf3856ad364e35_6.0.6000.20576_none_1530f0cefbc3b183.manifestNot Applicable8,87211-Apr-200714:26Not Applicable
Ipbusenum.dll6.0.6000.2057674,75211-Apr-200706:31x86
Ipbusenum.mofNot Applicable67207-Jan-200705:51Not Applicable
Wsdmon.dll6.0.6000.20576151,04011-Apr-200706:33x86
Windows Vista, 64-bit versions
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File nameFile versionFile sizeDateTimePlatform
Amd64_70cbc6adb7b031d1505565d20b96ed30_31bf3856ad364e35_6.0.6000.20576_none_63931c196f28e082.manifestNot Applicable1,07011-Apr-200714:24Not Applicable
Amd64_8e5219495db82517e451e2da7674c141_31bf3856ad364e35_6.0.6000.20576_none_b4c3646530656fd2.manifestNot Applicable68311-Apr-200714:24Not Applicable
Amd64_ipbusenum_31bf3856ad364e35_6.0.6000.20576_none_c480d88335a3170b.manifestNot Applicable20,01511-Apr-200714:30Not Applicable
Amd64_microsoft-windows-p..ting-wsdportmonitor_31bf3856ad364e35_6.0.6000.20576_none_714f8c52b42122b9.manifestNot Applicable8,90011-Apr-200714:30Not Applicable
Update.mumNot Applicable2,68511-Apr-200714:24Not Applicable
X86_microsoft-windows-p..ting-wsdportmonitor_31bf3856ad364e35_6.0.6000.20576_none_1530f0cefbc3b183.manifestNot Applicable8,87211-Apr-200714:30Not Applicable
Ipbusenum.dll6.0.6000.2057693,69611-Apr-200707:43x64
Ipbusenum.mofNot Applicable67207-Jan-200705:51Not Applicable
Wsdmon.dll6.0.6000.20576180,22411-Apr-200707:46x64
Wsdmon.dll6.0.6000.20576151,04011-Apr-200706:33x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 934455 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Ultimate
  • Windows Vista Enterprise
  • Windows Vista Business
  • Windows Vista Home Premium
  • Windows Vista Home Basic
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Starter
Keywords: 
kbautohotfix kbvistasp1fix kbbug kbfix kbHotfixServer kbqfe kbexpertiseinter kbwinvistapostrtmfix KB934455

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