Virhe: Koodi 0x80240029 -virhesanoma tulee näyttöön yritettäessä päivittää Windows Vista -tietokoneen Windows Defender -ohjelma

Artikkeleiden käännökset Artikkeleiden käännökset
Artikkelin tunnus: 934562 - Näytä tuotteet, joita tämä artikkeli koskee.
Laajenna kaikki | Kutista kaikki

Oire

Kun yrität päivittää Windows Vista -tietokoneen Microsoft Windows Defender -ohjelman, näyttöön tulee seuraavankaltainen virhesanoma:
Virhe: Koodi 0x80240029

Syy

Tämä ongelma ilmenee, koska SoftwareDistribution-kansio on vioittunut.

Ratkaisu

Voit ratkaista tämän ongelman kirjautumalla käyttäjätilille järjestelmänvalvojan oikeuksin ja käyttämällä sitten jotakin seuraavista tavoista:

Tapa 1
  1. Sulje kaikki avoimet ohjelmat. Voit tehdä tämän seuraavasti:
    1. Napsauta Käynnistä-painiketta, kirjoita Aloita haku -ruutuun Suorita ja paina sitten ENTER-näppäintä.
    2. Kirjoita msconfig ja valitse sitten OK.

      Järjestelmän kokoonpanosovellus avautuu.
    3. Valitse Käynnistys-välilehdessä Käynnistys vikasietotilaan -valintaruutu, valitse Vähimmäistaso-valintaruutu ja valitse sitten OK.
    4. Käynnistä tietokone uudelleen, kun näyttöön tulee kehote tehdä niin.

      Huomautus Kun olet tehnyt vaiheen 2, käynnistä Järjestelmän kokoonpanosovellus uudelleen. Poista Käynnistys-välilehden Käynnistys vikasietotilaan -valintaruudun valinta ja käynnistä tietokone uudelleen valitsemalla sitten OK.
  2. Nimeä SoftwareDistribution-kansio uudelleen. Voit tehdä tämän seuraavasti:
    1. Napsauta Käynnistä-painiketta, kirjoita Aloita haku -ruutuun %windir% ja paina sitten ENTER-näppäintä.

      Huomautus Tässä vaiheessa %windir% edustaa Windowsin järjestelmäkansion polkua. Yleensä Windowsin järjestelmäkansion polku on C:\Windows.
    2. Etsi SoftwareDistribution-kansio ja napsauta sitä hiiren kakkospainikkeella. Valitse sitten Nimeä uudelleen.
    3. Kirjoita SoftwareDistribution.old ja paina sitten ENTER-näppäintä.
    4. Käynnistä tietokone uudelleen.
Tapa 2
  1. Sulje kaikki avoimet ohjelmat. Voit tehdä tämän seuraavasti:
    1. Napsauta Käynnistä-painiketta
      Kutista tämä kuvaLaajenna tämä kuva
      Käynnistä-painike
      , valitse Etsi ja kirjoita sitten Palvelut.
    2. Kaksoisnapsauta Palvelut-vaihtoehtoa.
    3. Etsi Palvelut-luettelosta WMI-palvelu (Windows Management Instrumentation) ja napsauta sitä hiiren kakkospainikkeella. Valitse sitten Pysäytä.

      Huomautus Älä sulje Palvelut-valintaikkunaa.
    4. Avaa Resurssienhallinta.
    5. Etsi C:\%windir%\System32\wbem-kansion Repository-kansio ja poista se.
    6. Palaa Palvelut-valintaikkunaan, etsi WMI-palvelu (Windows Management Instrumentation) ja napsauta sitä hiiren kakkospainikkeella. Valitse sitten Käynnistä uudelleen.
    7. Sulje kaikki ohjelmat.
    8. Käynnistä tietokone uudelleen.

Ominaisuudet

Artikkelin tunnus: 934562 - Viimeisin tarkistus: 23. heinäkuuta 2011 - Versio: 3.1
Artikkelin tiedot koskevat seuraavia tuotteita:
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
Hakusanat: 
kbexpertisebeginner kbtshoot KB934562

Anna palautetta

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com