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When you connect a USB multifunction printer device to a Windows Vista-based computer, a second instance of the printer object is created, and the first instance no longer works

Article ID:934633
Last Review:May 15, 2008
Revision:3.1
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SYMPTOMS

Consider the following scenario:
You have a universal serial bus (USB) multifunction device. This device performs printing and scanning. Or, it performs printing, scanning, and copying.
You connect this device to a Windows Vista-based computer.
You restart the computer one time or multiple times.
When you open the Printers item in Control Panel in this scenario, you experience the following symptoms:
In the list of installed printers, there is a second instance of the printer object for this device.
The original instance of the printer object is set as the default printer. However, the original instance of the printer object does not communicate with the multifunction printer device. Therefore, this instance of the printer object does not work as expected.

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CAUSE

This problem occurs if the multifunction printer device is enumerated incorrectly in Windows Vista.

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RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 (http://support.microsoft.com/kb/935791/) How to obtain the latest Windows Vista service pack

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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable2,71730-Mar-200716:04Not Applicable
X86_usb.inf_31bf3856ad364e35_6.0.6000.20568_none_c962e4172a92da58.manifestNot Applicable2,35630-Mar-200716:05Not Applicable
X86_usbport.inf_31bf3856ad364e35_6.0.6000.20568_none_bc2cdc941fae283f.manifestNot Applicable5,38630-Mar-200716:05Not Applicable
Usbccgp.sys6.0.6000.2056873,21629-Mar-200702:27x86
Usbhub.sys6.0.6000.20568192,00029-Mar-200702:28x86
Hccoin.dll6.0.6000.205688,70429-Mar-200703:12x86
Usbd.sys6.0.6000.205685,88829-Mar-200702:27Not Applicable
Usbehci.sys6.0.6000.2056838,40029-Mar-200702:27x86
Usbhub.sys6.0.6000.20568192,00029-Mar-200702:28x86
Usbohci.sys6.0.6000.2056819,45629-Mar-200702:27x86
Usbport.sys6.0.6000.20568223,74429-Mar-200702:27x86
Usbuhci.sys6.0.6000.2056823,04029-Mar-200702:27x86
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Amd64_usb.inf_31bf3856ad364e35_6.0.6000.20568_none_25817f9ae2f04b8e.manifestNot Applicable2,35830-Mar-200716:10Not Applicable
Amd64_usbport.inf_31bf3856ad364e35_6.0.6000.20568_none_184b7817d80b9975.manifestNot Applicable5,38830-Mar-200716:10Not Applicable
Update.mumNot Applicable2,73330-Mar-200716:04Not Applicable
Usbccgp.sys6.0.6000.2056895,23229-Mar-200702:57x64
Usbhub.sys6.0.6000.20568266,75229-Mar-200702:57x64
Hccoin.dll6.0.6000.2056810,75229-Mar-200704:24x64
Usbd.sys6.0.6000.205687,55229-Mar-200702:57x64
Usbehci.sys6.0.6000.2056848,12829-Mar-200702:57x64
Usbhub.sys6.0.6000.20568266,75229-Mar-200702:57x64
Usbohci.sys6.0.6000.2056824,06429-Mar-200702:57x64
Usbport.sys6.0.6000.20568257,02429-Mar-200702:57x64
Usbuhci.sys6.0.6000.2056828,67229-Mar-200702:57x64

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

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MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Windows Vista Ultimate
Windows Vista Enterprise
Windows Vista Business
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Ultimate 64-bit Edition
Windows Vista Enterprise 64-bit Edition
Windows Vista Business 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Starter

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Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseinter kbwinvistapostrtmfix kbfix kbbug kbhotfixserver kbqfe kbpubtypekc KB934633

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