Při uložení nebo aktualizaci entity nebo atributu v aplikaci Microsoft Dynamics CRM 3.0 zobrazí chybová zpráva: „ došlo k chybě. Další informace získáte od vašeho správce systému"

Překlady článku Překlady článku
ID článku: 934690 - Produkty, které se vztahují k tomuto článku.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Při ukládání nebo aktualizaci entity nebo atributu v aplikaci Microsoft Dynamics CRM 3.0 zobrazí následující chybová zpráva:
Došlo k chybě. Další informace získáte od vašeho správce systému.
Pokud je povoleno trasování platformy, informace, která se podobá následující informace je dále zaznamenána v souboru protokolu trasování:
[2006-06-26 11:32:59.8] Proces: w3wp |Thread: 3672 |Category: |User aplikace: 00000000-0000-0000-0000-000000000000 |Level: Chyba | ErrorInformation.LogError
>Zprávu o chybách aplikace MSCRM:
Chyba: Metoda nebyla nalezena: void
Microsoft.Crm.Metadata.AttributeInfo.set_Searchable(Boolean).
Chybová zpráva: Metoda nebyla nalezena: void
Microsoft.Crm.Metadata.AttributeInfo.set_Searchable(Boolean).
Zdrojový soubor: Není k dispozici
Číslo řádku: Není k dispozici
Požadavku na adresu URL: zásobník http://localhost:5555/AppWebServices/SystemCustomization.asmx
Trasování Info: na
Microsoft.Crm.Application.WebServices.SystemCustomization.AttributeCreate.GetAttributeInfo (ParameterBag, paramBag, AttributeMetadata attributeMD, DynamicMetadataCache mdChache)
>na Microsoft.Crm.Application.WebServices.SystemCustomization.EntityCreate.Execute (uživatel uživatele, ParameterBag paramBag)
K těmto potížím dochází po instalaci opravy hotfix pro aplikaci Microsoft Dynamics CRM nebo kumulativní aktualizaci 1 pro aplikaci Microsoft Dynamics CRM 3.0.

Příčina

K tomuto problému dochází, pokud jeden platí nebo více z následujících podmínek:
  • Další kroky dokončeny, není po instalaci opravy hotfix pro aplikaci Microsoft Dynamics CRM a kumulativní aktualizace 1 pro aplikaci Microsoft Dynamics CRM 3.0.
  • Výchozí role Customizer systému Microsoft CRM byl odebrán nebo upravovat.

Řešení

Chcete-li tento problém vyřešit, následujícím postupem.

Odstraňte soubor Microsoft.crm.MetadataService.dll z globální mezipaměť sestavení (GAC) (GAC)

  1. Na serveru Microsoft Dynamics CRM klepněte na tlačítko Start, přejděte na příkaz Všechny programy, přejděte na položku Nástroje pro správu a klepněte na rozhraní Microsoft .NET Framework 1.1 Configuration.
  2. V podokně Navigace klepněte Mezipaměti sestavení.
  3. Klepněte na položku Zobrazit seznam sestavení v mezipaměti sestavení.
  4. Klepněte pravým tlačítkem myši na sestavení Microsoft.crm.MetadataService a potom klepněte na příkaz Odstranit.
  5. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz iisreset a pak klepněte na tlačítko OK.

Upravte soubor web.config odebrat text, který přidá soubor Microsoft.crm.MetadataService.dll GAC

Poznámka: V aplikaci Microsoft Dynamics CRM 3.0 nemáte přidání souboru Microsoft.crm.MetadataService.dll GAC. Některé aplikace jiných výrobců však načíst tento soubor do GAC. To může způsobit potíže, které je uveden v části "Příznaky". Pokud budete postupovat podle těchto kroků, úprav bude stále fungovat i v případě, že k GAC nepřidáte soubor Microsoft.crm.MetadataService.dll.
  1. Server Microsoft Dynamics CRM zálohu souboru web.config. Uložit záložní kopii souboru do jiné složky.

    Poznámka: Soubor web.config je umístěn ve složce Microsoft CRM web hlavní.
  2. Klepněte pravým tlačítkem myši na soubor web.config, klepněte na příkaz Otevřít v programu a klepněte na příkaz Poznámkový blok.
  3. Odstraňte následující text.
    <add assembly="Microsoft.Crm.MetadataService, Version=3.0.5300.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
  4. V nabídce soubor klepněte na příkaz Uložit.
  5. Klepněte na tlačítko Start, klepněte na příkaz Spustit, zadejte příkaz iisreset a pak klepněte na tlačítko OK.

Znovu vytvořit výchozí roli systému Customizer

Když je vytvořen vlastní entity, Microsoft Dynamics CRM automaticky povolí přístup na roli systému Customizer na nový subjekt. Pokud odstraníte nebo úprava role Customizer systému, zobrazí se chybová zpráva, uvedené v části "Příznaky".

Potřebujete-li odstranit tento problém okamžitě, obraťte se na technickou podporu společnosti. Úplný seznam telefonních čísel služeb technické podpory společnosti Microsoft a informace o cenách podpory naleznete na následujícím webu společnosti Microsoft:
http://support.microsoft.com/contactus/?ws=support

Další informace

Další informace získáte následujícím článku znalostní báze Microsoft:
922815Je k dispozici kumulativní aktualizace 1 pro aplikaci Microsoft Dynamics CRM 3.0

Vlastnosti

ID článku: 934690 - Poslední aktualizace: 15. srpna 2007 - Revize: 3.2
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft CRM 3.0
Klíčová slova: 
kbmt kbmbscrm40no kbmbscustomization kberrmsg kbtshoot kbmbsmigrate kbprb KB934690 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:934690

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com