Mensaje de error cuando inicia sesión una instancia de Microsoft SQL Server 2005 desde SQL Server Management Studio: "tiempo de espera agotado. Este período de tiempo de espera caducó antes de completar la operación o el servidor no responde"

Seleccione idioma Seleccione idioma
Id. de artículo: 934751 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Al iniciar sesión en una instancia de Microsoft SQL Server 2005 desde SQL Server Management Studio, recibirá el siguiente mensaje de error:
No se puede conectar a ComputerName / InstanceName

Tiempo de espera agotado. Este período de tiempo de espera caducó antes de completar la operación o el servidor no responde. (Microsoft SQL Server)
Si inicia sesión la instancia de SQL Server 2005 mediante la utilidad de Sqlcmd (Sqlcmd.exe) en el símbolo del sistema, recibirá el siguiente mensaje de error:
HResult 0x102, nivel 16, estado 1
ProtocolNameProveedor: Error tiempo de espera [258].
Sqlcmd: Error: Microsoft SQL Native Client: no se puede proceso de inicio de sesión completa debido retrasar la respuesta de inicio de sesión.
Sqlcmd: Error: Microsoft SQL Native Client: tiempo de espera de inicio de sesión caducado.
Nota ProtocolName representa el protocolo que el motor de base de datos de SQL Server utiliza actualmente para conectarse a la instancia de SQL Server 2005.

Además, la CPU es 100 por ciento durante el proceso de inicio de sesión.

El problema se produce cuando se cumplen las condiciones siguientes:
  • El inicio de sesión SQL Server que utilice para iniciar sesión a la instancia de SQL Server 2005 no es un miembro de la función fija de servidor sysadmin .
  • Muchos de los inicios de sesión de SQL Server existen en la instancia de SQL Server 2005.

Causa

Este problema se produce porque las entradas de caché de permisos para el objeto servidor se inicializan durante el proceso de conexión. Durante este proceso, el inicio de sesión de SQL Server no es un miembro de la función sysadmin fija de servidor.

Experimenta 100 por ciento de la CPU se produce cuando se inicializa la caché de permisos para el objeto de servidor .

Nota Otros problemas también pueden provocar la mensaje de error que se menciona en la sección "Síntomas".

Solución

Para evitar este problema, utilice uno de los métodos siguientes.

Método 1

Reducir el número de inicios de sesión de SQL Server que están en la instancia de SQL Server 2005.

Si muchos usuarios deben tener acceso a la instancia de SQL Server 2005 desde el Web, crear una tabla de usuario en la instancia para administrar estos usuarios en la instancia. No es necesario crear inicios de sesión de SQL Server para cada usuario en la instancia.

También puede configurar los inicios de sesión utilizar autenticación de Windows para registrar a la instancia de SQL Server. Para ello, siga estos pasos:
  1. Cree un grupo de Windows.
  2. Cree un inicio de sesión SQL Server que está asignado al grupo de Windows.
  3. Agregue los usuarios al grupo de Windows.

Método 2

Rellenar las entradas de caché de permisos antes de iniciar sesión en la instancia. Para ello, inicie sesión en la instancia de utilizando un inicio de sesión de SQL Server que no es un miembro de la función fija de servidor sysadmin . Cuando se rellenan las entradas de caché de permisos, experimenta el problema que se describe en la sección "Síntomas". Sin embargo, si inicia sesión en la instancia de nuevo, el proceso de inicio de sesión será rápido.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

No se inicializan cuando utiliza un miembro de la función fija de servidor sysadmin para iniciar sesión en la instancia, las entradas de caché de permisos para el objeto de servidor . Sin embargo, debe tener cuidado al conceder a los usuarios la función fija de servidor sysadmin para motivos de seguridad .

Por ejemplo, tendrá dos inicios de sesión de SQL Server. Inicios de sesión de SQL Server una es LoginA. Otros SQL Server es LoginB. Ni LoginA LoginB es un miembro de la función sysadmin fija de servidor. Cuando utiliza LoginA para iniciar sesión en la instancia, las entradas de caché de permisos para el objeto servidor se inicializan. Si muchos inicios de sesión SQL Server existen en la instancia de SQL Server 2005, el proceso de inicialización tarda mucho en completarse y de la CPU es 100 por ciento. Una vez completado el proceso de inicio de sesión LoginA, los procesos de inicio de sesión posterior será rápidos. Por ejemplo, si intenta utilizar LoginB para iniciar sesión la instancia de SQL Server 2005, el proceso de inicio de sesión será rápido aunque LoginB están utilizando para iniciar sesión en la instancia por primera vez.

Cuando inicia sesión en una instancia de SQL Server 2005, puede aparecer el siguiente comportamiento:
  • El objeto servidor se invalida.
  • Las entradas de caché de permisos para el objeto de servidor deben inicializarse.
Este comportamiento se produce después de realizar una de las operaciones siguientes:
  • Reinicie el servicio de SQL Server.
  • Uno ejecute las instrucciones siguientes en la instancia de SQL Server 2005:
    • CREAR INICIO DE SESIÓN
    • QUITAR INICIO DE SESIÓN
    • DBCC FREESYSTEM CACHÉ ('TODOS')
    • ESQUEMA DE COLOCACIÓN
  • Que una ejecución de las siguientes instrucciones en el maestro de base de datos en la instancia:
    • CREAR USUARIO
    • QUITAR USUARIO
    • QUITAR CERTIFICADO
    • COLOCAR ASYMETRIC CLAVE
    • COLOCAR SYMETRIC CLAVE
    • FUNCIÓN DE APLICACIÓN DE COLOCACIÓN

Propiedades

Id. de artículo: 934751 - Última revisión: viernes, 6 de abril de 2007 - Versión: 1.2
La información de este artículo se refiere a:
  • Microsoft SQL Server 2005 Standard Edition
  • Microsoft SQL Server 2005 Workgroup Edition
  • Microsoft SQL Server 2005 Developer Edition
  • Microsoft SQL Server 2005 Enterprise Edition
Palabras clave: 
kbmt kbexpertiseadvanced kbtshoot kbprb KB934751 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 934751

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com