Error message when you try to install a product that uses the InstallShield installer on a computer that is running Administrator's Pak: "The InstallShield Engine (ikernel.exe) could not be launched"

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Article ID: 935081 - View products that this article applies to.
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SYMPTOMS

You have a computer that is running Winternals Administrator's Pak. When you try to install a product that uses the InstallShield installer, you may receive the following error message:
The InstallShield Engine (Ikernel.exe) could not be launched. Error Loading Type Library/DLL patch
Additionally, you cannot continue with the installation.

CAUSE

This problem occurs when InstallShield components on the computer are corrupted or missing.

RESOLUTION

To resolve this problem, use the following methods. After you complete a method, run Setup. If Setup does not work, go to the next method.

Method 1

Delete the files that are in Temp directory.

Method 2

Delete the following folder:
C:\Program Files\Common Files\InstallShield\Engine

Method 3

Follow these steps:
  1. Open the following folder:
    C:\Program Files\Common Files\InstallShield\Engine\6\Intel 32
  2. In this folder, delete the folder that contains the IKernel.exe file.  
  3. Install and run the InstallShield installer. To do this, visit the following Web site:
    http://consumer.installshield.com/common.asp?source=all
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.
Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.

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Article ID: 935081 - Last Review: April 25, 2012 - Revision: 3.0
APPLIES TO
  • Winternals Administrator's Pak 4.2
  • Winternals Administrator's Pak 5.0
Keywords: 
kbtshoot kbexpertiseinter KB935081

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