The COM+ application cannot start when you use the COM+ Service Model Configuration tool to expose the COM+ components in the COM+ application

Article translations Article translations
Article ID: 935315 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

You use the COM+ Service Model Configuration command-line tool (Comsvcconfig.exe) to expose COM+ components in a COM+ application as Windows Communication Foundation (WCF) services. However, the COM+ application cannot start. This problem is likely to occur if one or both of the following conditions are true:
  • The COM+ application contains too many COM+ components.
  • The computer has limited resources, or the computer is under heavy load.

CAUSE

This problem occurs because the WCF process initializer does not inform the host process that the application process is still responding. If the WCF process initializer takes a long time to initialize the COM+ components, the host process assumes that the application process is not responding. Then the host process ends the application process.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that this article describes. Apply it only to systems that are experiencing this specific problem.

To resolve this problem, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

To apply this hotfix, you must have Microsoft .NET Framework 3.0 installed on the computer.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Microsoft .NET Framework 3.0, x86-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.servicemodel.dll3.0.4506.445,623,80822-Mar-200722:14x86
Microsoft .NET Framework 3.0, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
System.servicemodel.dll3.0.4506.445,623,80822-Mar-200722:13x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

After you apply this hotfix, the WCF process initializer periodically informs the host process and the remote procedure call (RPC) subsystem that the application process is still responding.

For more information about WCF in the .NET Framework 3.0, visit the following Microsoft Developer Network (MSDN) Web site:
http://msdn2.microsoft.com/en-us/library/ms735119.aspx
For more information about the COM+ Service Model Configuration tool, visit the following MSDN Web site:
http://msdn2.microsoft.com/en-us/library/ms732020.aspx
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 935315 - Last Review: September 28, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft .NET Framework 3.0
  • Windows Communication Foundation
Keywords: 
kbexpertiseinter kbbug kbfix kbqfe KB935315

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com