Help and Support

文書番号: 935370 - 最終更新日: 2008年10月9日 - リビジョン: 3.1

Windows Vista を実行しているコンピュータで Microsoft Office Access データベースを開いたとき、または使用しているときに発生することがある問題

すべて展開する | すべて折りたたむ

現象

Windows Vista を実行しているコンピュータで Microsoft Office Access データベースを開いたとき、または使用しているときに、次のいずれかまたは複数の問題が発生する場合があります。
  • Access が応答を停止しているように見える。
  • Access の応答が非常に遅い。
  • Access が突然終了またはクラッシュする。
  • 次のようなイベントがアプリケーション ログに記録されます。
    ログの名前 : Application
    ソース : Application Hang
    ログの日付 : Date_and_Time
    イベント ID : 1002
    タスクのカテゴリ : (101)
    レベル : Error
    キーワード : Classic
    ユーザー : N/A
    コンピュータ : Computer_Name
    説明 : プログラム MSACCESS.EXE バージョン Version_Number は Windows との対話を停止し、終了しました。問題に関する詳細な情報があるかどうかを確認するには、[問題のレポートと解決策] コントロール パネルで、エラーの履歴をクリックしてください。プロセス ID: Process_ID 開始時刻 : Hexadecimal_Time 終了時刻 : Hexadecimal_Time
上記のいずれかまたは複数の問題の発生後、次にデータベースを開いたときに、以下のエラー メッセージが表示されます。
ドキュメント Database_Name を前回開いたときに重大なエラーが発生しました。このドキュメントを引き続き開きますか?
データベースを開くと、次の問題が発生します。
  • テーブルおよびクエリ内のすべてのデータが "#Name?" と表示される。
  • ナビゲーション ウィンドウにオブジェクトがまったく表示されない。
この問題は、次の条件に該当する場合に発生することがあります。
  • 使用しているデータベースが、Windows Vista ベースのコンピュータ上に存在する共有データベースである。
  • 2 台以上の Windows Vista ベースのコンピュータでデータベースを同時に使用しようとしている。

原因

この問題は、サーバー メッセージ ブロック (SMB) 2.0 が Windows Vista ベースのコンピュータで実行されているときに SMB 2.0 で発生する問題に関連しています。

解決方法

この問題を解決するには、以下のいずれかの操作を実行します。
  • Windows Vista Service Pack 1 をインストールします。

    Windows Vista Service Pack 1 の関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    935791? (http://support.microsoft.com/kb/935791/ ) 最新の Windows Vista Service Pack を入手する方法
  • 「サポート技術情報」 (Microsoft Knowledge Base) の資料 935366 に記載されている修正プログラムを適用します。

    この修正プログラムの詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
    935366? (http://support.microsoft.com/kb/935366/ ) リモート データベースを開く際に Access が応答を停止することがある (英語)

回避策

Windows Vista を実行していないコンピュータからデータベースを共有することにより、この問題を一時的に回避できます。この方法は、根本的な解決策としてはお勧めしません。この資料を定期的にチェックして、根本的な解決策の有無を確認する必要があります。または、Microsoft Customer Support Services に連絡してください。Microsoft Customer Support Services の電話番号一覧およびサポート料金については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

SMB 2.0 の詳細については、次のマイクロソフト Web サイトにアクセスして、「サーバー メッセージ ブロック 2.0」を参照してください。
http://www.microsoft.com/japan/technet/network/evaluate/new_network.mspx (http://www.microsoft.com/japan/technet/network/evaluate/new_network.mspx)

この資料は以下の製品について記述したものです。
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
キーワード:?
kbeventlog kbsmb kbdatabase kbregistry kberrmsg kbexpertiseinter kbtshoot kbprb KB935370
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

サポート技術情報の翻訳