Artigo: 935370 - Última revisão: terça-feira, 7 de Outubro de 2008 - Revisão: 3.1

Problemas que poderão ocorrer quando abrir ou estiver a utilizar uma base de dados do Microsoft Office Access num computador com o Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando abrir ou estiver a utilizar uma base de dados do Microsoft Office Access num computador com o Windows Vista, poderá encontrar um ou mais dos seguintes problemas:
  • Acesso parece deixar de responder.
  • Acesso responde muito lentamente.
  • Acesso termina inesperadamente ou falha.
  • É registado um evento semelhante ao seguinte no registo de aplicações:
    Nome de registo: aplicação
    Origem: Bloqueio de aplicação
    Com sessão iniciada: Date_and_Time
    ID do evento: 1002
    Categoria de tarefa: (101)
    Nível: erro
    Palavras-chave: clássico
    Utilizador: N/d
    Computador: Computer_Name
    Descrição: O programa MSACCESS.EXE versão Version_Number parado interagir com o Windows e foi fechada. Para ver se estão disponíveis mais informações sobre o problema, consulte o histórico de problemas no painel de controlo de soluções e relatórios. Hora de início Process_ID de ID de processo:: Hora de fim Hexadecimal_Time: Hexadecimal_Time
Depois de encontrar um ou mais destes problemas, receberá a seguinte mensagem de erro da próxima vez que abrir a base de dados:
Documento Database_Name deu origem a um grave erro da última vez que foi aberto. Deseja continuar a abri-lo?
Quando abre a base de dados, encontrar os seguintes problemas:
  • Mostra todos os dados em tabelas e consultas como "# nome?"
  • Já não verá quaisquer objectos no painel de navegação.
Este problema poderá ocorrer se se verificarem as seguintes condições:
  • A base de dados que está a utilizar é uma base de dados partilhada que reside num computador baseado no Windows Vista.
  • Dois ou mais computadores baseados no Windows Vista estão a tentar utilizar a base de dados ao mesmo tempo.

Causa

Este problema está relacionado com problemas com o bloco de mensagem de servidor (SMB) 2.0 quando SMB 2.0 está em execução num computador com o Windows Vista.

Resolução

Para resolver este problema, efectue uma das seguintes acções:
  • Instale o Windows Vista Service Pack 1.

    Para obter mais informações sobre o Windows Vista Service Pack 1, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    935791  (http://support.microsoft.com/kb/935791/ ) Como obter o Windows Vista service pack mais recente
  • Aplique a correcção descrita no artigo da base de dados de conhecimento da Microsoft 935366.

    Para obter mais informações sobre esta correcção, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    935366  (http://support.microsoft.com/kb/935366/ ) Acesso poderá deixar de responder quando abre uma base de dados remota

Como contornar

Pode temporariamente contornar este problema, partilhar a base de dados de um computador que não está a executar o Windows Vista. Não recomendamos este método como uma solução permanente. Deve consultar este artigo periodicamente para obter uma solução permanente. Em alternativa, deverá contactar o suporte técnico da Microsoft. Para obter uma lista completa dos números de telefone de suporte técnico da Microsoft e informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre o SMB 2.0, visite o seguinte Web site da Microsoft e, em seguida, consulte a secção "Server Message Block 2.0":
http://technet.microsoft.com/en-us/library/bb726965.aspx (http://technet.microsoft.com/en-us/library/bb726965.aspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbeventlog kbsmb kbdatabase kbregistry kberrmsg kbexpertiseinter kbtshoot kbprb KB935370 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 935370  (http://support.microsoft.com/kb/935370/en-us/ )