ID do artigo: 935370 - Última revisão: terça-feira, 7 de outubro de 2008 - Revisão: 3.1

Problemas que você pode encontrar quando você abre ou estiver usando um banco de dados do Microsoft Office Access em um computador que está executando o Windows Vista

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Quando você abre ou estiver usando um banco de dados do Microsoft Office Access em um computador que está executando o Windows Vista, você pode encontrar um ou mais dos seguintes problemas:
  • Acesso parece parar de responder.
  • Acesso responde lentamente.
  • Acesso sai inesperadamente ou falha.
  • Um evento semelhante à seguinte é registrado no log do aplicativo:
    Nome de logon: aplicativos
    Origem: Falha de aplicativo
    Log: Date_and_Time
    IDENTIFICAÇÃO de evento: 1002
    Categoria da tarefa: (101)
    Nível: erro
    Palavras-chave: clássico
    Usuário: N/d
    Computador: Computer_Name
    Descrição: A versão Msaccess.exe programa Version_Number parou de interação com o Windows e foi fechada. Para ver se há mais informações sobre o problema, verifique o histórico de problema em relatórios de problemas e soluções no painel de controle. Identificação do processo: Process_ID iniciar hora: hora de término Hexadecimal_Time: Hexadecimal_Time
Depois que você encontrar um ou mais dos problemas, você receber a seguinte mensagem de erro na próxima vez que você abre o banco de dados:
Documento Database_Name causou um erro grave na última vez que foi aberto. Deseja continuar a abri-lo?
Quando você abre o banco de dados, encontrar os seguintes problemas:
  • Mostra todos os dados em tabelas e consultas como "# nome?"
  • Você não ver os objetos no painel de navegação.
Esse problema pode ocorrer se as seguintes condições forem verdadeiras:
  • O banco de dados que você está usando é um banco de dados compartilhado que reside em um computador baseado no Windows Vista.
  • Dois ou mais computadores com base no Windows Vista estão tentando usar o banco de dados ao mesmo tempo.

Causa

Esse problema está relacionado a problemas com o SMB (Server Message Block) 2.0 quando o SMB 2.0 está em execução em um computador baseado no Windows Vista.

Resolução

Para resolver esse problema, execute uma das seguintes ações:
  • Instale o Windows Vista Service Pack 1.

    Para obter mais informações sobre o Windows Vista Service Pack 1, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    935791  (http://support.microsoft.com/kb/935791/ ) Como obter o service pack mais recente do Windows Vista
  • Aplique o hotfix descrito no artigo da Base de dados de Conhecimento da Microsoft 935366.

    Para obter mais informações sobre esse hotfix, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    935366  (http://support.microsoft.com/kb/935366/ ) O acesso pode parar de responder quando você abre um banco de dados remoto

Como Contornar

Você pode contornar temporariamente esse problema por compartilhar o banco de dados de um computador que não está executando o Windows Vista. Não recomendamos esse método como uma solução permanente. Você deve verificar neste artigo periodicamente para uma solução permanente. Como alternativa, entre em contato com serviços de atendimento ao cliente da Microsoft. Para obter uma lista completa de telefones do serviço de suporte a clientes da Microsoft e informações sobre os custos de suporte, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações sobre o SMB 2.0, visite o seguinte site e, em seguida, consulte a seção "SMB 2.0":
http://technet.microsoft.com/en-us/library/bb726965.aspx (http://technet.microsoft.com/en-us/library/bb726965.aspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Office Access 2007
  • Microsoft Office Access 2003
  • Microsoft Access 2002 Standard Edition
  • Microsoft Access 2000 Standard Edition
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate
Palavras-chave: 
kbmt kbeventlog kbsmb kbdatabase kbregistry kberrmsg kbexpertiseinter kbtshoot kbprb KB935370 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 935370  (http://support.microsoft.com/kb/935370/en-us/ )