Message d'erreur lorsque vous exécutez manuellement une règle de workflow dans Microsoft Dynamics CRM 3.0: « une erreur s'est produite. Pour plus d'informations, contactez votre administrateur système. Code d'erreur : 0x80040216 »

Traductions disponibles Traductions disponibles
Numéro d'article: 935443 - Voir les produits auxquels s'applique cet article
Le correctif décrits dans cet article n'est pas disponible pour la version chinoise de Microsoft Dynamics CRM ou pour la version japonaise de Microsoft Dynamics CRM.
Agrandir tout | Réduire tout

Sommaire

Symptômes

Dans Microsoft Dynamics CRM 3.0, vous créez une règle du flux de travail pour créer des messages électroniques. Lorsque vous exécutez manuellement la règle du flux de travail, vous recevez le message d'erreur suivantes :
Une erreur s'est produite. Pour plus d'informations, contactez votre administrateur système.
Code d'erreur : 0x80040216.
Si la règle du flux de travail est configurée pour s'exécuter automatiquement lorsqu'il y a une action sur une autre entité, le message électronique n'est pas créé. En outre, vous recevez le message d'erreur suivant dans la trace de la plate-forme :
<description> Une erreur inattendue s'est produite. </description><details> Erreur de schéma : l'ID d'objet concernant et le code de type objet qui doivent être spécifiés ensemble. </details><file> e:\crm3_ur1_source_depot\src\platform\include\om\crm\communications.inl </file><line> 1800 </line>

Cause

Ce problème peut se produire si les conditions suivantes sont remplies :
  • Une légende PreCreate est configurée sur l'entité de courrier électronique.
  • La légende modifie le contenu de la chaîne entityXml. Par exemple, la légende peut remplacer une valeur de chaîne.

    note Si la chaîne entityXml n'est pas modifiée, le message d'erreur ne se produit pas.

Résolution

Ce problème a été corrigé dans Microsoft Dynamics CRM 3.0 mise à jour le correctif cumulatif 3.
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
935364Le correctif cumulatif 3 est disponible pour Microsoft Dynamics CRM 3.0
Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.

Client Microsoft Dynamics CRM pour Microsoft Office Outlook

Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeure
Crmaddin.dll3.0.5300.16141,182,56801-Mai 200719:58
Crmnativeinteropproxy.dll3.0.5300.16143,422,05601-Mai 200719:59
Crmobjectmodel.dll3.0.5300.16146,760,29601-Mai 200719:59
Microsoft.Crm.Application.pages.dll3.0.5300.1614738,66401-Mai 200719:49
Microsoft.CRM.ObjectModel.dll3.0.5300.1614320,87201-Mai 200719:49
Microsoft.CRM.Platform.Callout.Manager.dll3.0.5300.161450,53602-Mai 200708:12
Print_dlg.aspxNon applicable8,82201-Mai 200716:29
Syncqueue.dll3.0.5300.1614396,13601-Mai 200719:58
Microsoft.CRM.ObjectModel.dll3.0.5300.1318,23217-Nov 200504:42
Microsoft.CRM.Platform.Callout.Manager.dll3.0.5300.143,80017-Nov 200504:42

Client Microsoft Dynamics CRM pour la version de compatibilité Microsoft Office Outlook

Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeure
Crmaddin.dll3.0.5300.16141,209,70401-Mai 200719:58
Crmnativeinteropproxy.dll3.0.5300.16143,422,05601-Mai 200719:59
Crmobjectmodel.dll3.0.5300.16146,760,29601-Mai 200719:59
Microsoft.Crm.Application.Components.Core.dll3.0.5300.1614292,20001-Mai 200719:50
Microsoft.Crm.Application.Components.strings.dll3.0.5300.1614726,37601-Mai 200719:51
Microsoft.Crm.Application.pages.dll3.0.5300.1614738,66401-Mai 200719:50
Microsoft.CRM.dll3.0.5300.1614382,31201-Mai 200719:51
Microsoft.CRM.ObjectModel.dll3.0.5300.1614320,87201-Mai 200719:49
Microsoft.CRM.Platform.Callout.Manager.dll3.0.5300.161450,53602-Mai 200708:11
Print_dlg.aspxNon applicable8,82201-Mai 200716:29
Syncqueue.dll3.0.5300.1614396,13601-Mai 200719:58
Crmaddin.dll3.0.5300.16141,209,70401-Mai 200719:58
Microsoft.Crm.Application.Components.Core.dll3.0.5300.1614292,20001-Mai 200719:50
Microsoft.Crm.Application.Components.strings.dll3.0.5300.1614726,37601-Mai 200719:51
Microsoft.CRM.dll3.0.5300.1614382,31201-Mai 200719:51

Serveur Microsoft Dynamics CRM

Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeure
Crmnativeinteropproxy.dll3.0.5300.16143,422,05601-Mai 200719:59
Crmobjectmodel.dll3.0.5300.16146,760,29601-Mai 200719:59
Microsoft.Crm.Application.pages.dll3.0.5300.1614968,04001-Mai 200719:50
Microsoft.CRM.ObjectModel.dll3.0.5300.1614320,87201-Mai 200719:49
Microsoft.CRM.Platform.Callout.Manager.dll3.0.5300.161450,53602-Mai 200708:12
Microsoft.Crm.Tools.workflowlibrary.dll3.0.5300.1614275,81601-Mai 200719:48
Print_dlg.aspxNon applicable8,82201-Mai 200716:28
Microsoft.CRM.ObjectModel.dll3.0.5300.1318,21617-Nov 200504:39
Microsoft.CRM.Platform.Callout.Manager.dll3.0.5300.143,78417-Nov 200504:38

Informations sur l'installation

Installez ce correctif sur les ordinateurs qui exécutent Microsoft Dynamics CRM 3.0 et le client Microsoft Dynamics CRM pour Microsoft Office Outlook.

Conditions préalables

TTo appliquer ce correctif, vous avez devez installé la mise à jour qui est décrite dans l'article de la base de connaissances Microsoft 925874. Pour plus d'informations sur cette mise à jour, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
925874 Une mise à jour relative aux modifications de l'heure d'été 2007 est disponible pour Microsoft Dynamics CRM 3.0 et pour le client Microsoft Dynamics CRM 3.0 pour Outlook

Demande de redémarrage

Si vous êtes invité, redémarrez l'ordinateur après avoir installé le correctif logiciel.

Informations sur la suppression

Pour supprimer ce correctif d'un ordinateur qui exécute Microsoft Dynamics CRM 3.0, utilisez Ajout / Suppression de programmes dans le Panneau de configuration. Les administrateurs système peuvent utiliser l'outil Spuninst.exe pour supprimer ce correctif à partir d'un ordinateur qui exécute Microsoft Dynamics CRM 3.0.

L'utilitaire Spuninst.exe se trouve dans le dossier %Windir%\$NTUninstallKB935443$\Spuninst.

Plus d'informations

Pour plus d'informations sur la façon d'activer le suivi dans Microsoft Dynamics CRM, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
907490 Comment faire pour activer le suivi dans Microsoft Dynamics CRM
Pour plus d'informations sur la terminologie utilisée pour décrire les mises à jour logicielles Microsoft, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft
887283 Package correctif de logiciel Microsoft Business Solutions CRM et mise à jour de normes d'affectation de noms

Propriétés

Numéro d'article: 935443 - Dernière mise à jour: jeudi 3 avril 2008 - Version: 3.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft CRM 3.0
  • Microsoft CRM client for Microsoft Office Outlook sur le système suivant
    • Microsoft CRM 3.0
Mots-clés : 
kbmt kbautohotfix kbcrmv3c kbprb kberrmsg kbmbsemail kbqfe kbhotfixserver kbmbsmigrate KB935443 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 935443
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com