Help and Support
 

powered byLive Search

Description of Update Rollup 2 for Exchange 2007

Article ID:935490
Last Review:August 2, 2007
Revision:5.1
On This Page

SUMMARY

Microsoft has released Update Rollup 2 for Microsoft Exchange Server 2007. This article describes the following information about the update rollup:
The issues that the update rollup fixes
How to obtain the update rollup
The prerequisites for installing the update rollup
The known issues in the update rollup

Back to the top

INTRODUCTION

Issues that the update rollup fixes

Update Rollup 2 for Exchange 2007 includes the fixes for the issues that are described in Microsoft security bulletin MS07-026. The security bulletin contains all the relevant information about the security update. To view the complete security bulletin, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/bulletin/ms07-026.mspx (http://www.microsoft.com/technet/security/bulletin/ms07-026.mspx)

Back to the top

MORE INFORMATION

Update rollup information

Update Rollup 2 for Exchange 2007 has been replaced by a later update rollup. You must download and install the latest update rollup.

Note Update rollups for Exchange 2007 are not detected on clustered Exchange 2007 systems by Microsoft Update.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
937052 (http://support.microsoft.com/kb/937052/) How to obtain the latest update rollup for Exchange 2007
For more information about the Exchange Server 2007 servicing model, click the following article number to view the article in the Microsoft Knowledge Base:
937194 (http://support.microsoft.com/kb/937194/) The product service strategy for Exchange Server 2007

Back to the top

Prerequisites

The following list contains prerequisites for Update Rollup 2 for Exchange 2007:
Install Exchange 2007 on the computer before you apply this update rollup.
Remove all interim updates for Exchange 2007 before you apply this update rollup.
Review the issues in the "Known issues" section before you apply this update rollup.

Back to the top

Restart requirement

The required services are automatically stopped and then restarted when you apply this update rollup. However, if the required services cannot be stopped for any reason, or if required files are being used, this update may require a restart.

Back to the top

Removal information

To remove Update Rollup 2 for Exchange 2007, use Add or Remove Programs in Control Panel. Then, remove update 935490.

Back to the top

Important information for Outlook Web Access users about Outlook Web Access customization

When you apply an update rollup package, the update process modifies the Outlook Web Access directory names. Therefore, after you apply an update rollup package, you must re-create Outlook Web Access customization details. These details may include company logos and custom forms.

We recommend that you make a backup copy of any customized Outlook Web Access files before you apply the update rollup. For more information about Outlook Web Access customization details, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/aa996373.aspx (http://technet.microsoft.com/en-us/library/aa996373.aspx)
For more information about how to create Outlook Web Access themes, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/bb201700.aspx (http://technet.microsoft.com/en-us/library/bb201700.aspx)
If you are a CAS Proxy Deployment Guidance customer, and if you have deployed CAS-CAS proxying, apply the update rollup to the Internet-facing Client Access servers before you apply the update rollup to the non-Internet-facing Client Access servers. For other Exchange Server 2007 configurations, the order in which you apply the update rollup to the servers is not important.

For more information about CAS-CAS proxying, visit the following Microsoft Web site:
http://technet.microsoft.com/en-us/library/bb310763.aspx (http://technet.microsoft.com/en-us/library/bb310763.aspx)

Back to the top

Known issues

Issue 1

If you use Microsoft Update to apply Update Rollup 2 for Exchange 2007, or if you apply the update rollup in silent mode, certain services in Exchange 2007 remain disabled after the installer finishes. This issue occurs only if a file that must be updated by the update rollup cannot be replaced.

Symptoms

Certain services in Exchange 2007 remain disabled, and events that resemble the following are logged in the Application log:

Event ID: 11306

Type: Error
Source: MsiInstaller
Category: None
Event ID: 11306
Description:
Product: Microsoft Exchange Server -- Error 1306. Another application has exclusive access to the file ' PathOfFile '. Please shut down all other applications, then click Retry.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Data: 0000: 7b 32 34 42 32 43 31 36 {24B2C16 0008: 34 2d 44 45 36 36 2d 34 4-DE66-4 0010: 34 46 45 2d 42 34 36 38 4FE-B468 0018: 2d 41 34 36 44 39 44 35 -A46D9D5 0020: 45 36 42 33 31 7d E6B31}

Event ID: 1023

Type: Error
Source: MsiInstaller
Category: None
Event ID: 1023
Description:
Product: Microsoft Exchange Server - Update 'Update Rollup 2 for Exchange Server 2007 (KB935490) 8.0.711.2' could not be installed. Error code 1603. Additional information is available in the log file Drive :\ FileName.log.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Data: 0000: 7b 32 34 42 32 43 31 36 {24B2C16 0008: 34 2d 44 45 36 36 2d 34 4-DE66-4 0010: 34 46 45 2d 42 34 36 38 4FE-B468 0018: 2d 41 34 36 44 39 44 35 -A46D9D5 0020: 45 36 42 33 31 7d 20 7b E6B31} { 0028: 44 43 46 35 41 46 45 32 DCF5AFE2 0030: 2d 45 38 30 41 2d 34 32 -E80A-42 0038: 46 42 2d 41 36 30 44 2d FB-A60D- 0040: 41 33 42 37 35 45 38 45 A3B75E8E 0048: 43 33 39 34 7d 20 31 36 C394} 16 0050: 30 33 03

Event ID: 11729

Type: Information
Source: MsiInstaller
Category: None
Event ID: 11729
Description:
Product: Microsoft Exchange Server -- Configuration failed.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Data: 0000: 7b 32 34 42 32 43 31 36 {24B2C16 0008: 34 2d 44 45 36 36 2d 34 4-DE66-4 0010: 34 46 45 2d 42 34 36 38 4FE-B468 0018: 2d 41 34 36 44 39 44 35 -A46D9D5 0020: 45 36 42 33 31 7d E6B31}

Additionally, you receive an error message that resembles the following if you use Microsoft Update to apply the update:
Error Code: 0x80070643

Cause

This issue occurs if a silent installation of the update rollup encounters a "File in use" scenario. In this scenario, a file that is updated by the update rollup is being used.

Workaround

To work around this issue, view the Application log events that are mentioned in the "Symptoms" section to determine which file is being used. Then, make sure that the file is not being used when you install the update rollup.

Additionally, recover the original state of the Exchange Server services. To do this, use one of the following methods:
If this is the first time that you experience this issue, open Exchange Management Shell, and then run the ServiceControl.ps1 AfterPatch command from the following location: \Program Files\Microsoft\Exchange Server\Bin.
If this is not the first time that you have experienced this issue, use the Services Microsoft Management Console (MMC) snap-in to manually configure the Startup type setting of the services and to start the services. Perform this procedure before you try to reinstall the update rollup.

Back to the top

Issue 2

Symptoms

When you install Update Rollup 2 for Exchange 2007, you experience the following symptoms:
After the installation of Update Rollup 2 for Exchange 2007 is complete, users cannot log on to Outlook Web Access. In this scenario, the users are redirected to a blank Web page that has a URL that resembles the following:
https://servername/owa/auth/logon.aspx?url=https://servername/owa&reason=0
The following event is logged in the Application log:

Event Type: Error
Event Source: MsiInstaller
Event Category: None
Event ID: 1024
Description: Product: Microsoft Exchange Server - Update 'Update Rollup 2 for Exchange Server 2007 (KB935490) 8.0.711.2' could not be installed. Error code 1603. Windows Installer can create logs to help troubleshoot issues with installing software packages. Use the following link for instructions on turning on logging support: http://go.microsoft.com/fwlink/?LinkId=23127

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

The Setup Wizard for Update Rollup 2 for Exchange 2007 displays the following message during the installation of Update Rollup 2 for Exchange 2007:
Setup Wizard for Update Rollup 2 for Exchange Server 2007 (KB 935490) ended prematurely because of an error. Your system has not been modified. To install this program at a later time, please run the installation again.

Back to the top

Cause

This issue occurs if the %SYSTEMDRIVE%\ExchangeSetupLogs folder has been deleted, renamed, or moved after the installation of Exchange 2007.

Note The %SYSTEMDRIVE% variable represents the root directory of the drive on which the operating system is installed. For example, %SYSTEMDRIVE% might represent drive C.

Resolution

To resolve this issue, follow these steps:
1.If the ExchangeSetupLogs folder was renamed or moved, restore it to the root folder of the drive on which the operating system is installed.

Note The ExchangeSetupLogs folder may have been removed, and you may be unable to restore it. In this situation, create an empty folder that is named ExchangeSetupLogs in the root folder of the drive on which the operating system is installed.
2.Reinstall Update Rollup 2 for Exchange 2007.

Back to the top

REFERENCES

For more information about a version of this update for Microsoft Exchange Server 2003 or for Exchange 2000 Server, click the following article number to view the article in the Microsoft Knowledge Base:
931832 (http://support.microsoft.com/kb/931832/) MS07-026: Vulnerabilities in Microsoft Exchange could allow remote code execution
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Microsoft Exchange Server 2007 Standard Edition
Microsoft Exchange Server 2007 Enterprise Edition

Back to the top

Keywords: 
kbexpertisebeginner kbqfe kbsecurity kbsecbulletin kbsecvulnerability kbbug kbfix kbpubtypekc KB935490

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.