Artigo: 935634 - Última revisão: quinta-feira, 25 de Outubro de 2007 - Revisão: 1.1

ID de evento 459 é iniciado e poderá ser registada a seguinte mensagem de erro depois de efectuar uma cópia de segurança online de um arquivo do Exchange Server: "HRESEBACKUPTRUNCATELOGS() falhou com HRESULT: 0xc7ff1004"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

Efectuar uma cópia de segurança online completa ou uma cópia de incremental segurança online de um arquivo do Microsoft Exchange Server 2003 ou de um arquivo do Microsoft Exchange 2000 Server. Quando o fizer, a operação de cópia de segurança for concluída com êxito. No entanto, detecta os seguintes sintomas:
  • Poderá ser registada uma mensagem de erro semelhante à seguinte no ficheiro de registo do programa cópia de segurança:
    HRESEBACKUPTRUNCATELOGS() falhou com HRESULT: 0xc7ff1004
  • É registado o seguinte evento no registo de aplicações no servidor que esteja a executar o Exchange Server:

    Tipo de evento: erro
    Origem do evento: ESE
    Categoria do evento: Registo/recuperação
    ID do evento: 459
    Data: date
    Tempo: time
    Utilizador: N/d
    Computador: ComputerName
    Descrição: Arquivo de informações (4920) storage group: O ficheiro drive: \ logfilefolder \E0xxxxx.log está em falta e não pode ser dos quais foi efectuada uma cópia de segurança.

Causa

Este problema poderá ocorrer se as seguintes condições são verdadeiras:
  • A operação de cópia de segurança for concluída com êxito.
  • A operação de cópia de segurança não truncar os ficheiros de registo do Exchange Server com êxito.

Resolução

Para resolver este problema, siga estes passos.

Passo 1: Desmontar qualquer arquivos montados

Para desmontar um arquivo, siga estes passos:
  1. Inicie o programa Exchange System Manager.
  2. Expanda Administrative Groups , expanda o grupo administrativo, expanda Servers e expanda o servidor que está a ter o problema.
  3. Expanda o grupo de armazenamento que contém o arquivo que pretende desmontar, clique com o botão direito do rato no arquivo adequado e, em seguida, clique em Dismount Store .
  4. Clique em Sim para confirmar que pretende desmontar o arquivo.

Passo 2: Determinar o estado de encerramento de arquivos de Exchange Server

Utilize o programa utilitário Eseutil para determinar o estado de encerramento de cada loja do grupo de armazenamento. Para o fazer, siga estes passos:
  1. Abra uma linha de comandos e, em seguida, utilize o comando cd para mudar para o directório Exchsrvr\bin.

    Por exemplo, altere para o directório de Files\Exchsrvr\Bin c:\Programas\Microsoft.
  2. Escreva o seguinte comando e, em seguida, prima ENTER:
    eseutil /mh Database_File_Name
    Nota Para determinar o nome do ficheiro da base de dados que corresponde a um arquivo específico, siga estes passos:
    1. Inicie o programa Exchange System Manager.
    2. Expanda Administrative Groups , expanda o grupo administrativo, expanda Servers e expanda o servidor que está a ter o problema.
    3. Expanda o grupo de armazenamento que contém o arquivo que pretende, clique com o botão direito do rato StoreName (ServerName) e, em seguida, clique em Propriedades .

      Por exemplo, clique com o botão direito do rato Mailbox Store (Exchange-1) e, em seguida, clique em Propriedades .
    4. Clique no separador base de dados e, em seguida, anote o caminho e o nome de ficheiro que aparecem na caixa de base de dados do Exchange .

      Por exemplo, um caminho de base de dados como "C:\Program Files\Exchsrvr\mdbdata\priv1.edb" é apresentada nesta caixa.
    Por exemplo, para examinar os cabeçalhos de base de dados do ficheiro "C:\Program Files\Exchsrvr\mdbdata\priv1.edb", escreva eseutil /mh c:\progra~1\exchsrvr\mdbdata\priv1.edb e, em seguida, prima ENTER. Este comando apresenta o cabeçalho do ficheiro de base de dados.

    O cabeçalho do ficheiro de base de dados contém uma das seguintes entradas:
    • estado: Limpar encerramento
    • estado: desactualizadas encerramento
    Pode utilizar esta entrada para determinar o estado de encerramento da base de dados específico.
  3. Repita o passo 2 para cada base de dados do grupo de armazenamento.

Passo 3: Mover os ficheiros de registo do grupo de armazenamento afectado

Mova todos os ficheiros de registo da base de dados e todos os ficheiros ponto de verificação para o grupo de armazenamento da localização em que estão armazenadas para uma nova localização.

importante Neste passo, não altere a localização onde são armazenados os ficheiros de registo de transacções. Mova apenas os ficheiros de registo existentes a partir da pasta onde estão armazenadas para uma nova localização para cópia de segurança. Esta acção ajuda a recuperar os dados se tiver de recuperar os dados de uma base de dados anterior.

Os ficheiros de registo têm uma extensão de ficheiro. log. Geralmente, estes ficheiros têm nomes como E0000010.log, E0000011.log, E0000012.log e assim sucessivamente. Os ficheiros de ponto de verificação têm uma extensão de nome de ficheiro .chk. Geralmente, um ficheiro de ponto de verificação tem um nome como, por exemplo, E00.chk.

Nota Por predefinição, o Exchange Server armazena os ficheiros de registo e os ficheiros de ponto de verificação na mesma pasta que os ficheiros da base de dados. Para determinar onde estão localizados os ficheiros de registo para um grupo de armazenamento particular, siga estes passos:
  1. Inicie o programa Exchange System Manager.
  2. Expanda Administrative Groups , expanda o grupo administrativo, expanda Servers e expanda o servidor que está a ter o problema.
  3. Clique com o botão direito do rato no grupo de armazenamento para o qual pretende determinar a localização do ficheiro de registo e, em seguida, clique em Propriedades .

    Por exemplo, clique com o botão direito do rato First Storage Group e, em seguida, clique em Propriedades .
  4. No separador Geral , anote o caminho que aparece na caixa localização do registo de transacções .

    Por exemplo, um caminho como "C:\Program Files\Exchsrvr\mdbdata" é apresentada nesta caixa.

Passo 4: Montar os arquivos de grupo de armazenamento afectado

Para montar um arquivo, siga estes passos:
  1. Inicie o programa Exchange System Manager.
  2. Expanda Administrative Groups , expanda o grupo administrativo, expanda Servers e expanda o servidor que está a ter o problema.
  3. Expanda o grupo de armazenamento que contém o arquivo que pretende montar, clique com o botão direito do rato no arquivo adequado e clique em Montar os arquivos de .
  4. Clique em OK quando receber a seguinte mensagem:
    O arquivo foi montado com êxito.

Passo 5: Aguardar novos ficheiros de registo a serem gerados e efectue uma cópia de segurança completa online do grupo de armazenamento

Depois dos arquivos tem montado com êxito, aguarde tempo para novos ficheiros de registo de transacções para ser gerado. Em seguida, efectue uma cópia de segurança online completa do grupo de armazenamento do Exchange Server.

Depois do programa de cópia de segurança terminar a cópia de segurança do Exchange Server, verifique os ficheiros de registo da operação cópia de segurança para verificar que aparecem sem erros.

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
821915  (http://support.microsoft.com/kb/821915/ ) Como mover bases de dados do Exchange e registos no Exchange Server 2003

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Palavras-chave: 
kbmt kbeventlog kbtshoot kberrmsg kbprb kbbackup KB935634 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 935634  (http://support.microsoft.com/kb/935634/en-us/ )