ID do artigo: 935634 - Última revisão: quinta-feira, 25 de outubro de 2007 - Revisão: 1.1

A identificação de evento 459 é registrada e a seguinte mensagem de erro pode ser registrada após executar um backup online de um armazenamento do Exchange Server: "HRESEBACKUPTRUNCATELOGS() falhou com HRESULT: 0xc7ff1004"

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

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Sintomas

Você executar um backup online completo ou um backup incremental on-line de um armazenamento do Microsoft Exchange Server 2003 ou de um armazenamento do Microsoft Exchange 2000 Server. Quando você fizer isso, a operação de backup é concluída com êxito. No entanto, você os seguintes sintomas:
  • Uma mensagem de erro semelhante a seguinte mensagem de erro pode ser registrada no arquivo de log do programa de backup:
    HRESEBACKUPTRUNCATELOGS() falhou com HRESULT: 0xc7ff1004
  • O seguinte evento é registrado no log do aplicativo no servidor que está executando o Exchange Server:

    Tipo de evento: erro
    Origem do evento: ESE
    Categoria do evento: Log/recuperação
    IDENTIFICAÇÃO de evento: 459
    Data: date
    Tempo: time
    Usuário: N/d
    Computador: ComputerName
    Descrição: Armazenamento de informações (4920) storage group: O arquivo drive: \ logfilefolder \E0xxxxx.log está faltando e não pôde ser submetidos a backup.

Causa

Esse problema pode ocorrer se as seguintes condições forem verdadeiras:
  • A operação de backup é concluída com êxito.
  • A operação de backup não truncar os arquivos de log do Exchange Server com êxito.

Resolução

Para resolver esse problema, execute essas etapas.

Etapa 1: Desmontar quaisquer armazenamentos montados

Para desmontar um armazenamento, execute estas etapas:
  1. Inicie o programa Exchange System Manager.
  2. Expanda Administrative Groups , expanda o grupo administrativo, expanda Servers e, em seguida, expanda o servidor que está apresentando o problema.
  3. Expanda o grupo de armazenamento que contém o armazenamento que você deseja desmontar, clique armazenamento apropriado com o botão direito do mouse e, em seguida, clique em Desmontar armazenamento .
  4. Clique em Sim para confirmar que você deseja desmontar o armazenamento.

Etapa 2: Determinar o estado de desligamento de armazenamentos de Exchange Server

Use o programa Eseutil para determinar o estado de desligamento de cada armazenamento no grupo de armazenamento. Para fazer isso, execute as seguintes etapas:
  1. Abra um prompt de comando e, em seguida, use o comando cd para alterar para o diretório Exchsrvr\Bin.

    Por exemplo, altere para o diretório de Files\Exchsrvr\Bin c:\Program.
  2. Digite o seguinte comando e pressione ENTER:
    eseutil /mh Database_File_Name
    Observação Para determinar o nome do arquivo de banco de dados que corresponde a um armazenamento particular, execute as seguintes etapas:
    1. Inicie o programa Exchange System Manager.
    2. Expanda Administrative Groups , expanda o grupo administrativo, expanda Servers e, em seguida, expanda o servidor que está apresentando o problema.
    3. Expanda o grupo de armazenamento que contém o armazenamento que você deseja, clique StoreName (ServerName) com o botão direito do mouse e, em seguida, clique em Propriedades .

      Por exemplo, clique com o botão direito do mouse Mailbox Store (Exchange-1) e, em seguida, clique em Propriedades .
    4. Clique na guia banco de dados e, em seguida, anote o caminho e o nome de arquivo que aparecem na caixa de banco de dados do Exchange .

      Por exemplo, um caminho de banco de dados, como "C:\Program Files\Exchsrvr\mdbdata\priv1.edb" aparece nesta caixa.
    Por exemplo, para examinar os cabeçalhos de banco de dados do arquivo "C:\Program Files\Exchsrvr\mdbdata\priv1.edb", digite eseutil /mh c:\progra~1\exchsrvr\mdbdata\priv1.edb e, em seguida, pressione ENTER. Este comando exibe o cabeçalho do arquivo de banco de dados.

    O cabeçalho do arquivo de banco de dados contém uma das seguintes entradas:
    • estado: limpar desligamento
    • estado: desligamento anormal
    Você pode usar essa entrada para determinar o estado de desligamento do banco de dados específico.
  3. Repita a etapa 2 para cada banco de dados no grupo de armazenamento.

Etapa 3: Mover os arquivos de log do grupo de armazenamento afetado

Mova todos os arquivos de log os banco de dados e todos os os arquivos de ponto de verificação para o grupo de armazenamento do local no qual elas estão armazenadas para um novo local.

importante Nesta etapa, não altere o local onde estão armazenados os arquivos de log de transações. Mova apenas os arquivos de log existentes da pasta onde são armazenados para um novo local para backup. Essa ação ajuda a recuperar os dados se você tiver que recuperar os dados de um banco de dados anterior.

Os arquivos de log têm a extensão de nome .log. Geralmente, esses arquivos têm nomes como E0000010.log, E0000011.log, E0000012.log e assim por diante. Os arquivos de ponto de verificação têm uma extensão de nome de arquivo .chk. Geralmente, um arquivo de ponto de verificação tem um nome como E00.chk.

Observação Por padrão, o Exchange Server armazena os arquivos de log e os arquivos de ponto de verificação na mesma pasta dos arquivos de banco de dados. Para determinar onde os arquivos de log para um grupo de armazenamento específico estão localizados, execute essas etapas:
  1. Inicie o programa Exchange System Manager.
  2. Expanda Administrative Groups , expanda o grupo administrativo, expanda Servers e, em seguida, expanda o servidor que está apresentando o problema.
  3. Clique com o botão direito no grupo de armazenamento para o qual você deseja determinar o local do arquivo de log e, em seguida, clique em Propriedades .

    Por exemplo, clique com o botão direito do mouse First Storage Group e em seguida, clique em Propriedades .
  4. Na guia Geral , anote o caminho que aparece na caixa Transaction log location .

    Por exemplo, um caminho, como "C:\Program Files\Exchsrvr\mdbdata" aparece nesta caixa.

Etapa 4: Montar os armazenamentos no grupo de armazenamento afetado

Para montar um armazenamento, execute estas etapas:
  1. Inicie o programa Exchange System Manager.
  2. Expanda Administrative Groups , expanda o grupo administrativo, expanda Servers e, em seguida, expanda o servidor que está apresentando o problema.
  3. Expanda o grupo de armazenamento que contém o armazenamento que você deseja montar, clique com o botão direito no armazenamento apropriado e clique em Mount Store .
  4. Clique em OK quando receber a seguinte mensagem:
    O armazenamento foi montado com êxito.

Etapa 5: Aguardar novos arquivos de log a ser gerado e, em seguida, executar um backup online completo do grupo de armazenamento

Após os armazenamentos de tem montado com êxito, espere algum tempo para novos arquivos log de transação a ser gerado. Em seguida, execute um backup online completo do grupo de armazenamento do Exchange Server.

Após o programa de backup terminar o backup do Exchange Server, examine os arquivos de log da operação de backup para verificar se nenhum erro são exibidas.

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
821915  (http://support.microsoft.com/kb/821915/ ) Como mover bancos de dados e logs no Exchange Server 2003

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
Palavras-chave: 
kbmt kbeventlog kbtshoot kberrmsg kbprb kbbackup KB935634 KbMtpt
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Clique aqui para ver a versão em Inglês deste artigo: 935634  (http://support.microsoft.com/kb/935634/en-us/ )