Message d’erreur « Le stockage disponible est insuffisant pour effectuer cette opération » lorsque vous utilisez un contrôleur de domaine pour joindre un ordinateur à un domaine

Cet article fournit une résolution pour l’erreur « Le stockage disponible est insuffisant pour effectuer cette opération », lorsque vous utilisez un contrôleur de domaine pour joindre un ordinateur à un domaine.

Produits concernés : Windows Server 2019, Windows Server 2016, Windows Server 2012 R2
Numéro de la base de connaissances d’origine : 935744

Symptômes

Lorsque vous utilisez un contrôleur de domaine Microsoft Windows Server 2003 ou version ultérieure pour joindre un ordinateur client Microsoft Windows XP ou version ultérieure à un domaine, vous pouvez recevoir un message d’erreur semblable au suivant sur l’ordinateur client :

L’erreur suivante s’est produite lors de la tentative de jointure du domaine « domain_name.com » : Le stockage disponible est insuffisant pour effectuer cette opération.

En outre, le message d’avertissement suivant peut être enregistré dans le journal système sur l’ordinateur client :

Cause

Ce problème se produit parce que le jeton Kerberos généré pendant l’authentification est supérieur à la taille maximale fixe. Dans la version d’origine de Microsoft Windows 2000, la valeur par défaut de l’entrée de Registre MaxTokenSize était de 8 000 octets. Dans Windows 2000 avec Service Pack 2 (SP2) et dans les versions ultérieures de Windows, la valeur par défaut de l’entrée de Registre MaxTokenSize est de 12 000 octets.

Par exemple, si un utilisateur est membre d’un groupe directement ou par appartenance à un autre groupe, l’ID de sécurité (SID) de ce groupe est ajouté au jeton de l’utilisateur. Pour qu’un SID soit ajouté au jeton de l’utilisateur, les informations de SID doivent être communiquées à l’aide du jeton Kerberos. Si les informations SID requises dépassent la taille du jeton, l’authentification échoue.

Résolution

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 Comment sauvegarder et restaurer le Registre dans Windows

Pour résoudre ce problème, augmentez la taille du jeton Kerberos. Suivez ces étapes sur l’ordinateur client qui enregistre l’événement Kerberos.

  1. Cliquez sur Démarrer, puis sur Exécuter, tapez regedit, puis cliquez sur OK.

  2. Recherchez la sous-clé de Registre suivante, puis cliquez dessus : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Parameters

    Remarque

    Si la clé Parameters n’est pas présente, créez la clé. Pour cela, procédez comme suit :

    1. Recherchez la sous-clé de Registre suivante, puis cliquez dessus : HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos
    2. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Clé.
    3. Tapez Paramètres , puis appuyez sur Entrée.
  3. Dans le menu Edition, pointez sur Nouveau, puis cliquez sur Valeur DWORD.

  4. Tapez MaxTokenSize, puis appuyez sur Entrée.

  5. Dans le menu Edition, cliquez sur Modifier.

  6. Dans la zone Base , cliquez sur Décimal, tapez 65535 dans la zone Données de la valeur , puis cliquez sur OK.

    Remarque

    La valeur par défaut de l’entrée de Registre MaxTokenSize est une valeur décimale de 12 000. Nous vous recommandons de définir cette valeur d’entrée de Registre sur une valeur décimale de 65 535. Si vous définissez incorrectement cette valeur d’entrée de Registre sur une valeur hexadécimale de 65 535, les opérations d’authentification Kerberos peuvent échouer. En outre, les programmes peuvent retourner des erreurs.

  7. Fermez l’Éditeur du Registre.

  8. Redémarrez l'ordinateur.

Plus d’informations

Pour plus d’informations, cliquez sur les numéros d’article suivants pour afficher les articles dans la Base de connaissances Microsoft :

327825 Nouvelle résolution des problèmes liés à l’authentification Kerberos lorsque les utilisateurs appartiennent à de nombreux groupes