Messaggio di errore "Spazio di archiviazione insufficiente per completare questa operazione" quando si usa un controller di dominio per aggiungere un computer a un dominio

Questo articolo fornisce una risoluzione per l'errore "Non è disponibile spazio di archiviazione sufficiente per completare questa operazione" quando si usa un controller di dominio per aggiungere un computer a un dominio.

Si applica a: Windows Server 2019, Windows Server 2016, Windows Server 2012 R2
Numero KB originale: 935744

Sintomi

Quando si usa un controller di dominio di Microsoft Windows Server 2003 o versione successiva per aggiungere un computer client di Microsoft Windows XP o versione successiva a un dominio, è possibile che venga visualizzato un messaggio di errore simile al seguente nel computer client:

Si è verificato l'errore seguente durante il tentativo di aggiunta al dominio "domain_name.com": spazio di archiviazione insufficiente per completare l'operazione.

Inoltre, il messaggio di avviso seguente può essere registrato nel log di sistema nel computer client:

Causa

Questo problema si verifica perché il token Kerberos generato durante l'autenticazione è superiore alle dimensioni massime fisse. Nella versione originale di Microsoft Windows 2000 il valore predefinito della voce del Registro di sistema MaxTokenSize era 8.000 byte. In Windows 2000 con Service Pack 2 (SP2) e nelle versioni successive di Windows, il valore predefinito della voce del Registro di sistema MaxTokenSize è 12.000 byte.

Ad esempio, se un utente è membro di un gruppo direttamente o per appartenenza a un altro gruppo, l'ID di sicurezza (SID) per tale gruppo viene aggiunto al token dell'utente. Per aggiungere un SID al token dell'utente, le informazioni sul SID devono essere comunicate tramite il token Kerberos. Se le informazioni SID necessarie superano le dimensioni del token, l'autenticazione non riesce.

Risoluzione

Importante

In questa sezione, metodo o attività viene illustrata la procedura per modificare il Registro di sistema. Poiché l'errata modifica del Registro di sistema può causare seri problemi, Di conseguenza, attenersi scrupolosamente alla procedura indicata. Per una maggiore protezione, eseguire il backup del Registro di sistema prima di modificarlo. In questo modo sarà possibile ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni sull'esecuzione del backup e del ripristino del Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
322756 Come eseguire il backup e il ripristino del Registro di sistema in Windows

Per risolvere questo problema, aumentare le dimensioni del token Kerberos. Seguire questa procedura nel computer client che registra l'evento Kerberos.

  1. Fare clic su Start, scegliere Esegui, digitare regedit, quindi fare clic su OK.

  2. Individuare e selezionare la seguente sottochiave del Registro di sistema: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos\Parameters

    Nota

    Se la chiave Parameters non è presente, creare la chiave. A tal fine, attenersi alla seguente procedura:

    1. Individuare e selezionare la seguente sottochiave del Registro di sistema: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa\Kerberos
    2. Scegliere Nuovo dal menu Modifica e quindi Chiave.
    3. Digitare Parameters e quindi premere INVIO.
  3. Scegliere Nuovo dal menu Modifica, quindi fare clic su Valore DWORD.

  4. Digitare MaxTokenSize e quindi premere INVIO.

  5. Scegliere Modifica dal menu Modifica.

  6. Nell'area Base fare clic su Decimale, digitare 65535 nella casella Dati valore e quindi fare clic su OK.

    Nota

    Il valore predefinito per la voce del Registro di sistema MaxTokenSize è un valore decimale di 12.000. È consigliabile impostare questo valore di voce del Registro di sistema su un valore decimale pari a 65.535. Se il valore della voce del Registro di sistema viene impostato in modo errato su un valore esadecimale pari a 65.535, le operazioni di autenticazione Kerberos potrebbero non riuscire. Inoltre, i programmi possono restituire errori.

  7. Uscire dall'editor del Registro di sistema.

  8. Riavviare il computer.

Ulteriori informazioni

Per altre informazioni, fare clic sui numeri degli articoli seguenti per visualizzare gli articoli della Microsoft Knowledge Base:

327825 Nuova risoluzione dei problemi relativi all'autenticazione Kerberos quando gli utenti appartengono a molti gruppi