BUG: Un file HTML o un file XML che è archiviato in una periferica di archiviazione secondario potrebbe venire visualizzata senza icona in Esplora risorse in un computer client che esegue Windows Server 2003 o Windows XP

Traduzione articoli Traduzione articoli
Identificativo articolo: 935774 - Visualizza i prodotti a cui si riferisce l?articolo.
importante Vengono fornite informazioni su come modificare il Registro di sistema. Assicurarsi di backup del Registro di sistema prima di modificarlo. Verificare che come ripristinare il Registro di sistema se si verifica un problema. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
256986Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

In un computer client che esegue Microsoft Windows Server 2003 o Microsoft Windows XP, un file HTML o un file XML che è archiviato in una periferica di archiviazione secondario potrebbe essere visualizzato senza icona in Esplora risorse. Questo problema si verifica se è installato Microsoft Office XP, Microsoft Office 2003 o Microsoft Office system 2007.

Cause

Microsoft Office consente di installare un gestore di icona di shell per il tipo di file HTML e per il tipo di file MHTML. Inoltre, Microsoft Office consente di installare un altro gestore di icona shell per il tipo di file XML. Microsoft Office utilizza i gestori di icona di shell per visualizzare un'icona diversa a seconda dell'applicazione Microsoft Office che ha creato il file. I gestori di icona shell leggere il contenuto del file per determinare l'applicazione Microsoft Office che ha creato il file. Quindi, i gestori di icona shell restituiscono un'icona che si basa questa informazione per Esplora risorse per visualizzare. Questo processo funziona bene in maggior parte dei casi.

Il file per una periferica di archiviazione secondario potrebbe essere stata archiviata utilizzato Windows oppure utilizzando un sistema di archiviazione remoto di terze parti. In questo caso, il contenuto del file non è immediatamente disponibile per i gestori di icona di shell per leggere senza accedere alla periferica di archiviazione secondario. Di conseguenza, Windows Explorer esamina il file per l'attributo non in linea . Se il file contiene l'attributo non in linea , è possibile che Esplora non chiama i gestori dell'icona della shell. Questo comportamento è progettato per evitare il costo di una lettura remota a livello di prestazioni e per evitare di estrarre il file di archiviazione principale.

Tuttavia, a causa di un problema nella shell di Esplora non viene visualizzata un'icona generica per il file quando Esplora non vengono chiamati i gestori di icona di shell. Di conseguenza, un file che contiene l'attributo non in linea viene visualizzato senza un'icona se il tipo di file è impostato per utilizzare un gestore dell'icona della shell.

Risoluzione

Per risolvere il problema, aggiornare il sistema operativo a Windows Vista.

Workaround

avviso Può causare seri problemi se si modifica il Registro di sistema in modo errato mediante l'editor del Registro di sistema o utilizzando un altro metodo. Questi problemi potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce che sia possono risolvere questi problemi. La modifica del Registro di sistema è a rischio e pericolo dell'utente.

Per risolvere questo problema, utilizzare uno dei metodi descritti di seguito sul computer client.

Questi metodi è possono ripristinare l'immagine di un file remoto. Tuttavia, questi metodi possono avere effetti collaterali per il sistema archiviazione remota è utilizzare. Inoltre, questi metodi potrebbero richiedere di test in ambiente aziendale prima di utilizzare questi metodi ampiamente.

Metodo 1: Applicare un hotfix che consente di chiamare i gestori di icona di shell anche quando il file non è in linea di Windows Explorer

In un computer che esegue Windows XP con Service Pack 2 (SP2) o Windows XP con Service Pack 1 (SP1), hotfix 895115. Per ulteriori informazioni su questo aggiornamento rapido (hotfix), fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
895115Esplora le icone per il file htm, per i file HTML o per i file con estensione msg non viene visualizzato dopo aver attivato i file non in linea in Windows XP
Quindi, attivare un criterio che consente di chiamare i gestori di icona di shell anche quando il file non è in linea di Windows Explorer. Per attivare il criterio, attenersi alla seguente procedura:
  1. Individuare la seguente chiave di registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer
  2. Sotto questa chiave del Registro di sistema, creare la voce di registro di sistema di PerInstanceIconHandlerForOffline di tipo DWORD.
  3. Impostare il valore della voce del Registro di sistema PerInstanceIconHandlerForOffline su 1.

Metodo 2: Modificare i tasti del Registro di sistema per utilizzare immagini icona statica

Modificare le chiavi del Registro di sistema associati al tipo di file HTML, con il tipo di file MHTML e con il tipo di file XML. Verificare le chiavi di utilizzare immagini icona statica anziché i gestori dell'icona della shell. Per effettuare questa operazione, attenersi alla seguente procedura:
  1. Creare un nuovo file di testo e quindi incollare le seguenti informazioni nel nuovo file di testo.
    Windows Registry Editor Version 5.00
    
    [HKEY_CLASSES_ROOT\htmlfile\DefaultIcon]
    @="C:\\Program Files\\Internet Explorer\\IEXPLORE.EXE,-32529"
    
    [HKEY_CLASSES_ROOT\mhtmlfile\DefaultIcon]
    @="C:\\Program Files\\Internet Explorer\\IEXPLORE.EXE,-32554"
    
    [HKEY_CLASSES_ROOT\xmlfile\DefaultIcon]
    @="msxml.dll,-128"
    
    [-HKEY_CLASSES_ROOT\htmlfile\ShellEx\IconHandler]
    [-HKEY_CLASSES_ROOT\mhtmlfile\ShellEx\IconHandler]
    [-HKEY_CLASSES_ROOT\xmlfile\ShellEx\IconHandler]
  2. Salvare il nuovo file di testo del file RestoreHandlerKeys.reg. Assicurarsi che utilizzino l'estensione reg in modo che il file sia associato come un file di script del Registro di sistema di Windows.
  3. Fare clic con il pulsante destro del mouse sul RestoreHandlerKeys.reg file e quindi fare clic su Unisci . Se viene visualizzato un messaggio che chiede di consentire l'unione, scegliere .

    Nota Potrebbe essere necessario disconnettersi dal computer e riaccedere al computer.

Status

Microsoft ha confermato che questo un bug nei prodotti sono elencati nella sezione "Si applica a".

Informazioni

Questo problema non danneggiare il file o il contenuto del file. Questo problema è un problema di visualizzazione in un computer client che esegue Windows Server 2003 o Windows XP.

Archiviazione remota è una parte di Windows Server 2003 Enterprise Edition e Windows Server 2003 Datacenter Edition. Questo problema non è specifico da Archiviazione remota. Tuttavia, il problema è un problema in Windows Explorer su un computer client che esegue Windows Server 2003 o Windows XP se in archivi remoti è il centro dati di rete. Per ulteriori informazioni sull'archiviazione remota, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
816588L'utilizzo di archiviazione remota in Windows Server 2003

Proprietà

Identificativo articolo: 935774 - Ultima modifica: mercoledì 31 ottobre 2007 - Revisione: 1.4
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Office XP, All Editions
  • Microsoft Office 2003, All Editions
  • Microsoft Office Ultimate 2007
  • Microsoft Office Enterprise 2007
  • Microsoft Office Professional Plus 2007
  • Microsoft Office Professional 2007
  • Microsoft Office Small Business 2007
  • Microsoft Office Standard 2007
Chiavi: 
kbmt kbtshoot kbbug kbpending KB935774 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 935774
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com