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Error message when you try to print after you install the GDI security update 925902: "Stop 0x0000007F"

Article ID:935843
Last Review:August 23, 2007
Revision:4.2
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SYMPTOMS

Microsoft is aware of an issue that affects a limited number of printer drivers. When you try to print by using one of these drivers after you install security update 925902, you may experience the following symptoms.
Your computer automatically restarts.
After you log on, you receive the following error message:
Microsoft Windows
The system has recovered from a serious error.
A log of this error has been created.
Please tell Microsoft about this problem.
We have created an error report that you can send to help us improve Microsoft Windows. We will treat this report as confidential and anonymous.
To see what data this error report contains, click here.
Note If the error message still appears, and you want to see the data that the error report contains, click the click here link at the bottom of the message box. You see error signature information that may resemble the following:
BCCode : 0x0000007f (0x00000000, 0x00000000, 0x00000000, 0x00000000)

 OSVer : 5_1_2600 SP : 0_0 Product : 256_1
You receive the following Stop error message:
A problem has been detected and Windows has been shut down to prevent damage to your computer...
Technical information:

*** Stop 0x0000007f (0x00000000, 0x00000000, 0x00000000, 0x00000000)
UNEXPECTED_KERNEL_MODE_TRAP
When you view the System log in Event Viewer, you notice an Event ID 1003 entry that contains information that resembles the following:
Date: date
Source: System
Error Time: time
Category: (102)
Type: Error
Event ID: 1003
User: N/A
Computer: computer name
Description: Error code 0x0000007f (0x00000000, 0x00000000, 0x00000000, 0x00000000) . For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp. Data: 0000: 53 79 73 74 65 6d 20 45 System E 0008: 72 72 6f 72 20 20 45 72 rror Er 0010: 72 6f 72 20 63 6f 64 65 ror code 0018: 20 30 30 30 30 30 30 35 00000MN 0020: 30 20 20 50 61 72 61 6d 0 Param 0028: 65 74 65 72 73 20 66 66 eters ff 0030: 66 66 66 66 64 31 2c

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Notes

The symptoms of a Stop error vary according to the system failure options of the computer.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
307973 (http://support.microsoft.com/kb/307973/) How to configure system failure and recovery options in Windows
The four parameters that are included in the error signature information (BCP x) and in the parentheses of the technical information for the Stop error may vary according to the configuration of the computer.
Not all Stop 0x0000007f errors are caused by the problem that is described in this article.

For more information about Stop 0x0000007F errors , click the following article number to view the article in the Microsoft Knowledge Base:
137539 (http://support.microsoft.com/kb/137539/) General causes of "Stop 0x0000007F" errors

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CAUSE

This problem occurs when a printer driver makes a call that has invalid parameters to the Win32K.sys component. This problem affects the following printer drivers:
Ricoh LAN Fax Driver
Gestetner P7026n PCL
Ricoh Laser AP2600N PCL
HP LaserJet 9050
HP LaserJet 4200
HP 4050 PCL6
HP LaserJet 4345 PCL 6
Canon Pixma MP170
This problem may also occur if you print from SQL Reporting Services to a Printer Command Language (PCL) printer.

Notes
If you receive a similar error message when you use another driver, install the update that is mentioned in this article. If we confirm that other printer drivers are affected by this problem, we will update this article.
Check the printer manufacturer's Web site for the updated drivers that might resolve this issue.

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RESOLUTION

Update information

Microsoft Windows 2000

The following file is available for download from the Microsoft download center:

DownloadDownload the Windows2000-KB935843-x86-ENU.EXE package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=FB630B61-F84F-4D4C-8E6C-0A7E8210A506)

Release Date: April 18, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
Prerequisites
To install this update, you must have Windows 2000 Service Pack 4 (SP4) installed on the computer.
Deployment information
To install this update without requiring any user intervention and without restarting the computer, administrators can use the following command:
Windows2000-KB935843-x86-ENU.EXE /quiet /norestart
Note When you use when you use the /quiet switch and the /restart switch, you should restart the computer and verify that the installation was successful. You should also review the Kb935843.log file for information about any errors that occur when you use the /quiet switch. For more information about the setup switches that are supported by this update, click the following article number to view the article in the Microsoft Knowledge Base:
262841 (http://support.microsoft.com/kb/262841/) Command-line switches for Windows software update packages
Restart information
You must restart the computer after you apply this update.
File attributes
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformService branch
Win32k.sys5.0.2195.71351,641,96811-Apr-200708:12x86Not applicable
Win32k.sys5.0.2195.71351,641,96811-Apr-200708:12x86UNIPROC

Microsoft Windows XP

The following file is available for download from the Microsoft download center:

DownloadDownload the WindowsXP-KB935843-x86-ENU.exe package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=69443B00-F831-4785-B292-DBF8CF002C6A)

Release Date: April 18, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.
Prerequisites
To install this update, you must have Windows XP Service Pack 2 (SP2) installed on the computer.
Deployment information
To install this update without requiring any user intervention and without restarting the computer, administrators can use the following command:
WindowsXP-KB935843-x86-ENU.exe /quiet /norestart
Note When you use when you use the /quiet switch and the /restart switch, you should restart the computer and verify that the installation was successful. You should also review the Kb935843.log file for information about any errors that occur when you use the /quiet switch. For more information about the setup switches that are supported by this update, click the following article number to view the article in the Microsoft Knowledge Base:
262841 (http://support.microsoft.com/kb/262841/) Command-line switches for Windows software update packages
Restart information
You must restart the computer after you apply this update.
File attributes
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Win32k.sys5.1.2600.31151,843,58410-Apr-200710:37x86SP2SP2GDR
Win32k.sys5.1.2600.31151,843,96810-Apr-200710:59x86SP2SP2QFE


Note DELL 1815dn are also affected by this update.

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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REFERENCES

For more information about security update 925902, click the following article number to view the article in the Microsoft Knowledge Base:
925902 (http://support.microsoft.com/kb/925902/) MS07-017: Vulnerability in GDI could allow remote code execution
For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates
The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

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APPLIES TO
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition
Microsoft Windows 2000 Advanced Server
Microsoft Windows 2000 Professional Edition
Microsoft Windows 2000 Server

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Keywords: 
atdownload kbexpertiseadvanced kberrmsg kbwin2000presp5fix kbwinxppresp3fix kbbug kbhotfixserver kbqfe kbpubtypekc KB935843

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