Aparece un mensaje de error cuando intenta imprimir después de instalar la actualización de seguridad de GDI 925902: "Stop 0x0000007F"

Seleccione idioma Seleccione idioma
Id. de artículo: 935843 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Microsoft es consciente de un problema que afecta a un número limitado de controladores de impresora. Cuando intenta imprimir utilizando uno de estos controladores después de instalar la actualización de seguridad 925902, puede experimentar los síntomas siguientes.
  • El equipo se reinicia automáticamente.
  • Después de iniciar sesión, se muestra un mensaje de error similar al siguiente:
    Microsoft Windows
    El sistema se ha recuperado de un error grave.
    Se ha creado un registro de este error.
    Informe a Microsoft de este problema.
    Se ha creado un informe de errores que puede enviar para mejorar Microsoft Windows. El informe se tratará como confidencial y anónimo.
    Para consultar los datos que contiene este informe de errores, haga clic aquí.
    Nota: si el mensaje de error sigue apareciendo y desea ver los datos que contiene el informe, haga clic en el vínculo haga clic aquí que hay en la parte inferior del cuadro de mensaje. Puede ver información de firma de error similar a la siguiente:
    BCCode : 0x0000007f (0x00000000, 0x00000000, 0x00000000, 0x00000000)
    
     OSVer : 5_1_2600 SP : 0_0 Product : 256_1
  • Aparece un mensaje de error Stop similar al siguiente:
    Se ha encontrado un problema y Windows ha sido apagado para evitar daños al equipo...
    Información técnica:

    *** Stop 0x0000007f (0x00000000, 0x00000000, 0x00000000, 0x00000000)
    UNEXPECTED_KERNEL_MODE_TRAP
  • Cuando examina el registro del sistema en el Visor de sucesos, observa una entrada con el Id. de suceso 1003 que contiene información similar a la siguiente:
    Fecha: fecha
    Origen: Sistema
    Hora del error: hora
    Categoría: (102)
    Tipo: Error
    Id. de suceso: 1003
    Usuario: no disponible
    Equipo: nombreDeEquipo
    Descripción: Código de error 0x0000007f (0x00000000, 0x00000000, 0x00000000, 0x00000000) . Para obtener más información, vea el Centro de ayuda y soporte técnico en http://go.microsoft.com/fwlink/events.asp. Datos: 0000: 53 79 73 74 65 6d 20 45 System E 0008: 72 72 6f 72 20 20 45 72 rror Er 0010: 72 6f 72 20 63 6f 64 65 ror code 0018: 20 30 30 30 30 30 30 35 00000MN 0020: 30 20 20 50 61 72 61 6d 0 Param 0028: 65 74 65 72 73 20 66 66 eters ff 0030: 66 66 66 66 64 31 2c

Notas

  • Los síntomas de un error Stop varían según las opciones de error del sistema del equipo.

    Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    307973 CÓMO: Configurar técnicas de recuperación en Windows XP
  • Los cuatro parámetros incluidos en la información de firma del error (BCP x) y dentro de los paréntesis de la información técnica del error Stop pueden variar en función de la configuración del equipo.
  • No todos los errores "Stop 0x0000007f" se deben al problema descrito en este artículo.

    Para obtener más información acerca de los errores Stop 0x0000007F, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
    137539 Causas generales de los errores "STOP 0x0000007F"

Causa

Este problema se produce cuando un controlador de impresora hace una llamada al componente Win32K.sys que tiene parámetros no válidos. Este problema afecta a los controladores de impresora siguientes:
  • Ricoh LAN Fax Driver
  • Gestetner P7026n PCL
  • Ricoh Laser AP2600N PCL
  • HP LaserJet 9050
  • HP LaserJet 4200
  • HP 4050 PCL6
  • HP LaserJet 4345 PCL 6
  • Canon Pixma MP170
Este problema también puede producirse si imprime desde SQL Reporting Services en una impresora con el Lenguaje de control de impresora (PCL).

Notas
  • Si recibe un mensaje de error similar cuando usa otro controlador, instale la actualización que se menciona en este artículo. Si confirmamos que otros controladores de impresora se ven afectados por este problema, actualizaremos este artículo.
  • Busque en el sitio web del fabricante de la impresora si hay controladores actualizados que pudieran resolver el problema.

Solución

Información de la actualización

Microsoft Windows 2000

El siguiente archivo se puede descargar desde el Centro de descarga de Microsoft:

Contraer esta imagenAmpliar esta imagen
Descargar
Descargar ahora el paquete Windows2000-KB935843-x86-ESN.EXE.

Fecha de publicación: 18 de abril de 2007

Para obtener más información acerca de cómo descargar archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591 Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft exploró este archivo en busca de virus con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que ayudan a prevenir que se hagan cambios no autorizados.
Requisitos previos
Para poder instalar esta actualización debe tener instalado Windows 2000 Service Pack 4 (SP4) en el equipo.
Información de implementación
Para instalar esta actualización sin ninguna intervención de usuario y sin reiniciar el equipo, los administradores pueden usar el comando siguiente:
Windows2000-KB935843-x86-ENU.EXE /quiet /norestart
Nota: cuando utiliza los modificadores /quiet y /restart, debe reiniciar el equipo y comprobar que la instalación se realizó correctamente. También debe examinar el archivo Kb935843.log para buscar información sobre errores que se producen cuando se utiliza el modificador /quiet. Para obtener más información acerca de los modificadores de instalación compatibles con esta actualización, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
262841 Modificadores de la línea de comandos para los paquetes de actualización de software de Windows
Información de reinicio
Una vez aplicada esta actualización, debe reiniciar el equipo.
Atributos de archivo
La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la tabla siguiente (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria del elemento Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño del archivoFechaHoraPlataformaTipo de servicio
Win32k.sys5.0.2195.71351.641.96811-Abr-200708:12x86No aplicable
Win32k.sys5.0.2195.71351.641.96811-Abr-200708:12x86UNIPROC

Microsoft Windows XP

El siguiente archivo se puede descargar desde el Centro de descarga de Microsoft:

Contraer esta imagenAmpliar esta imagen
Descarga
Descargue ahora el paquete WindowsXP-KB935843-x86-ESN.exe.

Fecha de publicación: 18 de abril de 2007

Para obtener más información acerca de cómo descargar archivos de soporte técnico de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
119591 Cómo obtener Archivos de soporte técnico de Microsoft desde los servicios en línea
Microsoft exploró este archivo en busca de virus con el software de detección de virus más reciente disponible en la fecha de publicación. Asimismo, el archivo se almacenó en servidores seguros que ayudan a prevenir que se hagan cambios no autorizados.
Requisitos previos
Para poder instalar esta actualización debe tener instalado Windows XP Service Pack 2 (SP2) en el equipo.
Información de implementación
Para instalar esta actualización sin ninguna intervención de usuario y sin reiniciar el equipo, los administradores pueden usar el comando siguiente:
WindowsXP-KB935843-x86-ENU.exe /quiet /norestart
Nota: cuando utiliza los modificadores /quiet y /restart, debe reiniciar el equipo y comprobar que la instalación se realizó correctamente. También debe examinar el archivo Kb935843.log para buscar información sobre errores que se producen cuando se utiliza el modificador /quiet. Para obtener más información acerca de los modificadores de instalación compatibles con esta actualización, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
262841 Modificadores de la línea de comandos para los paquetes de actualización de software de Windows
Información de reinicio
Una vez aplicada esta actualización, debe reiniciar el equipo.
Atributos de archivo
La versión en inglés de esta revisión tiene los atributos de archivo mostrados en la tabla siguiente (u otros posteriores). Las fechas y las horas de estos archivos se muestran según el horario universal coordinado (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para ver la diferencia entre la hora UTC y la hora local, utilice la ficha Zona horaria del elemento Fecha y hora del Panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño del archivoFechaHoraPlataformaRequisito de SPTipo de servicio
Win32k.sys5.1.2600.31151.843.58410-Abr-200710:37x86SP2SP2GDR
Win32k.sys5.1.2600.31151.843.96810-Abr-200710:59x86SP2SP2QFE


Nota: esta actualización afecta también a DELL 1815dn.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Referencias

Para obtener más información acerca de la actualización de seguridad 925902, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
925902 MS07-017: Una vulnerabilidad en GDI podría permitir la ejecución remota de código
Para obtener más información acerca de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684 Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft
Los productos de terceros que se analizan en este artículo están fabricados por compañías independientes de Microsoft. Microsoft no otorga ninguna garantía, implícita o de otro tipo, con respecto al rendimiento o la confiabilidad de estos productos.

Propiedades

Id. de artículo: 935843 - Última revisión: martes, 4 de diciembre de 2007 - Versión: 4.2
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Palabras clave: 
kberrmsg kbbug kbqfe kbpubtypekc kbwin2000presp5fix atdownload kbwinxppresp3fix kbexpertiseadvanced kbhotfixserver KB935843

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com