Mensagem de erro quando tenta efectuar uma cópia de segurança ou exportar informações de configuração de ISA Server 2006: "A tarefa não está activada. Não existe memória suficiente para concluir a operação."

Traduções de Artigos Traduções de Artigos
Artigo: 935847 - Ver produtos para os quais este artigo se aplica.
importante Este artigo contém informações sobre como modificar o registo. Certifique-se uma que a cópia de segurança do registo antes de o modificar. Certifique-se que sabe como restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança, restaurar e modificar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Quando tenta efectuar uma cópia de segurança ou exportar informações de configuração para o Microsoft Internet Security and Acceleration (ISA) Server 2006, receberá a seguinte mensagem de erro:
A tarefa não está activada.

Não existe memória suficiente para concluir a operação.
Verificar este problema se tentar executar esta operação ao nível da matriz ou ao nível da empresa.

Causa

Este problema ocorre se a atribuição de memória para o Microsoft Core XML Services (MSXML) não tiver êxito durante a fase reformatting do processo de exportação do ISA Server. Para mais informações sobre este processo, consulte a secção "Mais informação".

Resolução

Uma correcção está disponível para computadores com o ISA Server 2006. Para resolver este problema, instale a correcção descrita no seguinte artigo da base de dados de conhecimento da Microsoft:
937186Descrição do pacote correcção do ISA Server 2006: data

Informações sobre instalação de correcções

aviso Podem ocorrer problemas graves se modificar o registo incorrectamente utilizando o Editor de registo ou utilizando outro método. Estes problemas poderão forçar a reinstalação do sistema operativo. Microsoft não garante que estes problemas podem ser resolvidos. Modificar o registo por sua conta e risco.

Por predefinição, o comportamento que fornece esta correcção não está activado. Para activar esta correcção, siga estes passos.

Nota Depois de activar esta correcção, os dados XML exportados não estão formatados. No entanto, ferramentas como, por exemplo, ISAInfo.hta podem ler os dados XML sem problemas. Também, operações de importação do ISA Server podem ler os dados XML não formatados.
  1. Sair da consola do ISA Server Management se estiver a ser executado.
  2. Adicione a seguinte entrada de registo:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\COM\


    Nome: DO_NOT_BEAUTIFY
    Tipo de valor: REG_DWORD
    Dados do valor: 1
  3. Saia do Editor de registo.
Também pode definir a entrada de registo utilizando um ficheiro. reg. Para o fazer, cole o seguinte código num ficheiro de texto que tem uma extensão de nome de ficheiro. reg.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\StingRay\Debug\COM] 
"DO_NOT_BEAUTIFY"=dword:00000001"
NOTA: depois de instalada esta actualização, pode utilizar esta entrada de registo para alterar o comportamento do processo de exportação de ISA. Uma vez que apenas ISA Server lê esta entrada de registo durante o processo de exportação, não é necessário reiniciar os serviços relacionados com o ISA Server ao fazê-lo.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

No ISA Server, o processo de exportação e o processo de importação utilize MSXML para converter informações de configuração de ISA para um documento XML. Por predefinição, não são formatados com documentos XML. Para tornar o XML exportado mais legível, ISA Server utiliza MSXML para formatar os dados XML depois de concluída a operação de exportação. Uma vez que o ISA Server contém o documento XML original na memória até a operação reformatting ser bem sucedido, a operação reformatting faz com que MSXML a utilizar, pelo menos, a mesma quantidade de memória para o documento XML reformatado como para o documento XML original. Este comportamento pode exceder utilizador disponíveis de memória no computador.

Depois de aplicar a correcção que é mencionada neste artigo e, em seguida, defina a entrada de registo adequada, o ISA Server ignora o processo de reformatação durante a operação de exportação.

Para obter mais informações sobre uma mensagem de erro semelhante, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
926218Mensagem de erro quando tenta efectuar uma cópia de segurança ou exportar a configuração no ISA Server 2006 ou no ISA Server 2004: "Não existe memória suficiente para concluir a operação"

Propriedades

Artigo: 935847 - Última revisão: 29 de maio de 2007 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Security and Acceleration Server 2006 Standard Edition
  • Microsoft Internet Security and Acceleration Server 2006 Enterprise Edition
Palavras-chave: 
kbmt kberrmsg kbfirewall kbtshoot kbfix kbbug kbprb KB935847 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 935847

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com