Mensagem de erro ao tentar fazer backup ou exportar informações de configuração para ISA Server 2006: "A tarefa não está ativada. Não há memória suficiente para concluir a operação."

Traduções deste artigo Traduções deste artigo
ID do artigo: 935847 - Exibir os produtos aos quais esse artigo se aplica.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você tenta fazer backup ou exportar informações de configuração para o Microsoft Internet Security and Acceleration (ISA) Server 2006, você receber a seguinte mensagem de erro:
A tarefa não está ativada.

Não há memória suficiente para concluir a operação.
Você enfrentar esse problema se você tentar executar esta operação no nível de matriz ou no nível empresarial.

Causa

Esse problema ocorre se a alocação de memória para o Microsoft Core XML Services (MSXML) não tiver êxito durante o estágio reformatando do processo de exportação do ISA Server. Para obter mais informações sobre esse processo, consulte a seção "Mais informação".

Resolução

Um hotfix está disponível para computadores que estejam executando o ISA Server 2006. Para resolver esse problema, instale o hotfix descrito no seguinte artigo da Base de dados de Conhecimento Microsoft:
937186Descrição do hotfix do ISA Server 2006: data

Informações sobre a instalação do hotfix

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Por padrão, o comportamento que fornece esse hotfix não está habilitado. Para habilitar esse hotfix, siga estas etapas.

Observação Depois de habilitar esse hotfix, os dados XML exportados não estão formatados. No entanto, ferramentas, como ISAInfo.hta podem ler os dados XML sem um problema. Além disso, as operações de importação do ISA Server podem ler os dados XML não formatados.
  1. Saia do console do ISA Server Management se ele estiver sendo executado.
  2. Adicione a seguinte entrada do Registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\Stingray\Debug\COM\


    Nome: DO_NOT_BEAUTIFY
    Tipo de valor: REG_DWORD
    Dados do valor: 1
  3. Feche o Editor do Registro.
Você também pode definir a entrada do Registro usando um arquivo. reg. Para fazer isso, cole o seguinte código em um arquivo de texto que possui uma extensão de nome de arquivo. reg.
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\RAT\StingRay\Debug\COM] 
"DO_NOT_BEAUTIFY"=dword:00000001"
Observação após esta atualização está instalada, você pode usar essa entrada do Registro para alterar o comportamento do processo de exportação do ISA. Como o ISA Server lê somente essa entrada do Registro durante o processo de exportação, não é necessário reiniciar serviços relacionados ao ISA Server quando você faz isso.

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

No ISA Server, o processo de exportação e o processo de importação use MSXML para converter informações de configuração do ISA para um documento XML. Por padrão, documentos XML não são formatados. Para tornar o XML exportado mais legível, o ISA Server usa MSXML para reformatar os dados XML depois que a operação de exportação estiver concluída. Como o ISA Server mantém o documento XML original na memória até que a operação reformatando é bem-sucedida, a operação reformatando faz com que MSXML usar pelo menos a mesma quantidade de memória para o documento XML reformatado como para o documento original. Esse comportamento pode exceder a memória do usuário disponíveis no computador.

Depois de aplicar o hotfix mencionado neste artigo e, em seguida, defina a entrada do registro apropriado, o ISA Server ignora o processo de reformatar durante a operação de exportação.

Para obter mais informações sobre uma mensagem de erro semelhante, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
926218Mensagem de erro quando você tenta fazer backup ou exportar a configuração no ISA Server 2006 ou no ISA Server 2004: "Não há memória suficiente para concluir a operação"

Propriedades

ID do artigo: 935847 - Última revisão: terça-feira, 29 de maio de 2007 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft Internet Security and Acceleration Server 2006 Standard Edition
  • Microsoft Internet Security and Acceleration Server 2006 Enterprise Edition
Palavras-chave: 
kbmt kberrmsg kbfirewall kbtshoot kbfix kbbug kbprb KB935847 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 935847

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com