Планшетный ПК под управлением Windows XP Tablet PC Edition 2005 перестает отвечать (зависает) при помещении его в ждущий или спящий режим

Переводы статьи Переводы статьи
Код статьи: 935892
Важные Эта статья содержит сведения об изменении реестра. Убедитесь, что резервную копию реестра перед внесением изменений. Убедитесь, что знаете, как восстановить реестр в случае возникновения проблем. Для получения дополнительных сведений о том, как резервное копирование, восстановлении и изменении реестра щелкните следующий номер статьи базы знаний Майкрософт:
256986 Описание реестра Microsoft Windows
Развернуть все | Свернуть все

В этой статье

Проблема

При попытке поместить планшетного ПК под управлением Microsoft Windows XP Tablet PC Edition 2005 в ждущий или спящий, он перестает отвечать (зависает).

Данная проблема возникает при установке одного или нескольких составных устройств USB, поддерживающие выборочной приостановки.

Причина

Данная проблема возникает взаимоблокировка возникает, когда драйвера концентратора USB (Usbhub.sys) выполняет синхронную передачу PowerDeviceD0 пакетов (D0) питания состояния ввода-вывода запроса (IRP). IRP помещаются в очередь, но не завершены IRP. Это условие взаимоблокировки предотвращает Tablet PC выхода из ждущего или спящего режима.

Решение

Сведения об исправлении

Корпорация Майкрософт выпустила исправление. Однако данное исправление предназначено для устранения проблемы, описанной в этой статье. Данное исправление только в тех системах, в которых обнаружена эта специфическая неполадка. Это исправление может проходить дополнительное тестирование. Таким образом Если вы не представляет особой эта проблема, рекомендуется отложить ее решение до выхода ближайшего пакета обновления, содержащего это исправление.

Если исправление доступно для загрузки, имеется раздел «Исправление доступно для загрузки» в верхней части статьи базы знаний. Если этот раздел не отображается, обратитесь в службу и службу поддержки для получения исправления.

Примечание Если возникают другие проблемы или необходимо устранить неполадки, возможно создать отдельный запрос на обслуживание. Затраты на обычные службы поддержки будут применяться дополнительные вопросы и проблемы, не связанные с данным исправлением, оплачиваются. Для получения полного списка телефонов службы поддержки и обслуживания клиентов корпорации Майкрософт или создать отдельный запрос посетите следующий веб-узел корпорации Майкрософт:
http://support.Microsoft.com/contactus/?ws=Support
Примечание В форме «Исправление доступно для загрузки» отображаются языки, для которых доступно исправление. Если язык не отображается, значит исправления недоступна для данного языка.

Сведения о файлах

Английская версия исправления содержит атрибуты файла (или более поздними), приведенные в следующей таблице. Дата и время для файлов указаны в формате общего скоординированного времени (UTC). При просмотре сведений о файле, он преобразуется в локальное время. Чтобы узнать разницу между временем по Гринвичу и местным временем, следует использовать Часовой пояс на вкладке Дата и время элемент панели управления.
Свернуть эту таблицуРазвернуть эту таблицу
Имя файлаВерсия файлаРазмер файлаДатаВремяПлатформа
Usbccgp.sys5.1.2600.311632,12811 Апреля 2007 г.11: 06X86

Включение данного исправления

Предупреждение При неправильном изменении реестра с помощью редактора реестра или иным способом могут возникнуть серьезные проблемы. Эти проблемы могут потребовать переустановки операционной системы. Корпорация Майкрософт не гарантирует эти проблемы. Изменения в реестр на ваш собственный риск.

После установки обновления, выполните следующие действия для активации исправления для Составное USB устройство.
  1. Нажмите кнопку Начало, нажмите кнопку Запустить, тип regedit, а затем нажмите кнопку ОК.
  2. Найдите и выделите следующий подраздел реестра:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\Vid_<xxxx>& Pid_<xxxx>\<instanceid>\Device параметры</instanceid></xxxx></xxxx>
    Примечание Vid_<xxxx> — это идентификатор производителя устройства. Pid_<xxxx> является Идентификатором продукта устройства. <instanceid> идентификатор экземпляра устройства.</instanceid></xxxx></xxxx>
  3. На Редактирование Выберите пункт Новый, а затем нажмите кнопку Значение типа DWORD.
  4. Тип IdleCompletionAsyncPowerIrp, а затем нажмите клавишу ВВОД.
  5. На Редактирование меню, нажмите кнопку Изменить.
  6. Тип 1 В диалоговом окне Значение данных поле, а затем нажмите кнопку ОК.
  7. На Файл меню, нажмите кнопку Выход Чтобы закрыть редактор реестра.

Статус

Корпорация Майкрософт подтверждает, что это проблема в продуктах Microsoft, перечисленных в разделе «Относится к».

Дополнительная информация

Для получения дополнительных сведений о терминологии, используемой при описании обновлений программных продуктов Майкрософт щелкните следующий номер статьи базы знаний Майкрософт:
824684Стандартные термины, используемые при описании обновлений программных продуктов Майкрософт

Свойства

Код статьи: 935892 - Последний отзыв: 11 октября 2011 г. - Revision: 5.0
Ключевые слова: 
kbautohotfix kbwinxppresp3fix kbbug kbfix kbhotfixserver kbqfe kbexpertiseinter kbmt KB935892 KbMtru
Переведено с помощью машинного перевода
ВНИМАНИЕ! Перевод данной статьи был выполнен не человеком, а с помощью программы машинного перевода, разработанной корпорацией Майкрософт. Корпорация Майкрософт предлагает вам статьи, переведенные как людьми, так и средствами машинного перевода, чтобы у вас была возможность ознакомиться со статьями базы знаний KB на родном языке. Однако машинный перевод не всегда идеален. Он может содержать смысловые, синтаксические и грамматические ошибки, подобно тому как иностранец делает ошибки, пытаясь говорить на вашем языке. Корпорация Майкрософт не несет ответственности за неточности, ошибки и возможный ущерб, причиненный в результате неправильного перевода или его использования. Корпорация Майкрософт также часто обновляет средства машинного перевода.
Эта статья на английском языке:935892

Отправить отзыв

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com