Problembeschreibung
Wenn die Integritätsdienst (HealthService.exe) zeitierte Skripts in Microsoft System Center Operations Manager 2007 ausführt, kann eine hohe Speicherauslastung auftreten. Dieses Problem tritt auf, wenn Sie ein System Center Operations Manager 2007 Management Pack verwenden, das aus einem Microsoft Operations Manager 2005 Management Pack konvertiert wurde. Die Integritätsdienst wird neu gestartet, da der überwachte Schwellenwert dieses Diensts verletzt wird.
Hinweis: Sie können das Leck sehen, indem Sie die folgenden Leistungsindikatoren überprüfen:
-
Private Bytes
-
Virtuelle Bytes
Um diese Leistungsindikatoren zu überprüfen, untersuchen Sie das Process-Objekt in Leistungsmonitor.
Ursache
Dieses Problem tritt auf, weil das MOMModules.dll Modul den zugewiesenen Speicher nicht ordnungsgemäß verwaltet.
Lösung
Informationen zum Hotfix
Ein unterstützter Hotfix ist von Microsoft verfügbar. Mit diesem Hotfix soll jedoch nur das in diesem Artikel beschriebene Problem behoben werden. Wenden Sie diesen Hotfix nur auf Systeme an, auf denen dieses spezifische Problem auftritt. Dieser Hotfix kann zusätzliche Tests erhalten. Wenn Sie von diesem Problem nicht stark betroffen sind, sollten Sie daher auf das nächste Softwareupdate warten, das diesen Hotfix enthält.
Wenn der Hotfix zum Download verfügbar ist, finden Sie oben in diesem Knowledge Base-Artikel den Abschnitt "Hotfix-Download verfügbar". Wenn dieser Abschnitt nicht angezeigt wird, wenden Sie sich an den Microsoft-Kundendienst und -Support, um den Hotfix zu erhalten.
Hinweis: Wenn zusätzliche Probleme auftreten oder eine Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die üblichen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die für diesen spezifischen Hotfix nicht in Frage kommen. Eine vollständige Liste der Microsoft Kundendienst- und Supporttelefonnummern oder zum Erstellen einer separaten Serviceanfrage finden Sie auf der folgenden Microsoft-Website:
http://support.microsoft.com/contactus/?ws=supportHinweis Das Formular "Hotfixdownload verfügbar" zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Ihre Sprache nicht angezeigt wird, liegt dies daran, dass für diese Sprache kein Hotfix verfügbar ist.
Voraussetzungen
Keine
Neustartanforderung
Sie müssen den Computer nicht neu starten, nachdem Sie diesen Hotfix angewendet haben.
Ersetzte Hotfixes
Dieser Hotfix ersetzt keine anderen Hotfixes.
Installationsanweisungen für Hotfix
Dieser Hotfix muss auf jedem Computer installiert sein, der eines der folgenden Kriterien erfüllt:
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Der Computer ist ein System Center Operations Manager-Agent.
-
Der Computer ist ein System Center Verwaltungsserver.
-
Der Computer ist ein System Center Gatewayserver.
Sie müssen jeden Verwaltungsserver und Gatewayserver in Ihren Verwaltungsgruppen manuell aktualisieren. Sie können jedoch die System Center Operations Manager 2007-Administratorkonsole verwenden, um den Hotfix auf Agentcomputern zu installieren. Eine Liste der Agents, die automatisch aktualisiert werden können, finden Sie im Ordner "Operations Manager Console\Administration\Geräteverwaltung\Pending Management".
So installieren Sie diesen Hotfix manuell
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Kopieren Sie die SystemCenterOpsMgr07-RTM-KB935896-X86-AMD64-ENU.msi Datei in einen lokalen Ordner oder in einen freigegebenen Netzwerkordner.
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Führen Sie die SystemCenterOpsMgr07-RTM-KB935896-X86-AMD64-ENU.msi Datei auf jedem entsprechenden Computer aus. Sie können die SystemCenterOpsMgr07-RTM-KB935896-X86-AMD64-ENU.msi Datei über Windows Explorer oder an einer Eingabeaufforderung ausführen.
Hinweis: System Manager Operations Manager 2007 startet die Dienste neu, nachdem der Hotfix installiert wurde.
Verwenden der Administratorkonsole zum Installieren des Hotfix auf Agentcomputern
-
Stellen Sie sicher, dass die Eigenschaft für die manuelle Installation für den Ordner "Operations Console Pending Management" aktiviert ist.
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Klicken Sie im Ordner "Vom Agent verwaltete Computer" mit der rechten Maustaste auf den Agent, und klicken Sie dann auf "Agent aktualisieren Einstellungen". Der Agent wird in Kürze aktualisiert.
Für Agents, die installiert werden, nachdem der Hotfix auf den Servern angewendet wurde, können Sie den Agent manuell aktualisieren, oder Sie können den Agent mithilfe der Administratorkonsole aktualisieren.
Dateiinformationen
Die englische Version dieses Hotfixes weist die in der nachstehenden Tabelle aufgelisteten Dateiattribute (oder höher) auf. Datums- und Uhrzeitangaben für diese Dateien sind in der "Universal Time Coordinated" (UTC) angegeben. Wenn Sie die Dateiinformationen anzeigen, werden diese Angaben in die Ortszeit umgewandelt. Den Unterschied zwischen UTC- und Ortszeit können Sie in der Systemsteuerung unter Datum und Uhrzeit mithilfe der Angaben auf der Registerkarte Zeitzone ermitteln.
System Center Operations Manager 2007, x86-basierte Version
File name |
Dateiversion |
Dateigröße |
Datum |
Time |
Platform |
---|---|---|---|---|---|
mommodules.dll |
6.0.5000.3 |
1,758,608 |
05-30-2007 |
1,442 |
x86 |
System Center Operations Manager 2007, x64-basierte Version
File name |
Dateiversion |
Dateigröße |
Datum |
Time |
Platform |
---|---|---|---|---|---|
mommodules.dll |
6.0.5000.3 |
3,276,176 |
05-30-2007 |
03:15 |
x64 |
Status
Microsoft hat bestätigt, dass es sich hierbei um ein Problem bei den in diesem Artikel genannten Microsoft-Produkten handelt.
Weitere Informationen
Weitere Informationen zur Terminologie für Softwareupdates von Microsoft finden Sie im folgenden Artikel der Microsoft Knowledge Base:
824684 Erläuterung von Standardbegriffen bei Microsoft-Softwareupdates