Help and Support

A USB telephony device that is installed on a Windows Vista-based computer is unexpectedly set as the default audio device

Article ID:936004
Last Review:August 28, 2007
Revision:2.1
On This Page

SYMPTOMS

After you install a universal serial bus (USB) telephony device on a Windows Vista-based computer, this device is unexpectedly set as the default audio device. The USB telephony device can be a USB telephone, a USB handset, or a USB headset. This behavior occurs even though other audio devices are already installed on the computer.

In this situation, the computer cannot correctly play media or record media.

Back to the top

CAUSE

This problem occurs because the system does not check the device type of the newly installed audio device. Instead, the system sets the newly installed device as the default audio device even though the device is a telephony device.

Back to the top

RESOLUTION

Update information

The following files are available for download from the Microsoft Download Center:

Windows Vista, 32-bit versions

DownloadDownload the 936004 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=9B71C47E-149C-43F9-B641-61126CE82EE4)

Windows Vista, 64-bit versions

DownloadDownload the 936004 package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=2A17B0E2-82A0-4C24-8055-EE9591DEBF3E)

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Back to the top

Prerequisites

No prerequisites are required.

Back to the top

Restart requirement

You must restart the computer after you apply this update.

Back to the top

Update replacement information

This update does not replace any other updates.

Back to the top

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable1,78719-Apr-200720:07Not Applicable
X86_1c84239218309afec9ac7d93795fd780_31bf3856ad364e35_6.0.6000.20581_none_f9e95f710cf6b0b3.manifestNot Applicable70319-Apr-200720:07Not Applicable
X86_microsoft-windows-audio-audiocore_31bf3856ad364e35_6.0.6000.20581_none_74ed9f6a00d6cd44.manifestNot Applicable139,51519-Apr-200720:20Not Applicable
Audiocore.mofNot Applicable4,34907-Jan-200705:26Not Applicable
Audiodg.exe6.0.6000.2058188,06419-Apr-200701:35x86
Audioeng.dll6.0.6000.20581398,84819-Apr-200702:12x86
Audiokse.dll6.0.6000.20581273,40819-Apr-200702:12x86
Audioses.dll6.0.6000.20581115,71219-Apr-200702:12x86
Audiosrv.dll6.0.6000.20581310,27219-Apr-200702:12x86
Encdump.dll5.0.1.1169,98419-Apr-200702:13x86
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatform
Amd64_c178c4416c36c8e38ba9bb7f5a319610_31bf3856ad364e35_6.0.6000.20581_none_3f6b32385bdc9bdc.manifestNot Applicable70719-Apr-200720:07Not Applicable
Amd64_microsoft-windows-audio-audiocore_31bf3856ad364e35_6.0.6000.20581_none_d10c3aedb9343e7a.manifestNot Applicable139,55719-Apr-200720:24Not Applicable
Update.mumNot Applicable1,79719-Apr-200720:07Not Applicable
Audiocore.mofNot Applicable4,34907-Jan-200705:26Not Applicable
Audiodg.exe6.0.6000.20581111,10419-Apr-200702:01x64
Audioeng.dll6.0.6000.20581480,76819-Apr-200703:21x64
Audiokse.dll6.0.6000.20581311,29619-Apr-200703:21x64
Audioses.dll6.0.6000.20581193,02419-Apr-200703:21x64
Audiosrv.dll6.0.6000.20581445,44019-Apr-200703:21x64
Encdump.dll5.0.1.1200,70419-Apr-200703:21x64

Back to the top

WORKAROUND

To work around this problem, reset the device of your choice as the default audio device. To do this, follow these steps:
1.Click Start, and then click Control Panel.
2.In Control Panel, double-click Sound.
3.On the Playback tab, click the audio device that you want in the Select a playback device below to modify its settings list, and then click Set Default.
4.On the Recording tab, click the audio device that you want in the Select a playback device below to modify its settings list, and then click Set Default.
5.Click OK.

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

For more information about the same problem in Windows XP, click the following article number to view the article in the Microsoft Knowledge Base:
935708 (http://support.microsoft.com/kb/935708/) A USB telephony device that is installed on a Windows XP-based computer is unexpectedly set as the default audio device
For more information about how to determine an audio device type, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms790325.aspx (http://msdn2.microsoft.com/en-us/library/ms790325.aspx)
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Windows Vista Ultimate
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Enterprise
Windows Vista Business
Windows Vista Business 64-bit Edition
Windows Vista Ultimate 64-bit Edition
Windows Vista Home Premium 64-bit Edition
Windows Vista Home Basic 64-bit Edition
Windows Vista Enterprise 64-bit Edition

Back to the top

Keywords: 
kbvistasp1fix kbwinvistapostrtmfix kbexpertisebeginner kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB936004

Back to the top

Article Translations

 

Other Support Options

  • Contact Microsoft
    Phone Numbers, Support Options and Pricing, Online Help, and more.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.