Article ID: 936005 - Last Review: June 21, 2007 - Revision: 1.0

FIX: Error message when you run a recorded Web test that contains cookies in the response URL in Visual Studio 2005 Team System Test Edition: "You are NOT authorized"

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SYMPTOMS

Consider the following scenario. In Microsoft Visual Studio 2005 Team System Test Edition, you record a Web test. The Web test contains cookies in the response URL. You run the recorded Web test. In this scenario, you may receive the following error message in the Test Results window:
You are NOT authorized
For example, you run a recorded Web test that uses forms authentication. The Web server sends cookies to the client. When a user logs on, the client also adds cookies for forms authentication to the response stream. However, the later pages cannot access these cookies. When the later pages try to access the cookies that are sent to the client, a NULL Reference exception is thrown. If you view the Request tab and the Response tab on the Results Test page, these cookies are added to the first page. However, the cookies are not added to later pages. The forms authentication fails. Additionally, the Web Browser tab in the Test Results window contains the following error message:
You are NOT authorized

CAUSE

This problem occurs because the cookies in Visual Studio 2005 Team System use the Request for Comments (RFC) specification. However, some Web browsers do not use the RFC specification. For example, Internet Explorer does not use the RFC specification.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. However, it is intended to correct only the problem that is described in this article. Apply it only to systems that are experiencing this specific problem. This hotfix may receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next Visual Studio 2005 service pack that contains this hotfix.

To resolve this problem immediately, contact Microsoft Customer Support Services to obtain the hotfix. For a complete list of Microsoft Customer Support Services telephone numbers and information about support costs, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.

Prerequisites

You must have Visual Studio 2005 Service Pack 1 (SP1) installed to apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Microsoft.visualstudio.qualitytools.loadtest.dll8.0.50727.877528,38430-Apr-200718:59x86
Microsoft.visualstudio.qualitytools.webtestframework.dll8.0.50727.877147,45630-Apr-200719:00x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Visual Studio 2005 Team System Test Edition
Keywords: 
kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB936005
 

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