Error message when click "OK" in the "Set up job scheduling" dialog box in Microsoft Dynamics AX 4.0: "A system error has occurred, preventing the Microsoft Dynamics client from continuing"

Article ID: 936028 - View products that this article applies to.
This article applies to Microsoft Dynamics AX 4.0 for all regions.
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SYMPTOMS

Consider the following scenario in Microsoft Dynamics AX 4.0:
  • You close the Job scheduling dialog box.
  • You click OK in the Set up job scheduling dialog box. Then, you receive the following error message:
    A system error has occurred, preventing the Microsoft Dynamics client from continuing.
  • You click OK when you receive this error message. Then, Microsoft Dynamics AX 4.0 closes.

CAUSE

This problem occurs because Microsoft Dynamics AX 4.0 updates the grid column header of the Job scheduling dialog box when you click OK in the Set up job scheduling dialog box. However, the grid column header was deleted after you closed the Job scheduling dialog box.

RESOLUTION

Hotfix information

A supported hotfix is now available from Microsoft. The hotfix corrects the problem that is described in this article. Apply the hotfix only to systems that are experiencing this specific problem.

To resolve this problem immediately, contact your Microsoft Dynamics partner or Technical Support for Microsoft Dynamics and related products to obtain the hotfix. If you have access to online assisted support you can log on to the Microsoft Dynamics site and create a new support request. To do this, visit the following Microsoft Web site:
https://mbs.microsoft.com/support/newstart.aspx
You can also contact Technical Support for Microsoft Dynamics and related products by telephone. To do this, visit the following Microsoft Web site:

Partners
https://mbs.microsoft.com/partnersource/resources/support/supportinformation/Global+Support+Contacts
Customers
https://mbs.microsoft.com/customersource/support/information/SupportInformation/global_support_contacts_eng.htm
In special cases, charges that are ordinarily incurred for support calls may be canceled if a Technical Support Professional for Microsoft Dynamics and related products determines that a specific update will resolve your problem. The usual support costs will apply to any additional support questions and issues that do not qualify for the specific update in question.
If you are a customer and if you do not have a Premier Support Agreement with Microsoft, you must contact your partner to obtain this hotfix.

Installation information

If you have customizations for one or more of the methods or the tables that are affected by this hotfix, you must follow these steps:
  1. Review the changes that are documented in the .xpo file.
  2. Apply these changes in a test environment before you apply the hotfix in a production environment.
For more information about how to install this hotfix, click the following article number to view the article in the Microsoft Knowledge Base:
893082 How to install a Microsoft Dynamics AX Hotfix

Prerequisites

You must have Service Pack 1 for Microsoft Dynamics AX 4.0 installed to apply this hotfix.

Removal information

You cannot remove this hotfix.

Restart requirement

If you are prompted to restart the computer, you must restart the computer after you apply this hotfix.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Ax4clientpatch30.mspNot applicable3,169,79219-Apr-200709:12Not applicable
Eula.rtfNot applicable36,35209-Jan-200610:37Not applicable
Setup.exe1.0.16.0535,33617-Oct-200623:54x86
Setup.xmlNot applicable1,59519-Apr-200709:02Not applicable

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 936028 - Last Review: August 2, 2011 - Revision: 2.0
APPLIES TO
  • Production, when used with:
    • Microsoft Dynamics AX 4.0
Keywords: 
kbax40presp2fix kberrmsg kbqfe kbmbsmigrate kbHotfixServer KB936028

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