Quando você usa software do HSM para gerenciar arquivos em uma rede, você não pode abrir um arquivo compartilhado de rede foi criado em um computador baseado no Windows XP quando você trabalha off-line

Traduções deste artigo Traduções deste artigo
ID do artigo: 936071 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Considere o seguinte cenário:
  • Você usar o software de gerenciamento de armazenamento hierárquicos (HSM) para gerenciar arquivos que são usados com pouca freqüência em um servidor de arquivos. Nesse caso, quando um usuário acessa um dos arquivos arquivados, o componente do Gerenciador de armazenamento no HSM traz o arquivo morto on-line. Além disso, o arquivo morto é transferido para mídia mais barata pelo Gerenciador de armazenamento de acordo com às diretivas que você especificar.
  • Em um computador cliente baseado no Windows XP, você criar uma pasta compartilhada no servidor de arquivos. Você tornar a pasta compartilhada disponível off-line.
  • Essa pasta contém arquivos com o atributo de ponto de nova análise .

    Observação O atributo de ponto de nova análise permanece nos arquivos quando os arquivos são migrados para o armazenamento off-line.
  • A pasta compartilhada foi sincronizada com o servidor de arquivos e os arquivos arquivados foram baixados para o cache off-line dos computadores cliente na rede.
  • Em um computador cliente baseado no Windows XP na rede, você tentar abrir um documento no compartilhamento de rede usando um aplicativo do Microsoft Office quando você trabalha off-line.
Nesse cenário, você não pode abrir o documento conforme o esperado. Além disso, você receberá uma mensagem de erro. Por exemplo, no Microsoft Word, você receberá uma mensagem de erro semelhante à seguinte:
Ocorreu um erro na abertura do arquivo.
No Microsoft Excel, você pode receber uma mensagem de erro semelhante à seguinte:
Não é possível para o Access para file_name

Causa

Quando o bloqueio oportunista exclusivo está disponível em um arquivo, o componente Mrxsmb armazena em cache determinadas solicitações, como solicitações de leitura, solicitações de gravação, solicitações de bloqueio e solicitações abertas. Esse comportamento de cache torna as solicitações interno. Portanto, essas solicitações só serão enviadas pela rede.

Quando o componente Mrxsmb recebe uma solicitação de bloqueio, o componente Mrxsmb verifica se um conflito de bloqueio existe localmente. Por exemplo, o componente Mrxsmb verifica se o arquivo é aberto por outros aplicativos, independentemente do bloqueio de estado de buffer.

No Windows XP, os processos de componente Mrxsmb solicitações somente para arquivos esparsos de leitura. Todas as outras solicitações são enviadas para o servidor de arquivos. (Isso inclui solicitações lock.) Portanto, quando o cliente estiver off-line, ele não é possível abrir o arquivo.

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Para instalar esse hotfix, você deve ter o Windows XP Service Pack 2 instalado.

Requisitos de reinicialização

Reinicie o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes lançados anteriormente.

Informações do registro

Para usar esse hotfix, não é necessário fazer alterações no registro.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Windows XP com SP2, versões com base em 86 x
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Mrxsmb.sys5.1.2600.3235454,78416 De outubro de 200712: 44x 86

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 936071 - Última revisão: quarta-feira, 31 de outubro de 2007 - Revisão: 1.2
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional
Palavras-chave: 
kbmt kbautohotfix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB936071 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 936071

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com