Article ID: 936161 - Last Review: October 8, 2011 - Revision: 2.0

The MOM service may crash in discovery in MOM 2005

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SYMPTOMS

In Microsoft Operations Manager (MOM) 2005, the MOM service (Momservice.exe) may crash in discovery. Therefore, the functionality that this service provides is lost.

When this problem occurs, the following event is logged in the System log:

Source: Service Control Manager
Date: Date
Event ID: 7031
Level: Error
User: N/A
Computer: ComputerName
Description:
The MOM service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000

CAUSE

This problem occurs because the MOM service incorrectly restarts when a discovery object returns a null value.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have MOM 2005 Service Pack 1 installed. Additionally, the computer must host a MOM 2005 management server.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
momdbconnector.dll5.0.2911.361,631,62420-16:08x86
momengine.dll5.0.2911.361,650,56820-16:08x86
momforwardingconnector.dll5.0.2911.36366,47220-16:08x86

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/LN/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Operations Manager (MOM) 2005
Keywords: 
kbautohotfix kbexpertiseinter kberrmsg kbbug kbfix kbHotfixServer kbqfe KB936161