Fehlermeldung, wenn Sie, versuchen System Center Operations Manager 2007-Berichterstattung installieren: "der Assistent wurde unterbrochen, bevor Operations Manager 2007 installiert werden konnte"

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 936219 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Wenn Sie versuchen, Microsoft System Center Operations Manager 2007-Berichterstattung installieren, wird die Installation schlägt fehl und führt einen Rollback. Außerdem erhalten Sie folgende Fehlermeldung:
Der Assistent wurde unterbrochen, bevor Operations Manager 2007 installiert werden konnte.

Ursache

Dieses Problem tritt auf, wenn Sie Operations Manager 2007 das lokale Systemkonto als das OpsMgr SDK-Dienstkonto verwenden konfigurieren. In dieser Konfiguration fragt die Installation Active Directory-Domänendienste (AD DS) für das Computerkonto, das der Stamm-Verwaltungsserver zugeordnet ist. In einer großen Active Directory-Domäne kann diese Abfrage Zeitüberschreitung kommen, bevor die AD DS abgefragten Daten zurückgegeben.

Lösung

Ein Update für dieses Problem ist im Hotfix enthalten, das im folgenden Artikel der Microsoft Knowledge Base beschrieben ist:
936481Sie können nicht die Funktion Berichte von System Center Operations Manager 2007 in einer getrennten Namespace Umgebung installieren.

Installieren Sie Hotfix 936481 wird dieses Problem behoben.

Abhilfe

Um dieses Problem zu umgehen, Konfigurieren der OpsMgr SDK-Dienst ein Domänenkonto anstelle von dem Konto LocalSystem verwenden. Nach Installation von Operations Manager 2007-Berichte können Sie den OpsMgr SDK-Dienst das lokale Systemkonto verwenden konfigurieren. Denken Sie daran, dass der OpsMgr-Konfiguration-Dienst dasselbe Konto wie der Dienst OpsMgr SDK verwendet konfiguriert werden muss.

Weitere Informationen zum Ändern der Dienstkonten finden Sie im folgenden Artikel der Microsoft Knowledge Base:
936220Zum Ändern der Anmeldeinformationen für das OpsMgr SDK-Dienst und für den OpsMgr-Config-Dienst in Microsoft System Center Operations Manager 2007

Weitere Informationen

Um zu überprüfen, dass dieses Problem rührt, tritt ein Timeout, können Sie das Microsoft Windows Installer-Protokoll untersuchen, das das Setupprogramm von Operation Manager 2007 Berichte generiert. Wenn Sie eine interaktive Installation durchführen, werden ausführliche MSI-Protokolle für den Ordner % temp % des aktuellen Benutzers geschrieben. Diese Protokolldateien folgen MomReporting N .log Namensmuster. In diesem Namensmuster ist N eine Zahl, die jedes Mal erhöht, die Sie die Installationsdatei Operation Manager 2007 Berichte ausführen. Gehen Sie folgendermaßen vor um die Protokolldatei untersuchen,
  1. Öffnen Sie den Ordner % temp %, und öffnen Sie die MomReporting N .log-Datei in Editor.

    Hinweis: Die Datei, die größte Zahl N ist die letzte Datei.
  2. Suchen Sie nach den folgenden Text:
    SetPropertiesToManagementServerActionAndSDKAccountCA error
Der vollständige Text, der den Fehler enthält etwa eine der folgenden Beispiele:

Beispiel 1
SetPropertiesToManagementServerActionAndSDKAccountCA error: Microsoft.EnterpriseManagement.Common.UnauthorizedAccessMonitoringException : The time limit for this request was exceeded.

MSI (s) (C0!94) [18:11:15:989]: PROPERTY CHANGE: Adding UnableToGetUserNameFromManagementServerActionAccount property. Its value is 'SetPropertiesToManagementServerActionAndSDKAccountCA error: Microsoft.EnterpriseManagement.Common.UnauthorizedAccessMonitoringException : The time limit for this request was exceeded.
'.
MSI (s) (C0!94) [18:11:15:989]: PROPERTY CHANGE: Adding UnableToGetUserNameFromManagementServerSDKAccount property. Its value is 'SetPropertiesToManagementServerActionAndSDKAccountCA error: Microsoft.EnterpriseManagement.Common.UnauthorizedAccessMonitoringException : The time limit for this request was exceeded.
'.
StackTrace:    at Microsoft.EnterpriseManagement.DataAbstractionLayer.SdkDataAbstractionLayer.HandleIndigoExceptions(Exception ex)
   at Microsoft.EnterpriseManagement.DataAbstractionLayer.AdministrationOperations.GetServiceAccount()
   at Microsoft.EnterpriseManagement.Administration.ManagementGroupAdministration.GetServiceAccount()
   at Microsoft.Reporting.Setup.ReportingManagedCAs.GetManagementServerSDKAccount(String momServerFQDN, String& sdkServiceDomainAndAccount)
   at Microsoft.Reporting.Setup.ReportingManagedCAs.SetPropertiesToManagementServerActionAndSDKAccountCA(Session session)
Action ended 18:11:16: _SetPropertiesToManagementServerActionAndSDKAccountCA. Return value 3.
Action ended 18:11:16: INSTALL. Return value 3.
Beispiel 2
SetPropertiesToManagementServerActionAndSDKAccountCA error: System.DirectoryServices.ActiveDirectory.ActiveDirectoryObjectNotFoundException : The specified domain does not exist or cannot be contacted.
MSI (s) (B4!84) [09:28:29:505]: PROPERTY CHANGE: Adding UnableToGetUserNameFromManagementServerActionAccount property. Its value is 'SetPropertiesToManagementServerActionAndSDKAccountCA error: System.DirectoryServices.ActiveDirectory.ActiveDirectoryObjectNotFoundException : The specified domain does not exist or cannot be contacted.'.
MSI (s) (B4!84) [09:28:29:505]: PROPERTY CHANGE: Adding UnableToGetUserNameFromManagementServerSDKAccount property. Its value is 'SetPropertiesToManagementServerActionAndSDKAccountCA error: System.DirectoryServices.ActiveDirectory.ActiveDirectoryObjectNotFoundException : The specified domain does not exist or cannot be contacted.'.
StackTrace:    at System.DirectoryServices.ActiveDirectory.Domain.GetDomain(DirectoryContext context)
   at Microsoft.Reporting.Setup.ReportingManagedCAs.GetSAMAccountName(String machine)
   at Microsoft.Reporting.Setup.ReportingManagedCAs.GetManagementServerSDKAccount(String momServerFQDN, String& sdkServiceDomainAndAccount)
   at Microsoft.Reporting.Setup.ReportingManagedCAs.SetPropertiesToManagementServerActionAndSDKAccountCA(Session session)
Action ended 9:28:29: _SetPropertiesToManagementServerActionAndSDKAccountCA. Return value 3.
Action ended 9:28:29: INSTALL. Return value 3.
in Beispiel 3
SetPropertiesToManagementServerActionAndSDKAccountCA error: Microsoft.EnterpriseManagement.Common.UnauthorizedAccessMonitoringException : The specified domain does not exist or cannot be contacted.
MSI (s) (58!68) [12:10:53:565]: PROPERTY CHANGE: Adding UnableToGetUserNameFromManagementServerActionAccount property. Its value is 'SetPropertiesToManagementServerActionAndSDKAccountCA error: Microsoft.EnterpriseManagement.Common.UnauthorizedAccessMonitoringException : The specified domain does not exist or cannot be contacted.'.
MSI (s) (58!68) [12:10:53:565]: PROPERTY CHANGE: Adding UnableToGetUserNameFromManagementServerSDKAccount property. Its value is 'SetPropertiesToManagementServerActionAndSDKAccountCA error: Microsoft.EnterpriseManagement.Common.UnauthorizedAccessMonitoringException : The specified domain does not exist or cannot be contacted.'.
StackTrace: at Microsoft.EnterpriseManagement.DataAbstractionLayer.SdkDataAbstractionLayer.HandleIndigoExceptions(Exception ex)
at Microsoft.EnterpriseManagement.DataAbstractionLayer.AdministrationOperations.GetServiceAccount()
at Microsoft.EnterpriseManagement.Administration.ManagementGroupAdministration.GetServiceAccount()
at Microsoft.Reporting.Setup.ReportingManagedCAs.GetManagementServerSDKAccount(String momServerFQDN, String& sdkServiceDomainAndAccount)
at Microsoft.Reporting.Setup.ReportingManagedCAs.SetPropertiesToManagementServerActionAndSDKAccountCA(Session session)
Action ended 12:10:53: _SetPropertiesToManagementServerActionAndSDKAccountCA. Return value 3.
Action ended 12:10:53: INSTALL. Return value 3.

Eigenschaften

Artikel-ID: 936219 - Geändert am: Dienstag, 6. November 2007 - Version: 2.1
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft System Center Operations Manager 2007
  • Microsoft System Center Essentials 2007
Keywords: 
kbmt kberrmsg kbtshoot kbexpertiseinter kbprb KB936219 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 936219
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com