FIX: When you are developing an application by using Media Foundation SDK, the application cannot load the unsigned drivers list the second time or any later time that the application tries to load the list

Article translations Article translations
Article ID: 936315 - View products that this article applies to.
Expand all | Collapse all

On This Page

SYMPTOMS

When you are developing an application by using Microsoft Media Foundation Software Development Kit (SDK), the application cannot load the unsigned drivers list the second time or any later time that the application tries to load the list. The first time that the application tries to load the list, the list loads successfully.

CAUSE

This problem occurs because the "Protected Environment Authentication and Authorization Export Driver" reports an unsigned driver only one time.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

Hotfix download information

The following files are available for download from the Microsoft Download Center.
Windows Vista for x86-based computers (all languages)
Collapse this imageExpand this image
Download
Download the Windows6.0-KB936315-x86.msu package now.
Windows Vista for x64-based computers (all languages)
Collapse this imageExpand this image
Download
Download the Windows6.0-KB936315-x64.msu package now.

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista for x86-based computers
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ci.dll6.0.6000.20583618,16821-Apr-200702:18x86
Windows Vista for x64-based computers
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ci.dll6.0.6000.20583384,69621-Apr-200703:32x64

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 936315 - Last Review: May 13, 2008 - Revision: 3.0
APPLIES TO
  • Windows Media Player 11
Keywords: 
kbvistasp1fix atdownload kbqfe kbfix KB936315

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com