Detener mensaje de error cuando ejecuta un controlador de filtro que se llama a la rutina "CmRegisterCallback" para registrar una rutina "RegistryCallback" en un equipo basado en Windows XP SP2: "STOP: 0x0000000A"

Seleccione idioma Seleccione idioma
Id. de artículo: 936456 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

En un Service Pack 2 (SP2) de Microsoft Windows XP - basado en equipo, ejecutar un controlador de filtro que se llama a la rutina CmRegisterCallback para registrar una rutina RegistryCallback . En esta situación, puede bloquearse Windows XP con SP2. Cuando se produce este problema, recibirá un mensaje de error stop similar al siguiente:
STOP: 0x0000000A (parameter1, parameter2, parameter3, parameter4) IRQL_NOT_LESS_OR_EQUAL

Causa

Cuando la rutina CmRegisterCallback registra una rutina RegistryCallback , la rutina CmRegisterCallback utiliza un espacio de direcciones desde la memoria asignada para inicializar una exclusión mutua rápida. Sin embargo, la memoria asignada para la exclusión mutua rápida procede de memoria de bloque paginado. Este comportamiento puede causar el problema que se menciona en la sección "Síntomas" en condiciones específicas.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Para aplicar este hotfix, debe tener instalado Windows XP SP2.

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Esta revisión no sustituye a ninguna otro publicada previamente.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Windows XP con SP2, x 86
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño del archivoFechaTiempoPlataformaRequisito de SP
Ntkrnlmp.exe5.1.2600.31242,141,18423 De abril de 200711: 34x 86SP2
Ntkrnlpa.exe5.1.2600.31242,062,08023 De abril de 200710: 49x 86SP2
Ntkrpamp.exe5.1.2600.31242,020,86423 De abril de 200710: 49x 86SP2
Ntoskrnl.exe5.1.2600.31242,184,96023 De abril de 200711: 36x 86SP2

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Información de la pila de llamadas

Cuando se produce este problema, se genera la siguiente pila de llamadas:
ee12a92c 804f9fdb badb0d00 e2bd5c54 80544698 nt!_KiTrap0E+0x238 
ee12a9a8 806e498e e2bd5c4c 00000000 00000000 nt!KeSetEventBoostPriority+0x1f 
ee12a9b8 80569dad c9ce63e4 e207db60 01b253e0 hal!ExReleaseFastMutex+0x1a 
ee12a9e0 8062d97e 0000000d ee12ab70 e29fe830 nt!CmpCallCallBacks+0x71 
ee12abb0 805bd8e5 01b253e0 00000000 821bba50 nt!CmpParseKey+0x6fa 
ee12ac28 805ba390 0000001c ee12ac68 00000040 nt!ObpLookupObjectName+0x119 
ee12ac7c 80623593 00000000 822f9ae8 00000001 nt!ObOpenObjectByName+0xea 
ee12ad50 8054060c 00cffaa8 00020019 00cff690 nt!NtOpenKey+0x1af 
ee12ad50 7c90eb94 00cffaa8 00020019 00cff690 nt!KiFastCallEntry+0xfc 
para obtener más información sobre la rutina CmRegisterCallback , visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/aa906439.aspx
Para obtener más información sobre la rutina RegistryCallback , visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/ms795487.aspx
Para obtener más información acerca del filtrado de llamadas de registro, visite el siguiente sitio Web de Microsoft:
http://msdn2.microsoft.com/en-us/library/aa906577.aspx
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 936456 - Última revisión: martes, 11 de septiembre de 2007 - Versión: 1.2
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
Palabras clave: 
kbmt kbautohotfix kbfix kbexpertiseadvanced kbpubtypekc kbqfe kbhotfixserver KB936456 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 936456

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com