Arrêter message d'erreur lorsque vous exécutez un pilote de filtre qui appelle la routine « CmRegisterCallback » pour enregistrer une routine « RegistryCallback » sur un ordinateur basé le Service Pack 2 Windows XP: « STOP : 0x0000000A »

Traductions disponibles Traductions disponibles
Numéro d'article: 936456 - Voir les produits auxquels s'applique cet article
Agrandir tout | Réduire tout

Sommaire

Symptômes

Sur un Microsoft Windows XP Service Pack 2 (SP2), ordinateur, vous exécutez un pilote de filtre qui appelle la routine CmRegisterCallback pour enregistrer une routine RegistryCallback . Dans ce cas, Windows XP avec SP2 peut se bloquer. Lorsque ce problème se produit, un message d'erreur d'arrêt semblable au suivant s'affiche :
: STOP 0x0000000A (parameter1, parameter2, parameter3, parameter4) IRQL_NOT_LESS_OR_EQUAL

Cause

Lorsque la routine CmRegisterCallback enregistre une routine RegistryCallback , la routine CmRegisterCallback utilise un espace d'adressage de la mémoire allouée pour initialiser un mutex rapide. Toutefois, la mémoire allouée pour le mutex rapide vient de mémoire paginée du pool. Ce comportement peut provoquer le problème mentionné dans la section « Symptômes » de cet article dans des conditions spécifiques.

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Pour appliquer ce correctif, vous devez être installé Windows XP SP2.

Demande de redémarrage

Vous devez redémarrer votre ordinateur après avoir appliqué ce correctif.

Informations sur le remplacement de correctif

Ce correctif ne remplace pas les autres correctifs précédemment publiés.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'élément Date et heure du Panneau de configuration.
Windows XP avec Service Pack 2, x 86 versions
Réduire ce tableauAgrandir ce tableau
Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-formeDemande de Service Pack
Ntkrnlmp.exe5.1.2600.31242,141,18423-Avril 200711:34x 86SERVICE PACK 2
Ntkrnlpa.exe5.1.2600.31242,062,08023-Avril 200710:49x 86SERVICE PACK 2
Ntkrpamp.exe5.1.2600.31242,020,86423-Avril 200710:49x 86SERVICE PACK 2
Ntoskrnl.exe5.1.2600.31242,184,96023-Avril 200711:36x 86SERVICE PACK 2

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Appeler des informations sur la pile

Lorsque ce problème se produit, la pile d'appel suivante est générée :
ee12a92c 804f9fdb badb0d00 e2bd5c54 80544698 nt!_KiTrap0E+0x238 
ee12a9a8 806e498e e2bd5c4c 00000000 00000000 nt!KeSetEventBoostPriority+0x1f 
ee12a9b8 80569dad c9ce63e4 e207db60 01b253e0 hal!ExReleaseFastMutex+0x1a 
ee12a9e0 8062d97e 0000000d ee12ab70 e29fe830 nt!CmpCallCallBacks+0x71 
ee12abb0 805bd8e5 01b253e0 00000000 821bba50 nt!CmpParseKey+0x6fa 
ee12ac28 805ba390 0000001c ee12ac68 00000040 nt!ObpLookupObjectName+0x119 
ee12ac7c 80623593 00000000 822f9ae8 00000001 nt!ObOpenObjectByName+0xea 
ee12ad50 8054060c 00cffaa8 00020019 00cff690 nt!NtOpenKey+0x1af 
ee12ad50 7c90eb94 00cffaa8 00020019 00cff690 nt!KiFastCallEntry+0xfc 
pour plus d'informations sur la routine CmRegisterCallback , reportez-vous à l'adresse Microsoft suivante :
http://msdn2.microsoft.com/en-us/library/aa906439.aspx
Pour plus d'informations sur la routine RegistryCallback , reportez-vous au site de Web Microsoft suivant :
http://msdn2.microsoft.com/en-us/library/ms795487.aspx
Pour plus savoir filtre les appels du Registre, reportez-vous au adresse site Web de Microsoft à l'adresse suivante :
http://msdn2.microsoft.com/en-us/library/aa906577.aspx
Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 936456 - Dernière mise à jour: mardi 11 septembre 2007 - Version: 1.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Édition familiale
  • Microsoft Windows XP Professional
Mots-clés : 
kbmt kbautohotfix kbfix kbexpertiseadvanced kbpubtypekc kbqfe kbhotfixserver KB936456 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 936456
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com