Error message when a domain user tries to change the password of a client computer that is running the German version of Windows Vista: "Status: C000006C/C000006C"

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Article ID: 936460 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario. On a domain controller, you configure some password policy settings. For example, you configure the Minimum password age password policy or the Password must meet complexity requirements password policy. However, when a domain user tries to change the password of a Windows Vista-based client computer in the domain, the user may receive the following error message:
Status: C000006C/C000006C
This error message contains only the status code. Therefore, the user does not know the meaning of the error message.

This problem occurs if the following conditions are true:
  • The user does not meet some password policy requirements when the user changes the password.
  • The client computer is running the German version of Windows Vista.

CAUSE

This problem occurs because of an error in the Authui.dll file. Currently, Windows Vista allocates a buffer of only 256 characters for an error message. If an error message is longer than 256 characters, Windows Vista resets the buffer by using the status code only.

The German version of this error message is longer than 256 characters. Therefore, the user receives the error message that contains only the status code.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

To resolve this problem, apply the following hotfix on the client computer that is running the German version of Windows Vista. A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
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File nameFile versionFile sizeDateTimePlatform
Update.mumNot applicable2,00826-Apr-200715:58Not applicable
X86_afc0ea3989214a77de4de8072cfc378b_31bf3856ad364e35_6.0.6000.20586_none_c4add85e0b57fe36.manifestNot applicable70926-Apr-200715:58Not applicable
X86_microsoft-windows-authentication-authui_31bf3856ad364e35_6.0.6000.20586_none_0a4659cc119a6e14.manifestNot applicable59,35826-Apr-200716:00Not applicable
Authui.dll6.0.6000.205861,984,51226-Apr-200703:03x86
Windows Vista, x64-based versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_80c93bbf8c8995c186c3c6d21846afbf_31bf3856ad364e35_6.0.6000.20586_none_2dc90416d0a47dd4.manifestNot applicable71326-Apr-200715:58Not applicable
Amd64_afc0ea3989214a77de4de8072cfc378b_31bf3856ad364e35_6.0.6000.20586_none_20cc73e1c3b56f6c.manifestNot applicable71126-Apr-200715:58Not applicable
Amd64_microsoft-windows-authentication-authui_31bf3856ad364e35_6.0.6000.20586_none_6664f54fc9f7df4a.manifestNot applicable59,41626-Apr-200716:04Not applicable
Package_1_for_kb936460~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable1,80026-Apr-200715:58Not applicable
Package_2_for_kb936460~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable2,01926-Apr-200715:58Not applicable
Update.mumNot applicable1,90926-Apr-200715:58Not applicable
Authui.dll6.0.6000.205862,270,72026-Apr-200704:14x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

If a password change violates the password policy requirements in the English version of Windows Vista, the user may receive an error message that is more informative. This error message resembles the following:
Unable to update the password. The value provided for the new password does not meet the length, complexity, or history requirement of the domain.
The "0xc000006c" status code represents the STATUS_PASSWORD_RESTRICTION status. This status indicates that the password change violates some password policy requirements. After you apply this hotfix on the Windows Vista-based client computer, the error message contains more information than only the status code. The information indicates that the user does not meet some password policy requirements when the user changes the password.

How to configure the password policy settings

To configure the password policy settings on a domain controller, follow these steps:
  1. Open the Active Directory Users and Computers snap-in.
  2. Right-click the domain name in question, and then click Properties.

    Note If the user is in a specific organizational unit, right-click the organizational unit, and then click Properties.
  3. Click the Group Policy tab, click the Default Domain Policy Group Policy object (GPO), and then click Edit.
  4. Expand Computer Configuration, expand Windows Settings, expand Security Settings, expand Account Policies, and then click Password Policy.
  5. Configure the related password policy.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 936460 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Ultimate
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB936460

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