Não pode instalar a funcionalidade de relatório do System Center Operations Manager 2007 num ambiente de espaço de nomes disjunto

Traduções de Artigos Traduções de Artigos
Artigo: 936481 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Não pode instalar a funcionalidade de relatório do Microsoft System Center Operations Manager 2007 num ambiente de espaço de nomes disjunto.

Além disso, as seguintes mensagens de erro são registadas no ficheiro MOMreporting.log:

mensagem 1
Propriedade (S): UnableToGetUserNameFromManagementServerActionAccount = erro SetPropertiesToManagementServerActionAndSDKAccountCA: System.DirectoryServices.ActiveDirectory.ActiveDirectoryObjectNotFoundException: O domínio especificado não existe ou não pode ser contactado. Propriedade (S): UnableToGetUserNameFromManagementServerSDKAccount = erro SetPropertiesToManagementServerActionAndSDKAccountCA: System.DirectoryServices.ActiveDirectory.ActiveDirectoryObjectNotFoundException: O domínio especificado não existe ou não pode ser contactado. MSI (s) (F4:E0) [TIME]: MainEngineThread is returning 1603
mensagem 2
TimeIP addressIP addressDNS de DNS: QueryId = 0xD8FD, QUERY (consulta padrão), o Query para _ldap._tcp. Domain Controller name. _sites.dc._msdcs. Primary Domain Name System suffix do tipo SRV na classe de Internet
Mensagem de 2 indica que um rastreio de rede está a consultar o registo SRV errado. O rastreio de rede, o servidor tenta contactar o seguinte site de serviço do directório do Active Directory:
Domain Controller name _ldap._tcp.. _sites.dc._msdcs. Primary Domain Name System suffix
No entanto, este é o registo SRV errado. Num ambiente se existe espaço de nomes disjunto, o nome do sistema de nomes de domínio (DNS, Domain Name System) do servidor não é o nome DNS do domínio.

Causa

Este problema ocorre porque o sufixo DNS primário do computador não coincide com o nome de domínio totalmente qualificado (FQDN, Fully Qualified Domain Name) do domínio no qual reside o computador.

Resolução

Informações sobre a correcção

Está disponível a partir da Microsoft uma correcção suportada. No entanto, esta correcção destina-se a corrigir o problema descrito neste artigo. Aplique esta correcção apenas em sistemas que tenham este problema específico. Esta correcção poderá submetida a testes adicionais. Por conseguinte, se não estiver a ser gravemente afectado por este problema, recomendamos que aguarde pela próxima actualização de software que contenha esta correcção.

Se a correcção está disponível para transferência, existe uma secção "denominada transferência de correcção disponível" na parte superior deste artigo da base de dados de conhecimento. Se esta secção não for apresentado, contacte o serviço de cliente do Microsoft e suporte para obter a correcção.

Nota Se ocorram problemas adicionais ou se for necessária qualquer resolução de problemas, poderá ter de criar um pedido de assistência separado. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem esta correcção específica. Para obter uma lista completa dos números de telefone do suporte de cliente do Microsoft ou para criar um pedido serviço separado, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota O formulário "Transferência de correcção disponível" apresenta os idiomas para a qual a correcção está disponível. Se não vir o idioma, é porque uma correcção não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisito de reinício

Não é necessário reiniciar o computador depois de aplicar esta correcção.

Informações sobre substituição de correcções

Esta correcção não substitui quaisquer outras correcções.

Instruções de instalação de correcções

Esta correcção têm de estar instalada em cada computador que cumpra qualquer um dos seguintes critérios:
  • O computador tem o System Center operações ' Gestor de ' relatório de Server.
  • O computador está a executar o System Center Operations Gestor raiz Management Server.
Para instalar esta correcção, utilize os seguintes dois procedimentos de separado. Efectue o procedimento primeiro na raiz Management Server (RMS). Execute o segundo procedimento em qualquer computador que actualiza o ficheiro Reporting2007.msi antes de utilizar este ficheiro .msi para a instalação do servidor de relatório.
  • passos de instalação para o servidor de gestão de raiz
    1. Copie o ficheiro SystemCenterOpsMgr07-RTM-KB9356481-X86-AMD64-ENU.MSI para uma pasta local ou com uma pasta de rede partilhada que está disponível para o RMS.
    2. Abra o ficheiro SystemCenterOpsMgr07-RTM-KB936481-X86-AMD64-ENU.MSI.
    3. Para instalar a correcção do RMS, conclua a instalação do ficheiro SystemCenterOpsMgr07-RTM-KB936481-X86-AMD64-ENU.MSI o RMS. A instalação MSI solicitará uma localização extrair a correcção, como a pasta "C:\Programas Files\System Center 2007 correcção utilitário". Seleccione o caminho predefinido ou outro caminho e anote a localização da instalação. Durante a instalação, serão extraídos os ficheiros de correcção para uma subpasta deste caminho com um nome de pasta do Q936841. Após a instalação, verá uma caixa de diálogo do System Center Operations Manager 2007 Software Update . Clique em Executar actualizações de software na caixa de diálogo quando estiver preparado para parar os serviços RMS e aplicar a actualização de software.
  • passos de instalação para qualquer computador que irá actualizar o ficheiro Reporting2007.msi numa cópia do suporte de dados

    Nota Se este computador for o RMS, conclua os passos 1 a 3 do procedimento primeiro e avance para o passo 3 deste procedimento.
    1. Copie o ficheiro SystemCenterOpsMgr07-RTM-KB9356481-X86-AMD64-ENU.MSI para uma pasta do disco rígido local.
    2. Execute o ficheiro SystemCenterOpsMgr07-RTM-KB936481-X86-AMD64-ENU.MSI para todos os utilizadores, mas não seleccione Executar o Software Update da caixa de diálogo System Center Operations Manager 2007 Software Update quando a instalação é concluída. Repare o caminho de instalação que for pedido durante a instalação.

      Nota O caminho de instalação normalmente é o seguinte:
      Programa utilitário de correcção Files\System Centro
    3. Utilize O Explorador do Windows para localizar a pasta de instalação de correcção que anotou no passo 3 do procedimento primeiro. Existirá uma série de subpastas na pasta Q936481\reporting_fix para x 86 e plataformas AMD64. Anote o caminho da pasta plataforma para a instalação de relatório que vai efectuar.
    4. Copie o ficheiro Reporting2007.msi da pasta plataforma adequada do suporte original do System Center Operations Manager 2007 para a pasta de platform Q936481\reporting_fix\.
    5. Abra uma linha de comandos e, em seguida, altere o directório de trabalho actual para Q936481\reporting_fix\ platform. Por exemplo, escreva o seguinte comando:
      CD c:\Programas\Microsoft Files\System Center Utility\Q936481\reporting_fix\x86 correcção 2007
    6. Para aplicar a transformação MSI, escreva o seguinte numa linha de comandos:
      WiUseXfm.vbs Reporting2007.msi ReportingXfm86.mst
    7. Para verificar uma instalação com êxito, verifique a última vez modificada do ficheiro Reporting2007.msi no Explorador do Windows.
    8. Depois da transformação MSI aplicação estiver concluída, copie o ficheiro Reporting2007.msi da pasta Q936481\reporting_fix\ platform para a pasta de platform reporting\ numa cópia do suporte original do System Center Operations Manager 2007. Se não consegue fazer porque o suporte de dados é só de leitura, pode instalar a correcção directamente do ficheiro reporting2007.msi modificado utilizando o seguinte comando:
      msiexec /i path of the modified .msi file \reporting2007.msi/l * v %TEMP%\MOMReporting.log
      Nota Aplicar a transformação MSI irá interromper a assinatura digital no ficheiro reporting2007.msi. Poderá receber o aviso sobre este problema antes de instalar a correcção. Com segurança é possível continuar a instalação.

Informações do ficheiro

A versão inglesa desta correcção tem os atributos de ficheiro (ou atributos de ficheiro posteriores) listados na seguinte tabela. As datas e horas destes ficheiros são indicadas na hora universal coordenada (UTC). Quando visualiza as informações do ficheiro, é convertido para a hora local. Para determinar a diferença entre a UTC e a hora local, utilize o separador fuso horário no item data e hora no painel de controlo.
O System Center Operations Manager 2007, 86 versão x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempo
Microsoft.EnterpriseManagement.OperationsManager.dll6.0.5000.22,166,78415 De Maio de 200721: 44
ReportingCAManaged.dll6.0.5000.2353,68015 De Maio de 200722: 25
ReportingCAManagedPac.dll1,250,97615 De Maio de 200723: 16
ReportingCAPack.dll 127,88815 De Maio de 200723: 16
O System Center Operations Manager 2007, versão de 64 x
Reduzir esta tabelaExpandir esta tabela
Nome de ficheiroVersão do ficheiroTamanho do ficheiroDataTempo
Microsoft.EnterpriseManagement.OperationsManager.dll6.0.5000.22,166,78415 De Maio de 200721: 44
ReportingCAManaged.dll6.0.5000.2353,68015 De Maio de 200722: 25
ReportingCAManagedPac.dll1,250,97615 De Maio de 200723: 16
ReportingCAPack.dll 127,88815 De Maio de 200723: 16

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".

Mais Informação

Para obter mais informações sobre a terminologia de actualização de software, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
824684Descrição da terminologia padrão utilizada para descrever actualizações de software da Microsoft

Propriedades

Artigo: 936481 - Última revisão: 15 de novembro de 2007 - Revisão: 4.3
A informação contida neste artigo aplica-se a:
  • Microsoft System Center Operations Manager 2007
  • Microsoft System Center Essentials 2007
Palavras-chave: 
kbmt kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbpubtypekc KB936481 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 936481

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com