Help and Support
 

powered byLive Search

Some Interix-related functions do not work, and you cannot open a command shell after you upgrade computers to Windows Server 2003 with Service Pack 2

Article ID:936529
Last Review:July 24, 2007
Revision:3.2
On This Page

SYMPTOMS

Consider the following scenario:
You have two or more computers in your organization that are running Microsoft Windows Server 2003 with Service Pack 1 (SP1).
These computers are also running Microsoft Windows Services for UNIX 3.5.
You upgrade computers to Microsoft Windows Server 2003 with Service Pack 2 (SP2).
In this scenario, the Password Synchronization component stops working, and some Interix-related functions do not work. Additionally, you cannot open the Interix Korn shell or the C shell. When this problem occurs, the following events are logged:

Event Type: Error
Event Source: Interix
Event ID: 1014
Description: Could not open registry key localhost: NtStatus : RPC: Port mapper failure - RPC: Unable to receive.

Event Type: Error
Event Source: SUA
Event ID: 1002
Description: The description for Event ID ( 1002 ) in Source ( SUA ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:

drive:\nt\base\sfu\interix\subsys\psxss\psxss.c: 284 Panic:registry value InstallRoot_Win not defined.

Event Type: Error
Event Source: SUA
Event ID: 1014
Description: The description for Event ID ( 1014 ) in Source ( SUA ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:

\Registry\Machine\Software\Microsoft\SUA, 0xc0000034.

Event Type: Error
Event Source: SUA
Event ID: 1
Description: The description for Event ID ( 1 ) in Source ( SUA ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:

The running psxss.exe file has the following version:

drive:\WINDOWS\system32\psxss.exe 9.0.3790.2825 566784 bytes AM

Event Type: Error
Event Source: NT to UNIX Password Sync Service
Event Category: None
Event ID: 16386
Description: Default encryption key is insecure. Please generate new encryption key.

Back to the top

CAUSE

This problem occurs because the installation program for Windows Server 2003 Service Pack 2 incorrectly replaces the Psxss.exe file from Windows Services for UNIX 3.5.

Back to the top

RESOLUTION

Update information

The following file is available for download from the Microsoft Download Center:

DownloadDownload the Update for Windows Server 2003 (KB936529) package now. (http://www.microsoft.com/downloads/details.aspx?FamilyId=7F4D264A-2D09-4832-9241-53A6EBC14119)

Release Date: July 24, 2007

For more information about how to download Microsoft support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591 (http://support.microsoft.com/kb/119591/) How to obtain Microsoft support files from online services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help prevent any unauthorized changes to the file.

Back to the top

Prerequisites

To apply this update, you must have the following products installed:
Windows Server 2003 Service Pack 2
Microsoft Windows Services for UNIX 3.5
Interix and Password Synchronization

Back to the top

Restart requirement

You must restart the computer after you apply this update.

Back to the top

Update replacement information

This update does not replace any other updates.

Back to the top

File information

The English version of this update has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Server 2003 with SP2, x86-based versions
File nameFile versionFile sizeDateTimePlatformSP requirement
Pswdsync.dll8.0.1969.5466,52828-Apr-200710:56x86SP2
Psxdll.dll8.0.1969.54246,60828-Apr-200710:56x86SP2
Psxdrv.sys8.0.1969.546,12824-Apr-200710:23x86SP2
Psxss.exe8.0.1969.54538,78424-Apr-200710:23x86SP2
Pswdsync.dll8.0.1969.5466,52828-Apr-200710:56x86SP2
Psxdll.dll8.0.1969.54246,60828-Apr-200710:56x86SP2
Psxdrv.sys8.0.1969.546,12824-Apr-200710:23x86SP2
Psxss.exe8.0.1969.54538,78424-Apr-200710:23x86SP2
Pswdsync.dll8.0.1969.5466,52828-Apr-200710:56x86SP2
Psxdll.dll8.0.1969.54246,60828-Apr-200710:56x86SP2
Psxdrv.sys8.0.1969.546,12824-Apr-200710:23x86SP2
Psxss.exe8.0.1969.54538,78424-Apr-200710:23x86SP2

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

For more information about the terms that are used to describe software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

Back to the top


APPLIES TO
Microsoft Windows Server 2003 Service Pack 2, when used with:
  Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)

Back to the top

Keywords: 
atdownload kbwinserv2003postsp2fix kbexpertiseinter kbqfe KB936529

Back to the top

Article Translations

 

Related Support Centers

Other Support Options

  • Need More Help?
    Contact a Support professional by E-mail, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.