Error message in Windows Vista when you use Registry Editor to load a registry hive file that is on a shared network resource: "Cannot load \\HivePath\filename: Access is denied"

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Article ID: 936756 - View products that this article applies to.
Important This article contains information about how to modify the registry. Make sure that you back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
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SYMPTOMS

On Windows Vista-based computer, you cannot use Registry Editor to load a registry hive file that is on a shared network resource. You receive the following error message:
Cannot load \\HivePath\FileName: Access is denied.
This problem occurs even if the user account that you use is granted Full Control permission to the registry hive file.

This problem also occurs if you use another utility to load a registry hive file that is on a shared network resource, and the utility uses the RegLoadKey API.

CAUSE

This problem occurs because of a design change in the RegLoadKey API in Windows Vista.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

Registry information

To use this hotfix, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
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File nameFile versionFile sizeDateTimePlatform
Update.mumNot applicable2,00410-Aug-200717:49Not applicable
X86_2ebb7f6aaa146a4c8881f0c616d547b8_31bf3856ad364e35_6.0.6000.20658_none_c4d8b768c453b437.manifestNot applicable69710-Aug-200717:49Not applicable
X86_microsoft-windows-os-kernel_31bf3856ad364e35_6.0.6000.20658_none_6aa5b093d03b7a87.manifestNot applicable18,77810-Aug-200717:49Not applicable
Ntkrnlpa.exe6.0.6000.206583,504,82410-Aug-200702:19Not applicable
Ntoskrnl.exe6.0.6000.206583,470,52010-Aug-200702:19Not applicable
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_0e4d201f04ccbd163b3fb054964fbecd_31bf3856ad364e35_6.0.6000.20658_none_77ff5b84569f5ec1.manifestNot applicable70110-Aug-200717:49Not applicable
Amd64_microsoft-windows-os-kernel_31bf3856ad364e35_6.0.6000.20658_none_c6c44c178898ebbd.manifestNot applicable17,33010-Aug-200718:06Not applicable
Update.mumNot applicable2,01610-Aug-200717:49Not applicable
Ntoskrnl.exe6.0.6000.206584,431,54410-Aug-200703:19x64

WORKAROUND

To work around this problem, copy the registry hive file to the local computer. Then, use Registry Editor to load the registry hive file.

STATUS

This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

How to load a remote registry hive file

  1. Click Start, type regedit in the Start Search box, and then click regedit.exe in the Programs list.
  2. Locate and then click one of the following keys:
    • HKEY_LOCAL_MACHINE
    • HKEY_USERS
  3. On the File menu, click Load Hive.
  4. Locate and then click the remote registry hive file, and then click Open.
  5. In the Load Hive dialog box, type a name in the Key Name box for the registry hive file that you want to load.
  6. Exit Registry Editor.
For more information about registry functions, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms724875.aspx
For more information about the RegLoadKey function, visit the following Microsoft Web site:
http://msdn2.microsoft.com/en-us/library/ms724889.aspx
For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 936756 - Last Review: October 8, 2011 - Revision: 3.0
APPLIES TO
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise 64-bit Edition
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbqfe kbhotfixserver KB936756

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