Mensagem de erro no Windows Vista ao usar o Editor do Registro para carregar um arquivo de hive do registro que está em um recurso de rede compartilhada: "não é possível carregar \\HivePath\filename: acesso negado"

Traduções deste artigo Traduções deste artigo
ID do artigo: 936756 - Exibir os produtos aos quais esse artigo se aplica.
importante Este artigo contém informações sobre como modificar o registro. Certifique-se de que você faça backup do registro antes de modificá-lo. Certifique-se que você sabe como restaurar o registro se ocorrer um problema. Para obter mais informações sobre como fazer backup, restaurar e modificar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

No computador baseado no Windows Vista, você não pode usar o Editor do Registro para carregar um arquivo de hive do registro que está em um recurso de rede compartilhada. Você receber a seguinte mensagem de erro:
Não é possível carregar \\ HivePath \ FileName: acesso negado.
Esse problema ocorre mesmo que a conta de usuário que você usa é concedida a permissão Controle total para o arquivo de hive do Registro.

Esse problema também ocorre se você usar outro utilitário para carregar um arquivo de hive do registro que está em um recurso de rede compartilhada, e o utilitário usa RegLoadKey API.

Causa

Esse problema ocorre devido a uma alteração de design no RegLoadKey API no Windows Vista.

Resolução

Informações sobre o service pack

Para resolver esse problema, obtenha o service pack mais recente para o Windows Vista. Para obter mais informações, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
935791Como obter o service pack mais recente do Windows Vista

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

Não pré-requisitos são necessários.

Requisitos de reinicialização

Você precisa reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações do registro

Para usar esse hotfix, não é necessário fazer alterações no registro.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos estão listadas no horário de universal coordenado (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário no item Data e hora no painel de controle.
Versões de 32 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Update.mumNão aplicável2,00410 De agosto de 200717: 49Não aplicável
X86_2ebb7f6aaa146a4c8881f0c616d547b8_31bf3856ad364e35_6.0.6000.20658_none_c4d8b768c453b437.manifestNão aplicável69710 De agosto de 200717: 49Não aplicável
X86_microsoft-windows-SO-kernel_31bf3856ad364e35_6.0.6000.20658_none_6aa5b093d03b7a87.manifestNão aplicável18,77810 De agosto de 200717: 49Não aplicável
Ntkrnlpa.exe6.0.6000.206583,504,82410 De agosto de 200702: 19Não aplicável
Ntoskrnl.exe6.0.6000.206583,470,52010 De agosto de 200702: 19Não aplicável
Versões de 64 bits do Windows Vista
Recolher esta tabelaExpandir esta tabela
Nome de arquivoVersão do arquivoTamanho do arquivoDataTempoPlataforma
Amd64_0e4d201f04ccbd163b3fb054964fbecd_31bf3856ad364e35_6.0.6000.20658_none_77ff5b84569f5ec1.manifestNão aplicável70110 De agosto de 200717: 49Não aplicável
Amd64_microsoft-windows-SO-kernel_31bf3856ad364e35_6.0.6000.20658_none_c6c44c178898ebbd.manifestNão aplicável17,33010 De agosto de 200718: 06Não aplicável
Update.mumNão aplicável2,01610 De agosto de 200717: 49Não aplicável
Ntoskrnl.exe6.0.6000.206584,431,54410 De agosto de 200703: 19x 64

Como Contornar

Para contornar esse problema, copie o arquivo de hive do Registro para o computador local. Em seguida, use o Editor do Registro para carregar o arquivo de hive do Registro.

Situação

Esse problema foi corrigido primeiro no Windows Vista Service Pack 1.

Mais Informações

Aviso Podem ocorrer sérios problemas se você modificar o registro incorretamente usando o Editor do registro ou usando outro método. Esses problemas podem exigir que você reinstalar o sistema operacional. A Microsoft não garante que esses problemas possam ser solucionados. Modificar o registro por sua própria conta e risco.

Como carregar um arquivo de hive de registro remoto

  1. Clique em Iniciar , digite regedit na caixa Iniciar procura e, em seguida, clique em regedit.exe na lista programas .
  2. Localize e, em seguida, clique em uma das seguintes chaves:
    • HKEY_LOCAL_MACHINE
    • HKEY_USERS
  3. No menu arquivo , clique em Carregar seção .
  4. Localize e clique em seguida, o arquivo de hive de registro remoto e, em seguida, clique em Abrir .
  5. Na caixa de diálogo Carregar seção , digite um nome na caixa Nome da chave para o arquivo de hive do registro que você deseja carregar.
  6. Feche o Editor do Registro.
Para obter mais informações sobre funções do Registro, visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/ms724875.aspx
Para obter mais informações sobre a função RegLoadKey , visite o seguinte site:
http://msdn2.microsoft.com/en-us/library/ms724889.aspx
Para obter mais informações sobre terminologia de atualização de software, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 936756 - Última revisão: sexta-feira, 16 de maio de 2008 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Windows Vista Home Premium
  • Windows Vista Ultimate
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Premium 64-bit edition
  • Windows Vista Ultimate 64-bit edition
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise 64-bit edition
Palavras-chave: 
kbmt kbautohotfix kbvistasp1fix kbexpertiseadvanced kbfix kbpubtypekc kbqfe kbhotfixserver KB936756 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 936756

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com