ターミナル サービス セッションでの作業中に 2007 Office プログラムのドキュメントをリダイレクトされたドライブに保存するとエラー メッセージ "ネットワークまたはファイル アクセス権のエラーです" が表示される

文書翻訳 文書翻訳
文書番号: 936970 - 対象製品
すべて展開する | すべて折りたたむ

目次

現象

リモート デスクトップ接続 6.0 によって開始されたターミナル サービス セッションで作業しているときに 2007 Microsoft Office プログラムのドキュメントをリダイレクトされたドライブに保存しようとすると、次のエラー メッセージが表示されます。
ネットワークまたはファイル アクセス権のエラーです。ネットワーク接続が取り消された可能性があります。
(\\tsclient\Path\FileName.docx)
そのため、2007 Office ドキュメントをリダイレクトされたドライブに保存できません。

Windows Vista には、既定でリモート デスクトップ接続 6.0 コンポーネントが含まれています。リモート デスクトップ接続 6.0 コンポーネントは、Windows XP または Windows Server 2003 に手動でインストールすることもできます。

  • このエラー メッセージで、Path\FileName.docx は保存しようとしたドキュメントのパスおよび名前です。
  • リダイレクトされたドライブは、ターミナル サービス セッションでリダイレクトされるローカル コンピュータ上のドライブです。リダイレクトされたドライブによって、ローカル ホストとリモート コンピュータの間で簡単にファイルを転送できるようになります。

原因

この問題は、2007 Microsoft Office プログラムとリモート デスクトップ接続 6.0 コンポーネントとの間で、ファイルを保存するロジックに競合があるために発生します。

2007 Microsoft Office プログラムのドキュメントを保存しようとすると、プログラムによりドキュメント ファイルは一時的な名前を使用してディスクに保存され、次にその一時ファイルの名前が変更されます。ただし、ファイルを閉じようとしても、リモート デスクトップ接続 6.0 コンポーネントはすぐにファイルを閉じることができません。このため、2007 Microsoft Office プログラムでは一時ファイルの名前を変更できず、ドキュメントを保存できません。

解決方法

Service Pack の情報

この問題を解決するには、Windows Vista の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
935791 最新の Windows Vista Service Pack を入手する方法

修正プログラムの情報

マイクロソフトでは、この問題を修正する修正プログラムを提供しています。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、ここで説明する問題が発生しているシステムにのみ適用してください。この修正プログラムは、今後さらにテストを行う場合があります。したがって、この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことを推奨します。

修正プログラムをダウンロードできる場合は、この「サポート技術情報」 (Microsoft Knowledge Base) の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、Microsoft Customer Service and Support にお問い合わせのうえ、修正プログラムを入手してください。

: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成することが必要になる場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。Microsoft Customer Service and Support の電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
:「ダウンロード」フォームには、修正プログラムを入手できる言語が表示されます。使用している言語が表示されない場合は、その言語の修正プログラムが存在しないことになります。

必要条件

以下のオペレーティング システムを実行しているコンピュータに RDP 6.0 をインストールする必要があります。
  • Windows XP Service Pack 2 (SP2)
  • Windows Server 2003 Service Pack 1 (SP1) およびそれ以降のバージョン

再起動の要件

この修正プログラムを適用した後に、コンピュータを再起動する必要はありません。

修正プログラムの置き換えに関する情報

この修正プログラムを適用しても、他の修正プログラムが置き換えられることはありません。

ファイル情報

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。これらのファイルの日付と時刻は世界協定時刻 (UTC) で表示されます。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
Windows Vista (32 ビット版)
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatform
Update.mumNot Applicable1,80615-May-200711:12Not Applicable
X86_c80cdcebb100c4200b8a72d5440a7db1_31bf3856ad364e35_6.0.6000.20598_none_c7686a7ceefb34ff.manifestNot Applicable72215-May-200711:12Not Applicable
X86_microsoft-windows-t..s-clientactivexcore_31bf3856ad364e35_6.0.6000.20598_none_2e381519e1e11139.manifestNot Applicable168,92015-May-200711:14Not Applicable
Aaclient.dll6.0.6000.20598116,73615-May-200702:18x86
Aaclient.mofNot Applicable1,09707-Jan-200705:26Not Applicable
Mstscax.dll6.0.6000.205981,865,72815-May-200702:20x86
Mstscax.mofNot Applicable1,96707-Jan-200705:26Not Applicable
Tsgqec.dll6.0.6000.2059836,35215-May-200702:21x86
Windows Vista (64 ビット版)
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatform
Amd64_fb56ff8a0a8e92962d7b23ce65dab37e_31bf3856ad364e35_6.0.6000.20598_none_efe6a35fe754e48a.manifestNot Applicable1,09215-May-200711:12Not Applicable
Amd64_microsoft-windows-t..s-clientactivexcore_31bf3856ad364e35_6.0.6000.20598_none_8a56b09d9a3e826f.manifestNot Applicable168,98215-May-200711:19Not Applicable
Update.mumNot Applicable2,05615-May-200711:12Not Applicable
Aaclient.dll6.0.6000.20598130,04815-May-200703:21x64
Aaclient.mofNot Applicable1,09707-Jan-200705:26Not Applicable
Mstscax.dll6.0.6000.205982,187,77615-May-200703:23x64
Mstscax.mofNot Applicable1,96707-Jan-200705:26Not Applicable
Tsgqec.dll6.0.6000.2059827,64815-May-200703:24x64
Windows XP
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatform
Lhmstscx.dll6.0.6000.206121,866,24003-Jul-200714:39x86
Windows Server 2003 SP1 (x86 ベース)
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatform
Lhmstscx.dll6.0.6000.206121,866,24004-Jul-200708:02x86
Windows Server 2003 SP2 (x86 ベース)
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatform
Lhmstscx.dll6.0.6000.206121,866,24004-Jul-200708:21x86
Windows Server 2003 SP1 (x64 ベース)
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Lhmstscx.dll6.0.6000.206122,188,28803-Jul-200717:41x64SP1Not Applicable
Wlhmstscx.dll6.0.6000.206121,866,24003-Jul-200717:41x86SP1WOW
Windows Server 2003 SP2 (x64 ベース)
元に戻す全体を表示する
File nameFile versionFile sizeDateTimePlatformSP requirementService branch
Lhmstscx.dll6.0.6000.206122,188,28803-Jul-200717:48x64SP2Not Applicable
Wlhmstscx.dll6.0.6000.206121,866,24003-Jul-200717:48x86SP2WOW

回避策

この問題を回避するには、ターミナル サーバーのディスクにファイルを保存します。その後で、リダイレクトされたドライブにファイルを移動します。

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。 この問題は、Windows Vista Service Pack 1 で修正済みです。

詳細

この修正プログラムによって解決されるリモート デスクトップ接続 6.0 の問題の詳細を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
938080 Windows Vista ベースのコンピュータ上のリモート デスクトップ ウィンドウのターミナル サービス セッションでキー入力の一部がそれ以前のキーボード ショートカットの一部分として解釈される (英語)
関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

プロパティ

文書番号: 936970 - 最終更新日: 2008年9月18日 - リビジョン: 4.1
この資料は以下の製品について記述したものです。
  • Windows Vista Business
  • Windows Vista Business 64-bit edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit edition
  • Windows Vista Ultimate
  • Windows Vista Ultimate 64-bit edition
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows XP Professional
キーワード:?
kbautohotfix kbvistasp1fix kbwinvistapostrtmfix kbexpertiseinter kbhotfixserver kbqfe KB936970
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com