The Perfmon.exe process may continuously start and stop when you click the "Resource Monitor" button on a Windows Vista-based computer

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Article ID: 937085 - View products that this article applies to.
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SYMPTOMS

On a Windows Vista-based computer, you click the Resource Monitor button. Then, the Performance Monitor (Perfmon.exe) process may continuously start and stop. Additionally, Windows Vista may stop responding.

Note You click the Resource Monitor button to display the utilization details for the CPU, for memory, for the disk, and for the network.

Steps to reproduce the problem

  • You log on to a Windows Vista-based computer by using an account that has administrator credentials.
  • You disable the User Account Control (UAC) feature.
  • You log on to the Windows Vista-based computer on which UAC has been disabled. Additionally, you use an account that does not have administrator credentials.
  • On the Performance tab of the Windows Task Manager dialog box, you click the Resource Monitor button.

CAUSE

This problem occurs because Perfmon.exe uses the ShellExecuteEx function. However, the ShellExecuteEx function cannot use the Runas command correctly if the UAC feature is disabled.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 How to obtain the latest Windows Vista service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other previously released hotfixes.

Registry information

To use one of the hotfixes in this package, you do not have to make any changes to the registry.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, 32-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pdhui.dll6.0.6000.2059446,08009-May-200708:51x86
Perfmon.exe6.0.6000.20594120,32009-May-200707:24x86
Sysmon.ocx6.0.6000.20594389,63209-May-200708:51x86
Wdc.dll6.0.6000.205941,019,90409-May-200708:52x86
Wvc.dll6.0.6000.20594456,70409-May-200708:52x86
Windows Vista, 64-bit versions
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Pdhui.dll6.0.6000.2059458,88009-May-200709:49x64
Perfmon.exe6.0.6000.20594124,92809-May-200707:44x64
Sysmon.ocx6.0.6000.20594475,64809-May-200709:50x64
Wdc.dll6.0.6000.205941,243,64809-May-200709:50x64
Wvc.dll6.0.6000.20594614,40009-May-200709:50x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Command-line parameters

For more Information about the command-line parameters for Windows Reliability and Performance Monitor, visit the following Microsoft Web site:
http://technet2.microsoft.com/WindowsVista/en/library/9a8d5eca-8473-463e-a6e0-7bbd590b18e11033.mspx?mfr=true

The /noelev parameter

The /noelev parameter is a new parameter for Windows Reliability and Performance Monitor. You can run the perfmon /noelev command to display the utilization details for the CPU, for memory, for the disk, and for the network. However, this parameter does not add any new functionality.

Properties

Article ID: 937085 - Last Review: October 8, 2011 - Revision: 4.0
APPLIES TO
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Ultimate 64-bit Edition
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Ultimate Beta
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows Vista Business
Keywords: 
kbautohotfix kbvistasp1fix kbexpertiseinter kbfix kbHotfixServer kbqfe KB937085

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