Rendimiento es deficiente en una aplicación basada en WPF en el que haya habilitado ventanas por capas en Windows XP o en Windows Server 2003

Seleccione idioma Seleccione idioma
Id. de artículo: 937106 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Un equipo tiene Microsoft .NET Framework 3.0 instalado. En una aplicación que está basada en Windows Presentation Foundation (WPF), habilita ventanas por capas estableciendo el valor de la Windows.AllowsTransparency ventanas propiedad en TRUE. En esta configuración, el rendimiento de la aplicación basada en WPF es deficiente. Además, puede observar los problemas siguientes:
  • Animación tiemble
  • Velocidad inferior
  • Uso de CPU elevado

Causa

Esto ocurre porque en capas de windows habilita los efectos de transparencia de la ventana de nivel superior. Las aplicaciones basadas en WPF representar gráficos utilizando la canalización de DirectX. En DirectX 9.0c, el método IDirect3DSurface9::GetDC no admite efectos de transparencia que utilice un canal alfa. Por lo tanto, gráficos que representa una aplicación basada en WPF no están acelerado por hardware. En su lugar, la aplicación procesa gráficos en el nivel de software. En esta situación, la aplicación realiza mal y utiliza una proporción alta de tiempo de CPU.

Nota DirectX 9.0c se incluye con Microsoft Windows XP con Service Pack 2 con Microsoft Windows Server 2003 con Service Pack 1 y con Windows Server 2003 con Service Pack 2.

Solución

Información de revisiones

Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
No se necesita ningún requisito previo.
Requisito de reinicio
No es necesario reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataforma
D3d9.dll5.3.2600.31331,689,08807-Mayo de 200713: 49x 86

Windows Server 2003

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.
Requisitos previos
Para aplicar este hotfix, debe tener Windows Server 2003 Service Pack 1 o Windows Server 2003 Service Pack 2 instalado.
Requisito de reinicio
No es necesario reiniciar el equipo después de aplicar este hotfix.
Información acerca de la sustitución de la revisión
Este hotfix no sustituye a otros hotfix.
Información de archivo
La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria el elemento fecha y hora en el panel de control.

Windows Server 2003, versiones basadas en 86 en x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
D3d9.dll5.3.3790.29431,690,62425 De mayo de 200706: 24x 86SP1SP1QFE
D3d9.dll5.3.3790.40871,690,62425 De mayo de 200705: 03x 86SP2SP2QFE
Windows Server 2003, versiones de 64 de x
Contraer esta tablaAmpliar esta tabla
Nombre de archivoArchivo VersiónTamaño de archivoFechaTiempoPlataformaRequisito de SPTipo de servicio
D3d9.dll5.3.3790.29432,098,17624 De mayo de 200715: 42x 64SP1SP1QFE
Wd3d9.dll5.3.3790.29431,690,62424 De mayo de 200715: 42x 86SP1GUAU
D3d9.dll5.3.3790.40872,098,17624 De mayo de 200715: 57x 64SP2SP2QFE
Wd3d9.dll5.3.3790.40871,690,62424 De mayo de 200715: 57x 86SP2GUAU

Solución

Para evitar este problema, deshabilite ventanas por capas en las aplicaciones basadas en WPF.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Aplíquela sólo a equipos en que las aplicaciones basadas en WPF no debe utilizar aceleración de hardware para representar gráficos.

Si establece la calidad del color en Media (16 bits) en el cuadro de diálogo Propiedades de pantalla , puede disminuir el rendimiento de determinados controladores de vídeo en ventanas superpuestas. Para evitar este problema, establezca la calidad del color en más alta (32 bits) .

Propiedades

Id. de artículo: 937106 - Última revisión: jueves, 11 de octubre de 2007 - Versión: 2.4
La información de este artículo se refiere a:
  • Microsoft Windows Server 2003 Service Pack 2 sobre las siguientes plataformas
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
    • Microsoft Windows Server 2003, Standard x64 Edition
    • Microsoft Windows Server 2003, Enterprise x64 Edition
    • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003 Service Pack 1 sobre las siguientes plataformas
    • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
    • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
    • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows XP Service Pack 2 sobre las siguientes plataformas
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Media Center Edition
Palabras clave: 
kbmt kbautohotfix kbwinxppresp3fix kbwinserv2003postsp2fix kbfix kbhotfixserver kbqfe kbexpertiseinter KB937106 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 937106

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com