Fehlermeldung oder hohe CPU-Auslastung beim Ausführen einer Windows Presentation Foundation WPF-basierten Anwendungs

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 937135 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Wenn Sie eine Windows Presentation Foundation WPF-basierte Anwendung in der Microsoft-.NET Framework 3.0 ausführen, erhalten Sie eine FileFormatException-Fehler oder ein ArgumentOutofRangeException-Fehler. Der Fehler tritt auf, wenn die WPF-basierte Anwendung gestartet wird, um Text zu verarbeiten. Sie können z. B. eine FileFormatException-Fehlermeldung angezeigt, die der folgenden ähnelt:
File:///FilePath/Dateiname Datei entspricht nicht der erwarteten Dateiformatspezifikation.
In dieser Fehlermeldung Dateiname ist in der Regel der Dateinamen für eine Schriftart. Die Anwendung wird darüber hinaus bis zu 100 Prozent CPU-Zeit verbraucht.


Wenn Sie im Task-Manager oder andere Tools suchen, verbraucht PresentationFontCache.exe verfügbare CPU-Zeit von mindestens 50 %.

Ursache

Dieses Problem tritt auf, wenn der Treiber die Daten im Cache Schriftart überschreiben, die im Arbeitsspeicher gespeichert wird.

Lösung

Um dieses Problem zu beheben, gehen Sie folgendermaßen vor:
  1. Beenden Sie alle WPF-basierte Anwendungen, die auf dem Computer ausgeführt werden.
  2. Beenden Sie Windows Presentation Foundation Schriftartcache 3.0.0.0-Dienst. Verwenden Sie eine der folgenden Methoden, um den Windows Presentation Foundation Schriftartcache 3.0.0.0-Dienst zu beenden.

    Methode 1: Verwenden Sie Microsoft Management Console
    1. Klicken Sie auf Start, klicken Sie auf Führen Sie, Typ Services.msc, und klicken Sie dann auf OK.
    2. Mit der rechten Maustaste Windows Presentation Foundation Schriftartcache 3.0.0.0, und klicken Sie dann auf Beenden.
    Methode 2: Verwenden der Eingabeaufforderung den Befehl
    1. Klicken Sie auf Start, klicken Sie auf Führen Sie, Typ cmd, und klicken Sie dann auf OK.
    2. Geben Sie an der Eingabeaufforderung den Befehl NET Stop "Windows Presentation Foundation Schriftartcache 3.0.0.0", und drücken Sie dann die EINGABETASTE.
  3. Löschen Sie die alte Fontcache3.0.0.0.dat-Datei.

    Hinweis Die Datei Fontcache3.0.0.0.dat befindet sich standardmäßig im Ordner "%windir%\ServiceProfiles\LocalService\AppData\Local" in Windows Vista. Die Datei Fontcache3.0.0.0.dat befindet sich standardmäßig im Verzeichnis %SystemDrive%\Dokumente und LocalService Einstellungen\anwendungsdaten Ordner in Windows XP und früheren Versionen von Windows.
  4. Aktualisieren Sie den Grafikkartentreiber. Verwenden Sie hierzu eine der folgenden Methoden.

    Methode 1: Verwenden Sie Windows Update-Katalog

    Um den Grafikkartentreiber aktualisieren, überprüfen Sie auf Updates in Windows Update-Katalog. Weitere Informationen dazu, wie Sie Treiber von Windows Update-Katalog herunterladen klicken Sie auf die folgende Artikelnummer klicken, um den Artikel in der Microsoft Knowledge Base anzuzeigen:
    323166Gewusst wie: Downloaden von Updates und Treibern aus dem Windows Update-Katalog

    Methode 2: Unterladen Sie her und installieren Sie die neuesten Grafikkartentreiber

    Zum Herunterladen und Installieren der neuesten Treiber, wenden Sie sich an den Hersteller des Computers oder der video-Hardware.

    Informationen über den Hardwarehersteller finden Sie auf den folgenden Website:
    http://support.Microsoft.com/GP/Vendors/en-US

Weitere Informationen

Der Treiber die Daten im Cache Schriftart überschreiben, die im Arbeitsspeicher gespeichert wird, können die beschädigten Daten als eine Datendatei auf der Festplatte gespeichert werden. Aus diesem Grund kann das Problem auftreten, das im Abschnitt "Problembeschreibung" beschrieben wird, wenn eine andere WPF-basierte Anwendung versucht, die beschädigte Datei zu lesen.

Nachdem Sie den Grafikkartentreiber aktualisieren und eine neue Schriftart-Cache-Datendatei, nachdem Sie die Datei Fontcache3.0.0.0.dat zu löschen erstellt wird, basierend auf der neuen Computerkonfiguration. Diese neue Schriftart-Cache-Datendatei wird erstellt, wenn der Windows Presentation Foundation Schriftartcache 3.0.0.0-Dienst beendet wird. In der Regel wird die neue Schriftart-Cache-Datendatei erstellt, wenn der Computer heruntergefahren oder neu gestartet wird.

Eigenschaften

Artikel-ID: 937135 - Geändert am: Donnerstag, 13. September 2012 - Version: 1.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft .NET Framework 3.0
Keywords: 
kbbug kbtshoot kbprb kbmt KB937135 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 937135
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com