Mensagem de erro ou de alta utilização da CPU ao executar um aplicativo baseado no WPF de Windows Presentation Foundation

Traduções de Artigos Traduções de Artigos
Artigo: 937135 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Quando você executar um aplicativo baseado no WPF de Windows Presentation Foundation no.NET Framework Microsoft 3.0, você pode receber um erro FileFormatException ou um ArgumentOutofRangeException. O erro ocorre quando inicia o aplicativo baseado no WPF processar texto. Por exemplo, você pode receber uma mensagem de erro FileFormatException semelhante à seguinte:
arquivo:///FilePath/nome_do_arquivo arquivo não segue a especificação de formato de arquivo esperada.
Na mensagem de erro, nome_do_arquivo normalmente é o nome do arquivo para uma fonte. Além disso, o aplicativo consome até ao tempo de CPU de 100 por cento.


Ao procurar no Gerenciador de tarefas ou outras ferramentas, PresentationFontCache.exe consome 50% ou mais de tempo do processador disponível.

Causa

Esse problema ocorre se os drivers de vídeo sobrescrever os dados no cache de fonte é armazenado na memória.

Resolução

Para resolver esse problema, siga estas etapas:
  1. Feche todos os aplicativos baseados em WPF executam no computador.
  2. Pare o serviço de Cache de fonte de Windows Presentation Foundation 3.0.0.0. Para parar o serviço de Cache de fonte de Windows Presentation Foundation 3.0.0.0, use um dos seguintes métodos.

    Método 1: Usar o Console de gerenciamento Microsoft
    1. Clique em Iniciar, clique em Executar, tipo Services. msce clique em OK.
    2. Com o botão direito Windows Presentation Foundation Font Cache 3.0.0.0e clique em Parar.
    Método 2: Usar o prompt de comando
    1. Clique em Iniciar, clique em Executar, tipo cmde clique em OK.
    2. No prompt de comando, digite: NET stop "Windows Presentation Foundation Font Cache 3.0.0.0", e pressione ENTER.
  3. Exclua o arquivo antigo Fontcache3.0.0.0.dat.

    Observação Por padrão, o arquivo Fontcache3.0.0.0.dat exe está localizado na pasta %windir%\ServiceProfiles\LocalService\AppData\Local no Windows Vista. Por padrão, o arquivo Fontcache3.0.0.0.dat exe está localizado na pasta Settings\LocalService\Local Settings\Application Data no Windows XP e em versões anteriores do Windows %systemdrive%\Documents and.
  4. Atualize os drivers de placa de vídeo. Para isso, use um dos seguintes métodos.

    Método 1: Usar o catálogo do Windows Update

    Para atualizar os drivers de placa de vídeo, verificar atualizações no catálogo do Windows Update. Para obter mais informações sobre como baixar os drivers do Windows Update, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
    323166Como baixar atualizações e drivers do catálogo do Windows Update

    Método 2: Baixe e instale os drivers mais recentes da placa de vídeo

    Para baixar e instalar os drivers mais recentes da placa de vídeo, contate o fabricante do hardware de vídeo ou computador.

    Para obter informações sobre o fabricante do hardware, visite o seguinte site:
    http://support.microsoft.com/gp/Vendors/en-US

Mais Informação

Se os drivers de placa de vídeo sobrescrevem os dados no cache de fonte é armazenado na memória, dados corrompidos poderão ser salvas no disco rígido como um arquivo de dados. Portanto, você pode enfrentar o problema descrito na seção "Sintomas" quando outro aplicativo baseado no WPF tenta ler o arquivo de dados corrompido.

Após você atualizar os drivers de placa de vídeo e depois excluir o arquivo Fontcache3.0.0.0.dat, um novo arquivo de dados do cache de fonte é criado com base na nova configuração do computador. Esse novo arquivo de dados do cache de fonte é criado quando o serviço de Cache de fonte de Windows Presentation Foundation 3.0.0.0 é interrompido. Normalmente, o novo arquivo de dados do cache de fonte é criado quando o computador é desligado ou reiniciado.

Propriedades

Artigo: 937135 - Última revisão: 13 de setembro de 2012 - Revisão: 1.0
A informação contida neste artigo aplica-se a:
  • Microsoft .NET Framework 3.0
Palavras-chave: 
kbbug kbtshoot kbprb kbmt KB937135 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 937135

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com