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After you configure Internet Connection Sharing in Windows Vista, the network connection stops working after one-to-two hours

Article ID:937168
Last Review:May 16, 2008
Revision:4.1
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SYMPTOMS

After you configure Internet Connection Sharing in Windows Vista, you may find that, although the network connection works correctly at first, the network connection stops working after one-to-two hours. For example, you may be unable to connect to the Internet, to other computers on the local area network (LAN), or to network resources on the LAN.

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CAUSE

This problem occurs because of a bug in the WinSock bind() function.

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RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Vista. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
935791 (http://support.microsoft.com/kb/935791/) How to obtain the latest Windows Vista service pack

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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
Windows Vista, x86-based versions
File nameFile versionFile sizeDateTimePlatform
Netio.sys6.0.6000.20597217,27212-May-200702:20x86
Update.mumNot applicable2,21814-May-200718:11Not applicable
X86_6f3afd5a63c97fc8c8030ef47028c44f_31bf3856ad364e35_6.0.6000.20597_none_e9c22ebd978f6a2c.manifestNot applicable1,04514-May-200718:11Not applicable
X86_microsoft-windows-netio-infrastructure_31bf3856ad364e35_6.0.6000.20597_none_54e479e8d18748c4.manifestNot applicable4,16214-May-200718:14Not applicable
X86_microsoft-windows-tcpip_31bf3856ad364e35_6.0.6000.20597_none_5fcea2efab936c1d.manifestNot applicable30,54014-May-200718:14Not applicable
Netiomig.dll6.0.6000.2059749,15212-May-200702:16x86
Netiougc.exe6.0.6000.2059722,01612-May-200701:30x86
Tcpip.sys6.0.6000.20597803,84012-May-200701:31x86
Tcpipcfg.dll6.0.6000.20597167,42412-May-200702:16x86
Windows Vista, 64-bit versions
File nameFile versionFile sizeDateTimePlatformService branch
Amd64_4f6a2dedb1c9dc859126b4d90b662383_31bf3856ad364e35_6.0.6000.20597_none_fe3288adb6197e2e.manifestNot applicable1,05114-May-200718:11Not applicableNot applicable
Amd64_93e9311ca92486efb11966358a7390cc_31bf3856ad364e35_6.0.6000.20597_none_1c92da281782d392.manifestNot applicable1,05114-May-200718:11Not applicableNot applicable
Amd64_microsoft-windows-netio-infrastructure_31bf3856ad364e35_6.0.6000.20597_none_b103156c89e4b9fa.manifestNot applicable4,17014-May-200718:20Not applicableNot applicable
Amd64_microsoft-windows-tcpip_31bf3856ad364e35_6.0.6000.20597_none_bbed3e7363f0dd53.manifestNot applicable30,61014-May-200718:20Not applicableNot applicable
Netio.sys6.0.6000.20597324,79212-May-200703:34x64Not applicable
Package_1_for_kb937168~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable2,01414-May-200718:11Not applicableNot applicable
Package_2_for_kb937168~31bf3856ad364e35~amd64~~6.0.1.0.mumNot applicable2,23114-May-200718:11Not applicableNot applicable
Update.mumNot applicable2,21814-May-200718:11Not applicableNot applicable
Wow64_microsoft-windows-netio-infrastructure_31bf3856ad364e35_6.0.6000.20597_none_bb57bfbebe457bf5.manifestNot applicable2,73012-May-200702:29Not applicableNot applicable
Wow64_microsoft-windows-tcpip_31bf3856ad364e35_6.0.6000.20597_none_c641e8c598519f4e.manifestNot applicable24,29714-May-200718:20Not applicableNot applicable
Netiomig.dll6.0.6000.2059759,90412-May-200703:29x64Not applicable
Netiougc.exe6.0.6000.2059725,60012-May-200701:58x64Not applicable
Tcpip.sys6.0.6000.205971,193,47212-May-200701:59x64Not applicable
Tcpipcfg.dll6.0.6000.20597232,96012-May-200703:30x64Not applicable
Netiomig.dll6.0.6000.2059749,15212-May-200702:16x86WOW64_MICROSOFT-WINDOWS-TCPIP_31BF3856AD364E35_6.0.6000.20597_NONE_C641E8C598519F4E
Netiougc.exe6.0.6000.2059722,01612-May-200701:30x86WOW64_MICROSOFT-WINDOWS-TCPIP_31BF3856AD364E35_6.0.6000.20597_NONE_C641E8C598519F4E
Tcpipcfg.dll6.0.6000.20597167,42412-May-200702:16x86WOW64_MICROSOFT-WINDOWS-TCPIP_31BF3856AD364E35_6.0.6000.20597_NONE_C641E8C598519F4E

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Windows Vista Service Pack 1.

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MORE INFORMATION

To verify whether Windows Vista is using Internet Connection Sharing, follow these steps:
1.Click Start Start button , type Services.msc in the Start Search box, and then click Services.msc in the Programs list.

 User Account Control permission If you are prompted for an administrator password or for confirmation, type your password, or click Continue.
2. Find the Internet Connection Sharing (ICS) service in the Name column, and then examine the status for the service in the Status Column. Windows Vista is using Internet Connection Sharing if the Status column for the service shows Started.
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Windows Vista Ultimate
Windows Vista Enterprise
Windows Vista Business
Windows Vista Home Premium
Windows Vista Home Basic
Windows Vista Starter
Windows Vista Ultimate 64-bit Edition
Windows Vista Enterprise 64-bit Edition
Windows Vista Business 64-bit Edition
Windows Vista Home Premium 64-bit Edition

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Keywords: 
kbautohotfix kbvistasp1fix kbbug kbfix kbhotfixserver kbqfe kbexpertiseinter kbwinvistapostrtmfix KB937168

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